aboutsummaryrefslogtreecommitdiff
path: root/sysutils/x86info
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2012-02-28 17:50:17 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2012-02-28 17:50:17 +0000
commit21f0b83c41dcc6c82dfbaf2a8fd745de4804027a (patch)
tree0a4f95ace02b0d4ab3597124a07b733e5f1df32d /sysutils/x86info
parent6174e64fb195c6080a96b8bd3d1f61f95a2ff5fc (diff)
downloadports-21f0b83c41dcc6c82dfbaf2a8fd745de4804027a.tar.gz
ports-21f0b83c41dcc6c82dfbaf2a8fd745de4804027a.zip
Notes
Diffstat (limited to 'sysutils/x86info')
-rw-r--r--sysutils/x86info/Makefile25
-rw-r--r--sysutils/x86info/files/patch-Makefile10
2 files changed, 13 insertions, 22 deletions
diff --git a/sysutils/x86info/Makefile b/sysutils/x86info/Makefile
index 5871ee9bb6f6..2ffcf31a84c5 100644
--- a/sysutils/x86info/Makefile
+++ b/sysutils/x86info/Makefile
@@ -1,6 +1,6 @@
# New ports collection makefile for: x86info
-# Date created: 26 Aug 2001
-# Whom: Erik Greenwald <erik@smluc.org>
+# Date created: 26 Aug 2001
+# Whom: Erik Greenwald <erik@smluc.org>
#
# $FreeBSD$
#
@@ -8,37 +8,28 @@
PORTNAME= x86info
PORTVERSION= 1.30
CATEGORIES= sysutils
-MASTER_SITES= http://codemonkey.org.uk/projects/x86info/%SUBDIR%/
-MASTER_SITE_SUBDIR= . old
+MASTER_SITES= http://codemonkey.org.uk/projects/x86info/
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-COMMENT= Utility to display information about the systems x86 processor(s)
+COMMENT= An x86 CPU identification utility
LICENSE= GPLv2
-ONLY_FOR_ARCHS= i386 amd64
-
LIB_DEPENDS= pci.3:${PORTSDIR}/devel/libpci
-USE_GNOME= pkgconfig
-USE_PYTHON_BUILD=yes
+ONLY_FOR_ARCHS= i386 amd64
+
USE_GMAKE= yes
ALL_TARGET= x86info lsmsr
+USE_GNOME= pkgconfig
+USE_PYTHON_BUILD=yes
MAKE_JOBS_SAFE= yes
MAN1= x86info.1
MAN8= lsmsr.8
PLIST_FILES= bin/lsmsr bin/x86info
-post-patch:
- @${REINPLACE_CMD} -e \
- '/^CFLAGS/s| =| +=|g ; \
- /^CFLAGS/s| -g|| ; \
- /^CFLAGS/s| -O2|| ; \
- /^CFLAGS/s| -Werror|| ; \
- /^CC/s| =| ?=|' ${WRKSRC}/Makefile
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 701102
diff --git a/sysutils/x86info/files/patch-Makefile b/sysutils/x86info/files/patch-Makefile
index 4ad8193f2628..c9b2f2771fbc 100644
--- a/sysutils/x86info/files/patch-Makefile
+++ b/sysutils/x86info/files/patch-Makefile
@@ -1,17 +1,17 @@
--- Makefile.orig 2011-09-15 15:43:52.000000000 -0700
+++ Makefile 2011-09-15 15:44:01.000000000 -0700
-@@ -1,8 +1,9 @@
- VERSION=1.29
+@@ -1,8 +1,8 @@
+ VERSION=1.30
- CFLAGS = -g -O2 -Werror -Wall -Wshadow -Wextra -Wmissing-declarations -Wdeclaration-after-statement -Wredundant-decls
-+CFLAGS+= `pkg-config --cflags libpci`
+-CFLAGS = -g -O2 -Werror -Wall -Wshadow -Wextra -Wmissing-declarations -Wdeclaration-after-statement -Wredundant-decls
++CFLAGS += -Wall -Wshadow -Wextra -Wmissing-declarations -Wdeclaration-after-statement -Wredundant-decls `pkg-config --cflags libpci`
LDFLAGS = -Wl,-z,relro,-z,now
-CC = gcc
+CC ?= gcc
SHELL = /bin/sh
-@@ -88,7 +89,7 @@
+@@ -91,7 +91,7 @@
X86INFO_OBJS = $(X86INFO_SRC:%.c=%.o)
x86info: $(X86INFO_OBJS)