aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xen-tools
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-04-06 14:29:51 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-04-06 14:29:51 +0000
commit945cae8720b4790b239bfe5348f33ee4f72fe49b (patch)
tree3711f4e5cc7863c5254ee9dda4860195aa3d90c5 /sysutils/xen-tools
parentc9d7334c7eb2e81855fe80abcbf0fc6e72d79a2c (diff)
downloadports-945cae8720b4790b239bfe5348f33ee4f72fe49b.tar.gz
ports-945cae8720b4790b239bfe5348f33ee4f72fe49b.zip
Notes
Diffstat (limited to 'sysutils/xen-tools')
-rw-r--r--sysutils/xen-tools/Makefile68
-rw-r--r--sysutils/xen-tools/distinfo4
-rw-r--r--sysutils/xen-tools/files/patch-configure27
-rw-r--r--sysutils/xen-tools/files/patch-tools_configure27
-rw-r--r--sysutils/xen-tools/files/patch-tools_firmware_seabios-dir_scripts_buildversion.sh11
-rw-r--r--sysutils/xen-tools/pkg-descr5
-rw-r--r--sysutils/xen-tools/pkg-plist421
7 files changed, 563 insertions, 0 deletions
diff --git a/sysutils/xen-tools/Makefile b/sysutils/xen-tools/Makefile
new file mode 100644
index 000000000000..45ae89ccd148
--- /dev/null
+++ b/sysutils/xen-tools/Makefile
@@ -0,0 +1,68 @@
+# $FreeBSD$
+
+PORTNAME= xl
+PORTVERSION= 4.5.0
+CATEGORIES= emulators
+MASTER_SITES= http://bits.xensource.com/oss-xen/release/${PORTVERSION}/ \
+ http://code.coreboot.org/p/seabios/downloads/get/:seabios
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Xen management tool, based on LibXenlight
+
+LICENSE= GPLv2 LGPL3
+LICENSE_COMB= multi
+
+OPTIONS_DEFINE= DOCS
+
+ONLY_FOR_ARCH= amd64
+
+LIB_DEPENDS= libyajl.so:${PORTSDIR}/devel/yajl \
+ liblzo2.so:${PORTSDIR}/archivers/lzo2
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+RUN_DEPENDS= /boot/xen:${PORTSDIR}/emulators/xen
+
+CONFIGURE_ARGS= --disable-xen
+
+SEABIOSVERSION= 1.8.1
+DISTFILES+= xen-${PORTVERSION}.tar.gz \
+ seabios-${SEABIOSVERSION}.tar.gz:seabios
+
+WRKSRC= ${WRKDIR}/xen-${PORTVERSION}
+
+USES= gmake perl5 python shebangfix
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= HOSTCC="${CC}" CC="${CC}" \
+ ac_cv_path_BASH=${TRUE} \
+ ac_cv_path_XGETTEXT=${TRUE} \
+ glib_CFLAGS=" " glib_LIBS=" "
+MAKE_ARGS= HOSTCC="${CC}" CC="${CC}"
+SHEBANG_FILES= tools/misc/xencov_split \
+ tools/misc/xen-ringwatch
+USE_GCC= yes
+ALL_TARGET= tools docs
+INSTALL_TARGET= install-tools install-docs
+
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} != FreeBSD
+IGNORE= Only supported on FreeBSD
+.endif
+
+.if ${OSVERSION} < 1100055
+IGNORE= Only supported on recent FreeBSD 11
+.endif
+
+post-extract:
+ ${MV} ${WRKDIR}/seabios-${SEABIOSVERSION} ${WRKSRC}/tools/firmware/seabios-dir
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/var/lib,/var/db,g" \
+ ${WRKSRC}/tools/Makefile \
+ ${WRKSRC}/tools/libxc/include/xenguest.h \
+ ${WRKSRC}/tools/libxl/libxl_dom.c \
+ ${WRKSRC}/tools/libxl/libxl_dm.c \
+ ${WRKSRC}/tools/qemu-xen-traditional/i386-dm/helper2.c \
+ ${WRKSRC}/docs/man/*
+
+.include <bsd.port.mk>
+RUN_DEPENDS:= ${RUN_DEPENDS:N*gcc*}
diff --git a/sysutils/xen-tools/distinfo b/sysutils/xen-tools/distinfo
new file mode 100644
index 000000000000..c1f31aeabb20
--- /dev/null
+++ b/sysutils/xen-tools/distinfo
@@ -0,0 +1,4 @@
+SHA256 (xen-4.5.0.tar.gz) = 5bdb40e2b28d2eeb541bd71a9777f40cbe2ae444b987521d33f099541a006f3b
+SIZE (xen-4.5.0.tar.gz) = 18404933
+SHA256 (seabios-1.8.1.tar.gz) = 283bd848f5ce9d4bc52add973a856347e02c9ce89a9e6bc92c99359b87c9871d
+SIZE (seabios-1.8.1.tar.gz) = 537712
diff --git a/sysutils/xen-tools/files/patch-configure b/sysutils/xen-tools/files/patch-configure
new file mode 100644
index 000000000000..d795d1c1f6c2
--- /dev/null
+++ b/sysutils/xen-tools/files/patch-configure
@@ -0,0 +1,27 @@
+--- configure.orig 2015-01-12 16:53:24 UTC
++++ configure
+@@ -1936,7 +1936,7 @@ XEN_RUN_DIR=$localstatedir/run/xen
+ XEN_LOG_DIR=$localstatedir/log/xen
+
+
+-XEN_LIB_STORED=$localstatedir/lib/xenstored
++XEN_LIB_STORED=$localstatedir/db/xenstored
+
+
+ SHAREDIR=$prefix/share
+@@ -1955,13 +1955,13 @@ XEN_SCRIPT_DIR=$XEN_CONFIG_DIR/scripts
+
+
+ case "$host_os" in
+-*freebsd*) XEN_LOCK_DIR=$localstatedir/lib ;;
++*freebsd*) XEN_LOCK_DIR=$localstatedir/db ;;
+ *netbsd*) XEN_LOCK_DIR=$localstatedir/lib ;;
+ *) XEN_LOCK_DIR=$localstatedir/lock ;;
+ esac
+
+
+-XEN_PAGING_DIR=$localstatedir/lib/xen/xenpaging
++XEN_PAGING_DIR=$localstatedir/db/xen/xenpaging
+
+
+
diff --git a/sysutils/xen-tools/files/patch-tools_configure b/sysutils/xen-tools/files/patch-tools_configure
new file mode 100644
index 000000000000..567b46129dd4
--- /dev/null
+++ b/sysutils/xen-tools/files/patch-tools_configure
@@ -0,0 +1,27 @@
+--- tools/configure.orig 2015-01-12 16:53:24 UTC
++++ tools/configure
+@@ -3776,7 +3776,7 @@ XEN_RUN_DIR=$localstatedir/run/xen
+ XEN_LOG_DIR=$localstatedir/log/xen
+
+
+-XEN_LIB_STORED=$localstatedir/lib/xenstored
++XEN_LIB_STORED=$localstatedir/db/xenstored
+
+
+ SHAREDIR=$prefix/share
+@@ -3795,13 +3795,13 @@ XEN_SCRIPT_DIR=$XEN_CONFIG_DIR/scripts
+
+
+ case "$host_os" in
+-*freebsd*) XEN_LOCK_DIR=$localstatedir/lib ;;
++*freebsd*) XEN_LOCK_DIR=$localstatedir/db ;;
+ *netbsd*) XEN_LOCK_DIR=$localstatedir/lib ;;
+ *) XEN_LOCK_DIR=$localstatedir/lock ;;
+ esac
+
+
+-XEN_PAGING_DIR=$localstatedir/lib/xen/xenpaging
++XEN_PAGING_DIR=$localstatedir/db/xen/xenpaging
+
+
+
diff --git a/sysutils/xen-tools/files/patch-tools_firmware_seabios-dir_scripts_buildversion.sh b/sysutils/xen-tools/files/patch-tools_firmware_seabios-dir_scripts_buildversion.sh
new file mode 100644
index 000000000000..82790ed0ce91
--- /dev/null
+++ b/sysutils/xen-tools/files/patch-tools_firmware_seabios-dir_scripts_buildversion.sh
@@ -0,0 +1,11 @@
+--- tools/firmware/seabios-dir/scripts/buildversion.sh.orig 2015-03-13 09:02:17 UTC
++++ tools/firmware/seabios-dir/scripts/buildversion.sh
+@@ -11,7 +11,7 @@ elif [ -f .version ]; then
+ else
+ VERSION="?"
+ fi
+-VERSION="${VERSION}-`date +"%Y%m%d_%H%M%S"`-`hostname`"
++VERSION="${VERSION}"
+ echo "Version: ${VERSION}"
+
+ # Build header file
diff --git a/sysutils/xen-tools/pkg-descr b/sysutils/xen-tools/pkg-descr
new file mode 100644
index 000000000000..e670ea441992
--- /dev/null
+++ b/sysutils/xen-tools/pkg-descr
@@ -0,0 +1,5 @@
+The xl program is the new tool for managing Xen guest domains. The program can
+be used to create, pause, and shutdown domains. It can also be used to list
+current domains, enable or pin VCPUs, and attach or detach virtual block devices
+
+WWW: http://wiki.xen.org/wiki/XL
diff --git a/sysutils/xen-tools/pkg-plist b/sysutils/xen-tools/pkg-plist
new file mode 100644
index 000000000000..2d8766e3ded0
--- /dev/null
+++ b/sysutils/xen-tools/pkg-plist
@@ -0,0 +1,421 @@
+bin/pygrub
+bin/xen-detect
+bin/xencons
+bin/xencov_split
+bin/xenstore
+bin/xenstore-chmod
+bin/xenstore-control
+bin/xenstore-exists
+bin/xenstore-list
+bin/xenstore-ls
+bin/xenstore-read
+bin/xenstore-rm
+bin/xenstore-watch
+bin/xenstore-write
+bin/xentrace
+bin/xentrace_format
+bin/xentrace_setsize
+etc/bash_completion.d/xl.sh
+etc/rc.d/xencommons
+etc/xen/README
+etc/xen/README.incompatibilities
+etc/xen/cpupool
+etc/xen/scripts/hotplugpath.sh
+etc/xen/scripts/vif-bridge
+etc/xen/xl.conf
+etc/xen/xlexample.hvm
+etc/xen/xlexample.pvlinux
+include/_libxl_list.h
+include/_libxl_types.h
+include/_libxl_types_json.h
+include/fsimage.h
+include/fsimage_grub.h
+include/fsimage_plugin.h
+include/libxl.h
+include/libxl_event.h
+include/libxl_json.h
+include/libxl_utils.h
+include/libxl_uuid.h
+include/xen/COPYING
+include/xen/arch-arm.h
+include/xen/arch-arm/hvm/save.h
+include/xen/arch-x86/cpuid.h
+include/xen/arch-x86/hvm/save.h
+include/xen/arch-x86/xen-mca.h
+include/xen/arch-x86/xen-x86_32.h
+include/xen/arch-x86/xen-x86_64.h
+include/xen/arch-x86/xen.h
+include/xen/arch-x86_32.h
+include/xen/arch-x86_64.h
+include/xen/callback.h
+include/xen/dom0_ops.h
+include/xen/domctl.h
+include/xen/elfnote.h
+include/xen/event_channel.h
+include/xen/features.h
+include/xen/foreign/arm32.h
+include/xen/foreign/arm64.h
+include/xen/foreign/x86_32.h
+include/xen/foreign/x86_64.h
+include/xen/gcov.h
+include/xen/grant_table.h
+include/xen/hvm/e820.h
+include/xen/hvm/hvm_info_table.h
+include/xen/hvm/hvm_op.h
+include/xen/hvm/hvm_xs_strings.h
+include/xen/hvm/ioreq.h
+include/xen/hvm/params.h
+include/xen/hvm/pvdrivers.h
+include/xen/hvm/save.h
+include/xen/io/blkif.h
+include/xen/io/console.h
+include/xen/io/fbif.h
+include/xen/io/fsif.h
+include/xen/io/kbdif.h
+include/xen/io/libxenvchan.h
+include/xen/io/netif.h
+include/xen/io/pciif.h
+include/xen/io/protocols.h
+include/xen/io/ring.h
+include/xen/io/tpmif.h
+include/xen/io/usbif.h
+include/xen/io/vscsiif.h
+include/xen/io/xenbus.h
+include/xen/io/xs_wire.h
+include/xen/kexec.h
+include/xen/mem_event.h
+include/xen/memory.h
+include/xen/nmi.h
+include/xen/physdev.h
+include/xen/platform.h
+include/xen/sched.h
+include/xen/sys/evtchn.h
+include/xen/sys/privcmd.h
+include/xen/sysctl.h
+include/xen/tmem.h
+include/xen/trace.h
+include/xen/vcpu.h
+include/xen/version.h
+include/xen/xen-compat.h
+include/xen/xen.h
+include/xen/xencomm.h
+include/xen/xenoprof.h
+include/xen/xsm/flask_op.h
+include/xenctrl.h
+include/xenctrlosdep.h
+include/xenguest.h
+include/xenstat.h
+include/xenstore-compat/xs.h
+include/xenstore-compat/xs_lib.h
+include/xenstore.h
+include/xenstore_lib.h
+include/xentoollog.h
+include/xs.h
+include/xs_lib.h
+lib/fs/ext2fs/fsimage.so
+lib/fs/fat/fsimage.so
+lib/fs/iso9660/fsimage.so
+lib/fs/reiserfs/fsimage.so
+lib/fs/ufs/fsimage.so
+lib/fs/xfs/fsimage.so
+lib/fs/zfs/fsimage.so
+lib/libfsimage.so
+lib/libfsimage.so.1.0
+lib/libfsimage.so.1.0.0
+lib/libxenctrl.a
+lib/libxenctrl.so
+lib/libxenctrl.so.4.5
+lib/libxenctrl.so.4.5.0
+lib/libxenguest.a
+lib/libxenguest.so
+lib/libxenguest.so.4.5
+lib/libxenguest.so.4.5.0
+lib/libxenlight.a
+lib/libxenlight.so
+lib/libxenlight.so.4.5
+lib/libxenlight.so.4.5.0
+lib/libxenstat.a
+lib/libxenstat.so
+lib/libxenstat.so.0
+lib/libxenstat.so.0.0
+lib/libxenstore.a
+lib/libxenstore.so
+lib/libxenstore.so.3.0
+lib/libxenstore.so.3.0.3
+lib/libxlutil.a
+lib/libxlutil.so
+lib/libxlutil.so.4.3
+lib/libxlutil.so.4.3.0
+%%PYTHON_SITELIBDIR%%/fsimage.so
+%%PYTHON_SITELIBDIR%%/grub/ExtLinuxConf.py
+%%PYTHON_SITELIBDIR%%/grub/ExtLinuxConf.pyc
+%%PYTHON_SITELIBDIR%%/grub/GrubConf.py
+%%PYTHON_SITELIBDIR%%/grub/GrubConf.pyc
+%%PYTHON_SITELIBDIR%%/grub/LiloConf.py
+%%PYTHON_SITELIBDIR%%/grub/LiloConf.pyc
+%%PYTHON_SITELIBDIR%%/grub/__init__.py
+%%PYTHON_SITELIBDIR%%/grub/__init__.pyc
+%%PYTHON_SITELIBDIR%%/pygrub-0.3-py%%PYTHON_VER%%.egg-info
+%%PYTHON_SITELIBDIR%%/xen-3.0-py%%PYTHON_VER%%.egg-info
+%%PYTHON_SITELIBDIR%%/xen/__init__.py
+%%PYTHON_SITELIBDIR%%/xen/__init__.pyc
+%%PYTHON_SITELIBDIR%%/xen/lowlevel/__init__.py
+%%PYTHON_SITELIBDIR%%/xen/lowlevel/__init__.pyc
+%%PYTHON_SITELIBDIR%%/xen/lowlevel/xc.so
+%%PYTHON_SITELIBDIR%%/xen/lowlevel/xs.so
+lib/xen/bin/libxl-save-helper
+lib/xen/bin/lsevtchn
+lib/xen/bin/pygrub
+lib/xen/bin/readnotes
+lib/xen/bin/xen-init-dom0
+lib/xen/bin/xenconsole
+lib/xen/bin/xenctx
+lib/xen/bin/xenpaging
+lib/xen/bin/xenpvnetboot
+lib/xen/boot/hvmloader
+man/man1/xenstore-chmod.1.gz
+man/man1/xenstore-ls.1.gz
+man/man1/xenstore.1.gz
+man/man1/xentop.1.gz
+man/man1/xentrace_format.1.gz
+man/man1/xl.1.gz
+man/man5/xl.cfg.5.gz
+man/man5/xl.conf.5.gz
+man/man5/xlcpupool.cfg.5.gz
+man/man8/xentrace.8.gz
+sbin/gdbsx
+sbin/gtracestat
+sbin/gtraceview
+sbin/kdd
+sbin/xen-bugtool
+sbin/xen-hptool
+sbin/xen-hvmcrash
+sbin/xen-hvmctx
+sbin/xen-lowmemd
+sbin/xen-mfndump
+sbin/xen-ringwatch
+sbin/xen-tmem-list-parse
+sbin/xenbaked
+sbin/xenconsoled
+sbin/xencov
+sbin/xenlockprof
+sbin/xenmon.py
+sbin/xenperf
+sbin/xenpm
+sbin/xenpmd
+sbin/xenstored
+sbin/xentop
+sbin/xentrace_setmask
+sbin/xenwatchdogd
+sbin/xl
+%%PORTDOCS%%share/doc/xen/README.xenmon
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/.deps
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,arch-arm,hvm,save.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,arch-arm.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,callback.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,dom0_ops.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,domctl.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,elfnote.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,event_channel.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,features.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,gcov.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,grant_table.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,hvm,e820.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,hvm,hvm_info_table.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,hvm,hvm_op.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,hvm,hvm_xs_strings.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,hvm,ioreq.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,hvm,params.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,hvm,pvdrivers.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,hvm,save.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,io,blkif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,io,console.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,io,fbif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,io,fsif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,io,kbdif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,io,libxenvchan.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,io,netif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,io,pciif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,io,protocols.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,io,ring.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,io,tpmif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,io,usbif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,io,vscsiif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,io,xenbus.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,io,xs_wire.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,kexec.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,mem_event.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,memory.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,nmi.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,physdev.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,platform.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,sched.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,sysctl.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,tmem.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,trace.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,vcpu.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,version.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,xen-compat.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,xen.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,xencomm.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,xenoprof.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,xsm,flask_op.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,xen,errno.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/arm/index.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/index.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/.deps
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,arch-x86,cpuid.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,arch-x86,hvm,save.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,arch-x86,xen-mca.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,arch-x86,xen-x86_32.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,arch-x86,xen.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,arch-x86_32.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,callback.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,dom0_ops.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,domctl.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,elfnote.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,event_channel.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,features.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,gcov.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,grant_table.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,hvm,e820.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,hvm,hvm_info_table.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,hvm,hvm_op.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,hvm,hvm_xs_strings.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,hvm,ioreq.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,hvm,params.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,hvm,pvdrivers.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,hvm,save.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,io,blkif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,io,console.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,io,fbif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,io,fsif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,io,kbdif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,io,libxenvchan.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,io,netif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,io,pciif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,io,protocols.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,io,ring.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,io,tpmif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,io,usbif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,io,vscsiif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,io,xenbus.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,io,xs_wire.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,kexec.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,mem_event.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,memory.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,nmi.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,physdev.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,platform.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,sched.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,sysctl.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,tmem.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,trace.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,vcpu.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,version.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,xen-compat.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,xen.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,xencomm.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,xenoprof.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,public,xsm,flask_op.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/include,xen,errno.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_32/index.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/.deps
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,arch-x86,cpuid.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,arch-x86,hvm,save.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,arch-x86,xen-mca.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,arch-x86,xen-x86_64.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,arch-x86,xen.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,arch-x86_64.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,callback.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,dom0_ops.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,domctl.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,elfnote.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,event_channel.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,features.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,gcov.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,grant_table.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,hvm,e820.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,hvm,hvm_info_table.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,hvm,hvm_op.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,hvm,hvm_xs_strings.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,hvm,ioreq.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,hvm,params.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,hvm,pvdrivers.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,hvm,save.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,io,blkif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,io,console.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,io,fbif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,io,fsif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,io,kbdif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,io,libxenvchan.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,io,netif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,io,pciif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,io,protocols.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,io,ring.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,io,tpmif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,io,usbif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,io,vscsiif.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,io,xenbus.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,io,xs_wire.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,kexec.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,mem_event.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,memory.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,nmi.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,physdev.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,platform.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,sched.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,sysctl.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,tmem.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,trace.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,vcpu.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,version.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,xen-compat.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,xen.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,xencomm.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,xenoprof.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,public,xsm,flask_op.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/include,xen,errno.h.html
+%%PORTDOCS%%share/doc/xen/html/hypercall/x86_64/index.html
+%%PORTDOCS%%share/doc/xen/html/index.html
+%%PORTDOCS%%share/doc/xen/html/man/index.html
+%%PORTDOCS%%share/doc/xen/html/man/xenstore-chmod.1.html
+%%PORTDOCS%%share/doc/xen/html/man/xenstore-ls.1.html
+%%PORTDOCS%%share/doc/xen/html/man/xenstore.1.html
+%%PORTDOCS%%share/doc/xen/html/man/xl.1.html
+%%PORTDOCS%%share/doc/xen/html/man/xl.cfg.5.html
+%%PORTDOCS%%share/doc/xen/html/man/xl.conf.5.html
+%%PORTDOCS%%share/doc/xen/html/man/xlcpupool.cfg.5.html
+%%PORTDOCS%%share/doc/xen/html/misc/amd-ucode-container.txt
+%%PORTDOCS%%share/doc/xen/html/misc/channel.txt
+%%PORTDOCS%%share/doc/xen/html/misc/console.txt
+%%PORTDOCS%%share/doc/xen/html/misc/crashdb.txt
+%%PORTDOCS%%share/doc/xen/html/misc/distro_mapping.txt
+%%PORTDOCS%%share/doc/xen/html/misc/dump-core-format.txt
+%%PORTDOCS%%share/doc/xen/html/misc/grant-tables.txt
+%%PORTDOCS%%share/doc/xen/html/misc/index.html
+%%PORTDOCS%%share/doc/xen/html/misc/kexec_and_kdump.txt
+%%PORTDOCS%%share/doc/xen/html/misc/libxl_memory.txt
+%%PORTDOCS%%share/doc/xen/html/misc/pci-device-reservations.txt
+%%PORTDOCS%%share/doc/xen/html/misc/printk-formats.txt
+%%PORTDOCS%%share/doc/xen/html/misc/pvh-readme.txt
+%%PORTDOCS%%share/doc/xen/html/misc/sedf_scheduler_mini-HOWTO.txt
+%%PORTDOCS%%share/doc/xen/html/misc/tscmode.txt
+%%PORTDOCS%%share/doc/xen/html/misc/vbd-interface.txt
+%%PORTDOCS%%share/doc/xen/html/misc/vtd.txt
+%%PORTDOCS%%share/doc/xen/html/misc/vtpm-platforms.txt
+%%PORTDOCS%%share/doc/xen/html/misc/vtpm.txt
+%%PORTDOCS%%share/doc/xen/html/misc/vtpmmgr.txt
+%%PORTDOCS%%share/doc/xen/html/misc/xen-error-handling.txt
+%%PORTDOCS%%share/doc/xen/html/misc/xenpaging.txt
+%%PORTDOCS%%share/doc/xen/html/misc/xenstore-ring.txt
+%%PORTDOCS%%share/doc/xen/html/misc/xenstore.txt
+%%PORTDOCS%%share/doc/xen/html/misc/xl-disk-configuration.txt
+%%PORTDOCS%%share/doc/xen/html/misc/xsm-flask.txt
+@dir etc/xen/auto
+@dir /var/db/xen/xenpaging
+@dir /var/db/xen
+@dir /var/db/xenstored
+@dir /var/log/xen
+@dir /var/xen/dump
+@dir /var/xen