aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xen-tools
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2011-12-14 09:03:23 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2011-12-14 09:03:23 +0000
commitd6e5838efa7b62c221cfceba5480165a8e0b23f4 (patch)
tree9e7422487769a9a692d4bad2f92db3c9275c6269 /sysutils/xen-tools
parent777d880b03acd05106e463876b25986133019af0 (diff)
Notes
Diffstat (limited to 'sysutils/xen-tools')
-rw-r--r--sysutils/xen-tools/Makefile51
-rw-r--r--sysutils/xen-tools/distinfo2
-rw-r--r--sysutils/xen-tools/files/patch-tools_xenstore_xs__lib.c11
-rw-r--r--sysutils/xen-tools/pkg-descr4
4 files changed, 68 insertions, 0 deletions
diff --git a/sysutils/xen-tools/Makefile b/sysutils/xen-tools/Makefile
new file mode 100644
index 000000000000..9a8e157779d3
--- /dev/null
+++ b/sysutils/xen-tools/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: xen-tools
+# Date created: 13 December 2011
+# Whom: Evan Sarmiento <esarmiento@wayfair.com>
+#
+# $FreeBSD$
+
+PORTNAME= xen-tools
+PORTVERSION= 4.0.1
+CATEGORIES= sysutils
+DISTNAME= xen-${PORTVERSION}
+
+MAINTAINER= esarmiento@wayfair.com
+COMMENT= Xen tools within FreeBSD domU
+
+MASTER_SITES= http://bits.xensource.com/oss-xen/release/${PORTVERSION}/
+
+USE_GMAKE= yes
+USE_PYTHON= yes
+
+PLIST_FILES= lib/libxenstore.so.3.0 \
+ bin/xen-detect \
+ bin/xenstore \
+ bin/xenstore-control \
+ bin/xenstore-chmod \
+ bin/xenstore-exists \
+ bin/xenstore-list \
+ bin/xenstore-ls \
+ bin/xenstore-read \
+ bin/xenstore-rm \
+ bin/xenstore-write
+do-build:
+ cd ${WRKSRC}/tools && ${GMAKE} -C include
+ cd ${WRKSRC}/tools/misc && ${GMAKE} xen-detect
+ cd ${WRKSRC}/tools/xenstore && ${GMAKE} clients
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tools/misc/xen-detect ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/tools/xenstore/xenstore ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/tools/xenstore/xenstore-control ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/tools/xenstore/libxenstore.so.3.0 ${PREFIX}/lib
+
+post-install:
+ ${LN} -sf ${PREFIX}/bin/xenstore ${PREFIX}/bin/xenstore-chmod
+ ${LN} -sf ${PREFIX}/bin/xenstore ${PREFIX}/bin/xenstore-exists
+ ${LN} -sf ${PREFIX}/bin/xenstore ${PREFIX}/bin/xenstore-list
+ ${LN} -sf ${PREFIX}/bin/xenstore ${PREFIX}/bin/xenstore-ls
+ ${LN} -sf ${PREFIX}/bin/xenstore ${PREFIX}/bin/xenstore-read
+ ${LN} -sf ${PREFIX}/bin/xenstore ${PREFIX}/bin/xenstore-rm
+ ${LN} -sf ${PREFIX}/bin/xenstore ${PREFIX}/bin/xenstore-write
+
+.include <bsd.port.mk>
diff --git a/sysutils/xen-tools/distinfo b/sysutils/xen-tools/distinfo
new file mode 100644
index 000000000000..84aa81d10bf8
--- /dev/null
+++ b/sysutils/xen-tools/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xen-4.0.1.tar.gz) = 6e6d1d29400db93cb8095e034138aa8748b1bd4cffb4d3fd07af4ba15c918873
+SIZE (xen-4.0.1.tar.gz) = 11909200
diff --git a/sysutils/xen-tools/files/patch-tools_xenstore_xs__lib.c b/sysutils/xen-tools/files/patch-tools_xenstore_xs__lib.c
new file mode 100644
index 000000000000..28c17b0c3bef
--- /dev/null
+++ b/sysutils/xen-tools/files/patch-tools_xenstore_xs__lib.c
@@ -0,0 +1,11 @@
+--- tools/xenstore/xs_lib.c.orig 2011-01-30 15:56:52.985324929 -0800
++++ tools/xenstore/xs_lib.c 2011-01-30 15:55:14.024346135 -0800
+@@ -84,6 +84,8 @@
+ return "/proc/xen/xenbus";
+ #elif defined(__NetBSD__)
+ return "/kern/xen/xenbus";
++#elif defined(__FreeBSD__)
++ return "/dev/xen/xenstore";
+ #else
+ return "/dev/xen/xenbus";
+ #endif
diff --git a/sysutils/xen-tools/pkg-descr b/sysutils/xen-tools/pkg-descr
new file mode 100644
index 000000000000..3f15d9c52987
--- /dev/null
+++ b/sysutils/xen-tools/pkg-descr
@@ -0,0 +1,4 @@
+These tools are useful for debugging Xen related problems when one
+does not have access to the dom0 or wants to view the entries from
+domU's perspective. These work on FreeBSD VMs using the XEN (i386)
+kernel or the XENHVM kernel.