aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xfburn
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-29 20:16:51 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-29 20:16:51 +0000
commit6dbbf246f5ec362f359403bbf0ca6f9e14285810 (patch)
tree42c6aee7d2ed19c2efc3f901dd08812d78d9301d /sysutils/xfburn
parent228ebff813753d2f65b9b8d5e9b4e17d5986398e (diff)
downloadports-6dbbf246f5ec362f359403bbf0ca6f9e14285810.tar.gz
ports-6dbbf246f5ec362f359403bbf0ca6f9e14285810.zip
Notes
Diffstat (limited to 'sysutils/xfburn')
-rw-r--r--sysutils/xfburn/Makefile4
-rw-r--r--sysutils/xfburn/files/patch-xfburn-xfburn-data-composition.c47
2 files changed, 50 insertions, 1 deletions
diff --git a/sysutils/xfburn/Makefile b/sysutils/xfburn/Makefile
index ef3207de3526..a4641711bc02 100644
--- a/sysutils/xfburn/Makefile
+++ b/sysutils/xfburn/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xfburn
PORTVERSION= 0.3.91
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://goodies.xfce.org/releases/xfburn/
@@ -16,7 +17,8 @@ COMMENT= CD/DVD burning tool for Xfce
LIB_DEPENDS= burn.23:${PORTSDIR}/devel/libburn \
isofs.12:${PORTSDIR}/devel/libisofs
RUN_DEPENDS= hal-device:${PORTSDIR}/sysutils/hal \
- cdrdao:${PORTSDIR}/sysutils/cdrdao
+ cdrdao:${PORTSDIR}/sysutils/cdrdao \
+ cdrecord:${PORTSDIR}/sysutils/cdrtools
GNU_CONFIGURE= yes
CONFIGURE_ENV= GMSGFMT=${PREFIX}/bin/msgfmt DATADIRNAME=share
diff --git a/sysutils/xfburn/files/patch-xfburn-xfburn-data-composition.c b/sysutils/xfburn/files/patch-xfburn-xfburn-data-composition.c
new file mode 100644
index 000000000000..16a2ea80c36f
--- /dev/null
+++ b/sysutils/xfburn/files/patch-xfburn-xfburn-data-composition.c
@@ -0,0 +1,47 @@
+--- xfburn/xfburn-data-composition.c.orig 2008-09-14 04:41:53.000000000 -0400
++++ xfburn/xfburn-data-composition.c 2008-11-16 19:57:03.000000000 -0500
+@@ -1099,6 +1099,7 @@
+ DATA_COMPOSITION_COLUMN_ICON, icon_directory,
+ DATA_COMPOSITION_COLUMN_CONTENT, name,
+ DATA_COMPOSITION_COLUMN_TYPE, DATA_COMPOSITION_TYPE_DIRECTORY,
++ DATA_COMPOSITION_COLUMN_PATH, path,
+ DATA_COMPOSITION_COLUMN_SIZE, (guint64) 4, -1);
+ xfburn_disc_usage_add_size (XFBURN_DISC_USAGE (priv->disc_usage), (guint64) 4);
+ gdk_threads_leave ();
+@@ -1742,10 +1743,7 @@
+ gtk_tree_model_get (model, iter, DATA_COMPOSITION_COLUMN_TYPE, &type,
+ DATA_COMPOSITION_COLUMN_CONTENT, &name, DATA_COMPOSITION_COLUMN_PATH, &src, -1);
+
+- if (type == DATA_COMPOSITION_TYPE_DIRECTORY)
+- r = iso_tree_add_new_dir (parent, name, &dir);
+- else
+- r = iso_tree_add_node (image, parent, src, &node);
++ r = iso_tree_add_node (image, parent, src, &node);
+
+ if (r < 0) {
+ if (r == ISO_NULL_POINTER)
+@@ -1758,9 +1756,11 @@
+ g_error ("Failed adding %s as a node to the image: code %d!", src, r);
+ }
+
+- /* FIXME: do we need to call iso_node_ref on node? Probably not... */
++ /* why was this called again? iso_tree_add_node seems to do
++ * a good job setting the name by itself.
+ if (type != DATA_COMPOSITION_TYPE_DIRECTORY)
+ iso_node_set_name (node, name);
++ */
+
+ g_free (name);
+ g_free (src);
+@@ -1768,10 +1768,9 @@
+ if (type == DATA_COMPOSITION_TYPE_DIRECTORY && gtk_tree_model_iter_has_child (model, iter)) {
+ GtkTreeIter child;
+
+- /* FIXME: this should not cause a sigfault...
+ if (iso_node_get_type(node) != LIBISO_DIR)
+ g_error ("Expected %s to be a directory, but it isn't...\n", src);
+- */
++ dir = (IsoDir *)node;
+
+ gtk_tree_model_iter_children (model, &child, iter);
+ fill_image_with_composition (model, image, dir, &child);