aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xfburn
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2019-11-03 19:14:10 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2019-11-03 19:14:10 +0000
commit7c805bf4df08d7742686c17e345a5e739c1d3c1b (patch)
treed7e259e7658026b2d98c735b7799e07b9f8e4028 /sysutils/xfburn
parent5d1ca20071e52cf6ef55f751099494a31c6748e4 (diff)
Notes
Diffstat (limited to 'sysutils/xfburn')
-rw-r--r--sysutils/xfburn/Makefile18
-rw-r--r--sysutils/xfburn/distinfo6
-rw-r--r--sysutils/xfburn/files/patch-xfburn_xfburn-transcoder-gst.c50
-rw-r--r--sysutils/xfburn/pkg-plist3
4 files changed, 10 insertions, 67 deletions
diff --git a/sysutils/xfburn/Makefile b/sysutils/xfburn/Makefile
index 01e79b9ed3f4..3892cb9a17d0 100644
--- a/sysutils/xfburn/Makefile
+++ b/sysutils/xfburn/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xfburn
-PORTVERSION= 0.5.5
-PORTREVISION= 2
+PORTVERSION= 0.6.1
CATEGORIES= sysutils
MASTER_SITES= XFCE/apps
DIST_SUBDIR= xfce4
@@ -14,16 +13,12 @@ COMMENT= CD/DVD burning tool for Xfce
LICENSE= GPLv2
LIB_DEPENDS= libburn.so:devel/libburn \
- libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2 \
libisofs.so:devel/libisofs
-RUN_DEPENDS= cdrdao:sysutils/cdrdao \
- ${LOCALBASE}/include/libburn/libburn.h:devel/libburn \
- ${LOCALBASE}/include/libisofs/libisofs.h:devel/libisofs
+RUN_DEPENDS= cdrdao:sysutils/cdrdao
USES= compiler:c11 desktop-file-utils gettext-tools gmake gnome \
- pkgconfig tar:bzip2 xfce:gtk2
-USE_GNOME= cairo glib20 gtk20 intltool
+ pkgconfig tar:bzip2 xfce
+USE_GNOME= cairo glib20 gtk30 intltool
USE_XFCE= libexo
GNU_CONFIGURE= yes
@@ -40,9 +35,4 @@ GSTREAMER_USE= gstreamer1=yes,faac,flac,lame,vorbis,wavpack
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext-runtime
-post-patch:
- ${REINPLACE_CMD} -e 's|media-cdrom|media-optical|g' \
- ${WRKSRC}/desktop-integration/thunar-sendto-xfburn.desktop.in \
- ${WRKSRC}/xfburn.desktop.in
-
.include <bsd.port.mk>
diff --git a/sysutils/xfburn/distinfo b/sysutils/xfburn/distinfo
index 638bddb0e59d..661ec78ca8ce 100644
--- a/sysutils/xfburn/distinfo
+++ b/sysutils/xfburn/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1513262582
-SHA256 (xfce4/xfburn-0.5.5.tar.bz2) = aa173aa8a6c0887a4b236aee3753760e943f3e2be99af1f2d5343a6df345ade1
-SIZE (xfce4/xfburn-0.5.5.tar.bz2) = 819546
+TIMESTAMP = 1572807139
+SHA256 (xfce4/xfburn-0.6.1.tar.bz2) = b3772b103a89652f7cc06751ec667d34da9344b22bb15ed623c1d8e46851b379
+SIZE (xfce4/xfburn-0.6.1.tar.bz2) = 847568
diff --git a/sysutils/xfburn/files/patch-xfburn_xfburn-transcoder-gst.c b/sysutils/xfburn/files/patch-xfburn_xfburn-transcoder-gst.c
deleted file mode 100644
index ecfe19293e02..000000000000
--- a/sysutils/xfburn/files/patch-xfburn_xfburn-transcoder-gst.c
+++ /dev/null
@@ -1,50 +0,0 @@
---- xfburn/xfburn-transcoder-gst.c.orig 2017-12-14 12:34:57 UTC
-+++ xfburn/xfburn-transcoder-gst.c
-@@ -221,8 +221,8 @@ xfburn_transcoder_gst_init (XfburnTranscoderGst * obj)
-
- /* if the mutex is locked, then we're not currently seeking
- * information from gst */
-+ /* Actual locking in prepare and finish */
- g_mutex_init (&priv->gst_mutex);
-- g_mutex_lock (&priv->gst_mutex);
-
- priv->discoverer = gst_discoverer_new(GST_SECOND, NULL);
- }
-@@ -492,19 +492,9 @@ bus_call (GstBus *bus, GstMessage *msg, gpointer data)
-
- if (strcmp (GST_OBJECT_NAME (GST_MESSAGE_SRC (msg)), "decoder") != 0)
- break;
--
-- if (!g_mutex_trylock (&priv->gst_mutex)) {
-- g_critical ("Lock held by another thread, can't signal transcoding start!");
-- break;
-- } else {
--#if DEBUG_GST > 0
-- DBG ("Locked mutex to signal transcoding start");
--#endif
-- }
-
- priv->gst_done = TRUE;
- g_cond_signal (&priv->gst_cond);
-- g_mutex_unlock (&priv->gst_mutex);
- break;
- } /* switch of priv->state */
-
-@@ -835,6 +825,8 @@ prepare (XfburnTranscoder *trans, GError **error)
- gboolean ret;
- gint64 end_time;
-
-+ g_mutex_lock(&priv->gst_mutex);
-+
- priv->tracks = g_slist_reverse (priv->tracks);
-
- priv->state = XFBURN_TRANSCODER_GST_STATE_TRANSCODE_START;
-@@ -933,6 +925,8 @@ finish (XfburnTranscoder *trans)
- }
- */
- recreate_pipeline (gst);
-+
-+ g_mutex_unlock (&priv->gst_mutex);
- }
-
-
diff --git a/sysutils/xfburn/pkg-plist b/sysutils/xfburn/pkg-plist
index 2bafc96567dc..c9b30703e66a 100644
--- a/sysutils/xfburn/pkg-plist
+++ b/sysutils/xfburn/pkg-plist
@@ -49,6 +49,7 @@ share/icons/hicolor/scalable/stock/media/stock_xfburn-new-data-composition.svg
share/icons/hicolor/scalable/stock/media/stock_xfburn.svg
%%NLS%%share/locale/ar/LC_MESSAGES/xfburn.mo
%%NLS%%share/locale/ast/LC_MESSAGES/xfburn.mo
+%%NLS%%share/locale/be/LC_MESSAGES/xfburn.mo
%%NLS%%share/locale/bg/LC_MESSAGES/xfburn.mo
%%NLS%%share/locale/ca/LC_MESSAGES/xfburn.mo
%%NLS%%share/locale/cs/LC_MESSAGES/xfburn.mo
@@ -67,7 +68,9 @@ share/icons/hicolor/scalable/stock/media/stock_xfburn.svg
%%NLS%%share/locale/he/LC_MESSAGES/xfburn.mo
%%NLS%%share/locale/hr/LC_MESSAGES/xfburn.mo
%%NLS%%share/locale/hu/LC_MESSAGES/xfburn.mo
+%%NLS%%share/locale/hy_AM/LC_MESSAGES/xfburn.mo
%%NLS%%share/locale/id/LC_MESSAGES/xfburn.mo
+%%NLS%%share/locale/ie/LC_MESSAGES/xfburn.mo
%%NLS%%share/locale/is/LC_MESSAGES/xfburn.mo
%%NLS%%share/locale/it/LC_MESSAGES/xfburn.mo
%%NLS%%share/locale/ja/LC_MESSAGES/xfburn.mo