aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xfce4-cpugraph-plugin/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-06-07 22:03:10 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-06-07 22:03:10 +0000
commit08b0f9136154c3adb1a39fe63d92550916b36f96 (patch)
tree781695fc135318dcd0d328293e33283ed3f11c2d /sysutils/xfce4-cpugraph-plugin/Makefile
parent0a0e09f347ac84b0ec3ff7b4dd956a4e88012a8f (diff)
downloadports-08b0f9136154c3adb1a39fe63d92550916b36f96.tar.gz
ports-08b0f9136154c3adb1a39fe63d92550916b36f96.zip
Notes
Diffstat (limited to 'sysutils/xfce4-cpugraph-plugin/Makefile')
-rw-r--r--sysutils/xfce4-cpugraph-plugin/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/xfce4-cpugraph-plugin/Makefile b/sysutils/xfce4-cpugraph-plugin/Makefile
new file mode 100644
index 000000000000..9aafe7101451
--- /dev/null
+++ b/sysutils/xfce4-cpugraph-plugin/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: xfce4-cpugraph-plugin
+# Date created: 2004-06-07
+# Whom: Matt Lancereau <matt@rimasec.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-cpugraph-plugin
+PORTVERSION= 0.1.1
+CATEGORIES= sysutils xfce
+MASTER_SITES= http://download.berlios.de/xfce-goodies/ \
+ http://matt.nerim.net/xfce-goodies/ \
+ http://www.bsd-blax.org/ports/mirrors/
+DIST_SUBDIR= xfce4
+
+MAINTAINER= matt@rimasec.net
+COMMENT= XFce4 systemload plugin with multiple CPU display modes
+
+BUILD_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
+ xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui \
+ startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+
+USE_GNOME= gtk20 libxml2
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER=15
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.mk>