aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xfce4-cpugraph-plugin/Makefile
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2010-12-24 21:59:15 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2010-12-24 21:59:15 +0000
commit8054684ed7f6ed52e2a7918edc5532ef78f43af8 (patch)
tree3ee975818c3da65f6ee2ac4e4a618dfc672341ef /sysutils/xfce4-cpugraph-plugin/Makefile
parent3aa1420788d45a5e376bf16a8675ae1765bcdf9f (diff)
Notes
Diffstat (limited to 'sysutils/xfce4-cpugraph-plugin/Makefile')
-rw-r--r--sysutils/xfce4-cpugraph-plugin/Makefile22
1 files changed, 18 insertions, 4 deletions
diff --git a/sysutils/xfce4-cpugraph-plugin/Makefile b/sysutils/xfce4-cpugraph-plugin/Makefile
index efefec4ad484..08c2b14a33a7 100644
--- a/sysutils/xfce4-cpugraph-plugin/Makefile
+++ b/sysutils/xfce4-cpugraph-plugin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xfce4-cpugraph-plugin
-PORTVERSION= 1.0.0
+PORTVERSION= 1.0.1
CATEGORIES= sysutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
@@ -17,9 +17,23 @@ COMMENT= XFce4 systemload plugin with multiple CPU display modes
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gnometarget gtk20 intltool intlhack pkgconfig
+USE_GNOME= gnomehack gtk20 intltool intlhack pkgconfig
USE_XFCE= configenv libgui panel
-.include <bsd.port.mk>
+CONFIGURE_ARGS= --disable-debug
+
+OPTIONS= NLS "Enable Native Language Support" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ARGS+=--enable-nls
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.post.mk>