aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xfce4-genmon-plugin/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2004-10-22 10:51:45 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2004-10-22 10:51:45 +0000
commit47911288bdd5a52ba27e052e78be26ccbd0893ec (patch)
tree40ebd05b1d5b220451da35eb4eb43b650fba7bb4 /sysutils/xfce4-genmon-plugin/Makefile
parenteb1700e64a17a9577590c748023344253a455beb (diff)
Notes
Diffstat (limited to 'sysutils/xfce4-genmon-plugin/Makefile')
-rw-r--r--sysutils/xfce4-genmon-plugin/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/sysutils/xfce4-genmon-plugin/Makefile b/sysutils/xfce4-genmon-plugin/Makefile
new file mode 100644
index 000000000000..e6cb590f5671
--- /dev/null
+++ b/sysutils/xfce4-genmon-plugin/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: xfce4-genmon-plugin
+# Date created: 2004-09-12
+# Whom: Matt Lancereau <matt@bsdfly.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-genmon-plugin
+PORTVERSION= 1.0
+CATEGORIES= sysutils xfce
+MASTER_SITES= http://download.berlios.de/xfce-goodies/ \
+ http://matt.nerim.net/xfce-goodies/
+DIST_SUBDIR= xfce4
+
+MAINTAINER= matt@bsdfly.org
+COMMENT= Generic Monitor XFce4 panel plugin
+
+BUILD_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
+ xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui \
+ startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+
+USE_GNOME= gtk20 libxml2
+USE_X_PREFIX= yes
+USE_INC_LIBTOOL_VER=15
+INSTALLS_SHLIB= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+.include <bsd.port.mk>