aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xfce4-genmon-plugin
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-11-11 17:43:32 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-11-11 17:43:32 +0000
commitd76b5f5846a9a9edd9c81f1f368fefba96cf7194 (patch)
tree108cda25363b60e0f39b2c076e32194f0de4896e /sysutils/xfce4-genmon-plugin
parent2aa4b42436b1e0c69f0a51cc96b754ba3fb76a65 (diff)
downloadports-d76b5f5846a9a9edd9c81f1f368fefba96cf7194.tar.gz
ports-d76b5f5846a9a9edd9c81f1f368fefba96cf7194.zip
Notes
Diffstat (limited to 'sysutils/xfce4-genmon-plugin')
-rw-r--r--sysutils/xfce4-genmon-plugin/Makefile1
-rw-r--r--sysutils/xfce4-genmon-plugin/files/patch-panel-plugin__main.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/sysutils/xfce4-genmon-plugin/Makefile b/sysutils/xfce4-genmon-plugin/Makefile
index 6fa2f8891709..e4d9e26b8ab3 100644
--- a/sysutils/xfce4-genmon-plugin/Makefile
+++ b/sysutils/xfce4-genmon-plugin/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xfce4-genmon-plugin
PORTVERSION= 3.3.0
+PORTREVISION= 1
CATEGORIES= sysutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
diff --git a/sysutils/xfce4-genmon-plugin/files/patch-panel-plugin__main.c b/sysutils/xfce4-genmon-plugin/files/patch-panel-plugin__main.c
new file mode 100644
index 000000000000..f70cba95bdb2
--- /dev/null
+++ b/sysutils/xfce4-genmon-plugin/files/patch-panel-plugin__main.c
@@ -0,0 +1,11 @@
+--- ./panel-plugin/main.c.orig 2011-11-11 18:35:50.000000000 +0100
++++ ./panel-plugin/main.c 2011-11-11 18:36:46.000000000 +0100
+@@ -836,6 +836,8 @@
+
+ SetMonitorFont (genmon);
+
++ SetTimer (genmon);
++
+ g_signal_connect (plugin, "free-data", G_CALLBACK (genmon_free), genmon);
+
+ g_signal_connect (plugin, "save", G_CALLBACK (genmon_write_config),