aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xfce4-netload-plugin/Makefile
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2003-09-03 14:10:01 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2003-09-03 14:10:01 +0000
commit1570ba744047133f1dfd6cc53c2c01a6ccd80bae (patch)
tree6ef2a798f8524c4f0b15d0bba349899db4ebc223 /sysutils/xfce4-netload-plugin/Makefile
parentb38f49d58fe25abe77c811cc48936de6eb1634f7 (diff)
downloadports-1570ba744047133f1dfd6cc53c2c01a6ccd80bae.tar.gz
ports-1570ba744047133f1dfd6cc53c2c01a6ccd80bae.zip
Notes
Diffstat (limited to 'sysutils/xfce4-netload-plugin/Makefile')
-rw-r--r--sysutils/xfce4-netload-plugin/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/sysutils/xfce4-netload-plugin/Makefile b/sysutils/xfce4-netload-plugin/Makefile
new file mode 100644
index 000000000000..4276ea56a073
--- /dev/null
+++ b/sysutils/xfce4-netload-plugin/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: xfce-netload-plugin
+# Date created: 3 September 2003
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-netload-plugin
+PORTVERSION= 0.2.0.p5
+CATEGORIES= sysutils xfce
+MASTER_SITES= http://download.berlios.de/xfce-goodies/
+DISTNAME= ${PORTNAME}-0.2.0pre5
+DIST_SUBDIR= xfce4
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= Network Load plugin for XFce4
+
+BUILD_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
+ xfce4util.1:${PORTSDIR}/x11/libxfce4util \
+ xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui
+RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+
+USE_GNOME= gtk20
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+.include <bsd.port.mk>