aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xfce4-settings
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2010-05-31 15:27:35 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2010-05-31 15:27:35 +0000
commitfadaf7d1d97c291cdeea808c263b2f35631844c6 (patch)
treebd97a0478b3f2879cbfd9f5a13b8d778a1dd9852 /sysutils/xfce4-settings
parentcba0b6798bcf3f053a366c0447d18114d51cbb2b (diff)
Notes
Diffstat (limited to 'sysutils/xfce4-settings')
-rw-r--r--sysutils/xfce4-settings/Makefile59
-rw-r--r--sysutils/xfce4-settings/distinfo6
-rw-r--r--sysutils/xfce4-settings/pkg-plist163
3 files changed, 166 insertions, 62 deletions
diff --git a/sysutils/xfce4-settings/Makefile b/sysutils/xfce4-settings/Makefile
index eb72db23545a..245bcdf3b3fb 100644
--- a/sysutils/xfce4-settings/Makefile
+++ b/sysutils/xfce4-settings/Makefile
@@ -6,29 +6,33 @@
#
PORTNAME= xfce4-settings
-PORTVERSION= 4.6.4
-PORTREVISION= 4
+PORTVERSION= 4.6.5
CATEGORIES= sysutils xfce
-MASTER_SITES= http://www.xfce.org/archive/src/xfce/xfce4-settings/4.6/
+MASTER_SITES= ${MASTER_SITE_XFCE}
DIST_SUBDIR= xfce4
MAINTAINER= oliver@FreeBSD.org
COMMENT= XFce 4 settings application
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
-LIB_DEPENDS= wnck-1.22:${PORTSDIR}/x11-toolkits/libwnck
+LIB_DEPENDS= wnck-1.22:${PORTSDIR}/x11-toolkits/libwnck \
+ dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
-OPTIONS= XKLAVIER "Keyboard layout settings" off
+OPTIONS= XKLAVIER "Keyboard layout settings" off \
+ XCURSOR "Enable cursor themes support" on \
+ XRANDR "Enable Xrandr support" on \
+ NOTIFY "Enable notification support" on \
+ NLS "Enable Native Language Support" on
-CONFIGURE_ARGS= --disable-sound-settings
+CONFIGURE_ARGS= --disable-sound-settings --disable-debug
+USE_AUTOTOOLS= libtool:22
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
-USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gnometarget gtk20 intltool intlhack pkgconfig
+USE_GNOME= gnometarget glib20 gtk20 desktopfileutils intltool intlhack \
+ libglade2 pkgconfig
USE_XFCE= configenv libexo libgui libutil xfconf
+USE_XORG= x11 xi
.include <bsd.port.pre.mk>
@@ -39,6 +43,38 @@ CONFIGURE_ARGS+=--enable-libxklavier
CONFIGURE_ARGS+=--disable-libxklavier
.endif
+.if defined(WITH_XCURSOR)
+USE_XORG+= xcursor
+CONFIGURE_ARGS+=--enable-xcursor
+.else
+CONFIGURE_ARGS+=--disable-xcursor
+.endif
+
+.if defined(WITH_XRANDR)
+USE_XORG+= xrandr
+CONFIGURE_ARGS+=--enable-xrandr
+PLIST_SUB+= XRANDR=""
+.else
+CONFIGURE_ARGS+=--disable-xrandr
+PLIST_SUB+= XRANDR="@comment "
+.endif
+
+.if defined(WITH_NOTIFY)
+LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+CONFIGURE_ARGS+=--enable-libnotify
+.else
+CONFIGURE_ARGS+=--disable-libnotify
+.endif
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ARGS+=--enable-nls
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
post-patch:
# until xfce4-icon-theme is back we rely on Tango
@${REINPLACE_CMD} -e 's|Rodent|Tango|g' \
@@ -48,4 +84,7 @@ post-patch:
s|xkl_engine_stop_listen (settings->priv->xkl_engine)|xkl_engine_stop_listen (settings->priv->xkl_engine, FALSE)|g' \
${WRKSRC}/dialogs/keyboard-settings/xfce-keyboard-settings.c
+post-install:
+ @-update-desktop-database
+
.include <bsd.port.post.mk>
diff --git a/sysutils/xfce4-settings/distinfo b/sysutils/xfce4-settings/distinfo
index 729f311ba985..0d28c5a1022d 100644
--- a/sysutils/xfce4-settings/distinfo
+++ b/sysutils/xfce4-settings/distinfo
@@ -1,3 +1,3 @@
-MD5 (xfce4/xfce4-settings-4.6.4.tar.bz2) = 04985407e8e5b916c44780314a177e96
-SHA256 (xfce4/xfce4-settings-4.6.4.tar.bz2) = a5e3f0d959b0d424355414769250473785043c3977446a73b36fa3a5ce44ecdb
-SIZE (xfce4/xfce4-settings-4.6.4.tar.bz2) = 519247
+MD5 (xfce4/xfce4-settings-4.6.5.tar.bz2) = f988cb732913b5fbc115ad7105d2231e
+SHA256 (xfce4/xfce4-settings-4.6.5.tar.bz2) = 1601b8d2cac5d931c39bed7e331c5bd91018d0e56663295e7a083a2c78fe168b
+SIZE (xfce4/xfce4-settings-4.6.5.tar.bz2) = 522389
diff --git a/sysutils/xfce4-settings/pkg-plist b/sysutils/xfce4-settings/pkg-plist
index 048c4272839d..b1e1d197ad66 100644
--- a/sysutils/xfce4-settings/pkg-plist
+++ b/sysutils/xfce4-settings/pkg-plist
@@ -1,60 +1,125 @@
-bin/xfce4-appearance-settings
bin/xfce4-accessibility-settings
-bin/xfce4-display-settings
+bin/xfce4-appearance-settings
+%%XRANDR%%bin/xfce4-display-settings
bin/xfce4-keyboard-settings
bin/xfce4-mouse-settings
+bin/xfce4-settings-editor
bin/xfce4-settings-helper
bin/xfce4-settings-manager
-bin/xfce4-settings-editor
bin/xfsettingsd
etc/xdg/autostart/xfce4-settings-helper-autostart.desktop
etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xsettings.xml
-share/locale/ast/LC_MESSAGES/xfce4-settings.mo
-share/locale/ca/LC_MESSAGES/xfce4-settings.mo
-share/locale/cs/LC_MESSAGES/xfce4-settings.mo
-share/locale/da/LC_MESSAGES/xfce4-settings.mo
-share/locale/de/LC_MESSAGES/xfce4-settings.mo
-share/locale/el/LC_MESSAGES/xfce4-settings.mo
-share/locale/es/LC_MESSAGES/xfce4-settings.mo
-share/locale/eu/LC_MESSAGES/xfce4-settings.mo
-share/locale/fi/LC_MESSAGES/xfce4-settings.mo
-share/locale/fr/LC_MESSAGES/xfce4-settings.mo
-share/locale/gl/LC_MESSAGES/xfce4-settings.mo
-share/locale/hu/LC_MESSAGES/xfce4-settings.mo
-share/locale/id/LC_MESSAGES/xfce4-settings.mo
-share/locale/it/LC_MESSAGES/xfce4-settings.mo
-share/locale/ja/LC_MESSAGES/xfce4-settings.mo
-share/locale/lv/LC_MESSAGES/xfce4-settings.mo
-share/locale/nb/LC_MESSAGES/xfce4-settings.mo
-share/locale/nl/LC_MESSAGES/xfce4-settings.mo
-share/locale/pl/LC_MESSAGES/xfce4-settings.mo
-share/locale/pt_BR/LC_MESSAGES/xfce4-settings.mo
-share/locale/pt/LC_MESSAGES/xfce4-settings.mo
-share/locale/ro/LC_MESSAGES/xfce4-settings.mo
-share/locale/ru/LC_MESSAGES/xfce4-settings.mo
-share/locale/sk/LC_MESSAGES/xfce4-settings.mo
-share/locale/sv/LC_MESSAGES/xfce4-settings.mo
-share/locale/tr/LC_MESSAGES/xfce4-settings.mo
-share/locale/uk/LC_MESSAGES/xfce4-settings.mo
-share/locale/ur/LC_MESSAGES/xfce4-settings.mo
-share/locale/ur_PK/LC_MESSAGES/xfce4-settings.mo
-share/locale/zh_CN/LC_MESSAGES/xfce4-settings.mo
-share/applications/xfce-ui-settings.desktop
-share/applications/xfce4-accessibility-settings.desktop
-share/applications/xfce-display-settings.desktop
-share/applications/xfce-keyboard-settings.desktop
-share/applications/xfce-mouse-settings.desktop
-share/applications/xfce-settings-manager.desktop
-share/applications/xfce4-settings-editor.desktop
-@dirrmtry etc/xdg/autostart
+%%XRANDR%%%%NLS%%share/applications/xfce-display-settings.desktop
+%%NLS%%share/applications/xfce-keyboard-settings.desktop
+%%NLS%%share/applications/xfce-mouse-settings.desktop
+%%NLS%%share/applications/xfce-settings-manager.desktop
+%%NLS%%share/applications/xfce-ui-settings.desktop
+%%NLS%%share/applications/xfce4-accessibility-settings.desktop
+%%NLS%%share/applications/xfce4-settings-editor.desktop
+%%NLS%%share/locale/am/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/ast/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/da/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/de/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/el/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/es/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/id/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/it/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/kk/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/ug/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/ur/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/ur_PK/LC_MESSAGES/xfce4-settings.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/xfce4-settings.mo
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+%%NLS%%@dirrmtry share/locale/zh_CN/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/zh_CN
+%%NLS%%@dirrmtry share/locale/ur_PK/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ur_PK
+%%NLS%%@dirrmtry share/locale/ur/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ur
+%%NLS%%@dirrmtry share/locale/uk/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/uk
+%%NLS%%@dirrmtry share/locale/ug/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ug
+%%NLS%%@dirrmtry share/locale/tr/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/tr
+%%NLS%%@dirrmtry share/locale/sv/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/sv
+%%NLS%%@dirrmtry share/locale/sk/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/sk
+%%NLS%%@dirrmtry share/locale/ru/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ru
+%%NLS%%@dirrmtry share/locale/ro/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ro
+%%NLS%%@dirrmtry share/locale/pt_BR/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/pt_BR
+%%NLS%%@dirrmtry share/locale/pt/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/pt
+%%NLS%%@dirrmtry share/locale/pl/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/pl
+%%NLS%%@dirrmtry share/locale/nl/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/nl
+%%NLS%%@dirrmtry share/locale/nb/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/nb
+%%NLS%%@dirrmtry share/locale/lv/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/lv
+%%NLS%%@dirrmtry share/locale/kk/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/kk
+%%NLS%%@dirrmtry share/locale/ja/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ja
+%%NLS%%@dirrmtry share/locale/it/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/it
+%%NLS%%@dirrmtry share/locale/id/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/id
+%%NLS%%@dirrmtry share/locale/hu/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/hu
+%%NLS%%@dirrmtry share/locale/gl/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/gl
+%%NLS%%@dirrmtry share/locale/fr/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/fr
+%%NLS%%@dirrmtry share/locale/fi/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/fi
+%%NLS%%@dirrmtry share/locale/eu/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/eu
+%%NLS%%@dirrmtry share/locale/es/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/es
+%%NLS%%@dirrmtry share/locale/el/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/el
+%%NLS%%@dirrmtry share/locale/de/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/de
+%%NLS%%@dirrmtry share/locale/da/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/da
+%%NLS%%@dirrmtry share/locale/cs/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/cs
+%%NLS%%@dirrmtry share/locale/ca/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ca
+%%NLS%%@dirrmtry share/locale/ast/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ast
+%%NLS%%@dirrmtry share/locale/am/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/am
@dirrmtry etc/xdg/xfce4/xfconf/xfce-perchannel-xml
@dirrmtry etc/xdg/xfce4/xfconf
@dirrmtry etc/xdg/xfce4
-@dirrmtry share/locale/ast/LC_MESSAGES
-@dirrmtry share/locale/ast
-@dirrmtry share/locale/kk/LC_MESSAGES
-@dirrmtry share/locale/kk
-@dirrmtry share/locale/ur/LC_MESSAGES
-@dirrmtry share/locale/ur
-@dirrmtry share/locale/ur_PK/LC_MESSAGES
-@dirrmtry share/locale/ur_PK
+@dirrmtry etc/xdg/autostart
+@dirrmtry etc/xdg
+