aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xfce4-wavelan-plugin
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-24 21:57:52 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-24 21:57:52 +0000
commitc98724bdca427936bf70b06ea974b921b41064bc (patch)
tree410e7a734355ab57c848126b5f91eadd03906415 /sysutils/xfce4-wavelan-plugin
parentf7c70a405f9f3cc4ba7d4308887be44430d5bd61 (diff)
downloadports-c98724bdca427936bf70b06ea974b921b41064bc.tar.gz
ports-c98724bdca427936bf70b06ea974b921b41064bc.zip
Notes
Diffstat (limited to 'sysutils/xfce4-wavelan-plugin')
-rw-r--r--sysutils/xfce4-wavelan-plugin/Makefile31
-rw-r--r--sysutils/xfce4-wavelan-plugin/distinfo2
-rw-r--r--sysutils/xfce4-wavelan-plugin/pkg-descr9
-rw-r--r--sysutils/xfce4-wavelan-plugin/pkg-plist4
4 files changed, 46 insertions, 0 deletions
diff --git a/sysutils/xfce4-wavelan-plugin/Makefile b/sysutils/xfce4-wavelan-plugin/Makefile
new file mode 100644
index 000000000000..84d8425625c3
--- /dev/null
+++ b/sysutils/xfce4-wavelan-plugin/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: xfce-wavelan-plugin
+# Date created: 22 May 2004
+# Whom: Manuel Rabade Garica <mig@mig-29.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-wavelan-plugin
+PORTVERSION= 0.3.2
+CATEGORIES= sysutils xfce
+MASTER_SITES= http://download.berlios.de/xfce-goodies/ \
+ http://matt.nerim.net/xfce-goodies/ \
+ http://xfce.org/~kelnos/mirrors/xfce-goodies/
+DIST_SUBDIR= xfce4
+
+MAINTAINER= mig@mig-29.net
+COMMENT= Displays various information about a WaveLAN device
+
+BUILD_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
+ xfce4util.1:${PORTSDIR}/x11/libxfce4util \
+ xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui
+RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+
+USE_GNOME= gtk20
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_LIBTOOL_VER=13
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/xfce4-wavelan-plugin/distinfo b/sysutils/xfce4-wavelan-plugin/distinfo
new file mode 100644
index 000000000000..93343efe5ae0
--- /dev/null
+++ b/sysutils/xfce4-wavelan-plugin/distinfo
@@ -0,0 +1,2 @@
+MD5 (xfce4/xfce4-wavelan-plugin-0.3.2.tar.gz) = 22d9b0fe28fb74222b04e23afb47c4f7
+SIZE (xfce4/xfce4-wavelan-plugin-0.3.2.tar.gz) = 523917
diff --git a/sysutils/xfce4-wavelan-plugin/pkg-descr b/sysutils/xfce4-wavelan-plugin/pkg-descr
new file mode 100644
index 000000000000..d2a7db88c0a0
--- /dev/null
+++ b/sysutils/xfce4-wavelan-plugin/pkg-descr
@@ -0,0 +1,9 @@
+WaveLAN plugin for the XFce4 panel.
+
+Displays various information about a WaveLAN device:
+
+* Signal state (tells if a carrier signal was detected)
+* Signal quality (current quality of the carrier signal)
+* Network name (current SSID of the WaveLAN network)
+
+WWW: http://xfce-goodies.berlios.de/
diff --git a/sysutils/xfce4-wavelan-plugin/pkg-plist b/sysutils/xfce4-wavelan-plugin/pkg-plist
new file mode 100644
index 000000000000..a263bb908177
--- /dev/null
+++ b/sysutils/xfce4-wavelan-plugin/pkg-plist
@@ -0,0 +1,4 @@
+lib/xfce4/panel-plugins/libwavelan.so
+lib/xfce4/panel-plugins/libwavelan.la
+lib/xfce4/panel-plugins/libwavelan.a
+@unexec rmdir %D/lib/xfce4/panel-plugins 2>/dev/null || true