aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xmbmon
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-06-21 22:09:38 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-06-21 22:09:38 +0000
commit3c1b8094f3dd4f92cceaaf70d41c555928a3993f (patch)
tree7f6cb6c502594dd3d9a63a8198cc6a120d5590c2 /sysutils/xmbmon
parent7d04da6fe4d0cc377f898d6f1d026bb83615827e (diff)
downloadports-3c1b8094f3dd4f92cceaaf70d41c555928a3993f.tar.gz
ports-3c1b8094f3dd4f92cceaaf70d41c555928a3993f.zip
Notes
Diffstat (limited to 'sysutils/xmbmon')
-rw-r--r--sysutils/xmbmon/Makefile10
-rw-r--r--sysutils/xmbmon/files/patch-Makefile.in6
-rw-r--r--sysutils/xmbmon/files/patch-configure10
-rw-r--r--sysutils/xmbmon/files/patch-getMB-smb_ioctl.c14
-rw-r--r--sysutils/xmbmon/files/patch-mbmon.c12
-rw-r--r--sysutils/xmbmon/files/patch-pci__pm.c12
-rw-r--r--sysutils/xmbmon/files/patch-pci__pm.h4
-rw-r--r--sysutils/xmbmon/files/patch-sens_lm85.c12
-rw-r--r--sysutils/xmbmon/files/patch-sens_winbond.c6
-rw-r--r--sysutils/xmbmon/files/patch-testsmb.c12
-rw-r--r--sysutils/xmbmon/files/patch-xmbmon.c4
-rw-r--r--sysutils/xmbmon/files/patch-xmbmon.resources8
12 files changed, 53 insertions, 57 deletions
diff --git a/sysutils/xmbmon/Makefile b/sysutils/xmbmon/Makefile
index 0bb2cf061c9f..8adfec65563b 100644
--- a/sysutils/xmbmon/Makefile
+++ b/sysutils/xmbmon/Makefile
@@ -13,7 +13,7 @@ COMMENT= MB monitor for LM78/79, W8378x, AS99127F, VT82C686 and ADM9240
LICENSE= BSD2CLAUSE
-PORTSCOUT= limit:^[0-9]+$
+PORTSCOUT= skipv:205conf
PATCH_SITES+= ${MASTER_SITES}
PATCHFILES+= ${PORTNAME}${PORTVERSION}_fflush.patch
@@ -29,6 +29,8 @@ OPTIONS_DEFAULT=SMB CLI
ASUS_DESC= Enable A7N8X-VM support
SMB_DESC= Enable smb(4) support
CLI_DESC= CLI support only
+X11_USE= XORG=x11,xt
+X11_MAKE_ARGS_OFF= PROGRAM="mbmon"
ASUS_PATCHFILES= ${PORTNAME}${PORTVERSION}_A7N8X-VM.patch
X11_PLIST_FILES= "@mode 4555"\
@@ -43,12 +45,6 @@ CLI_PLIST_FILES= "@mode 4555"\
.include <bsd.port.options.mk>
-.if !${PORT_OPTIONS:MX11}
-MAKE_ARGS= PROGRAM="mbmon"
-.else
-USE_XORG= x11 xt
-.endif
-
.if ${PORT_OPTIONS:MCLI}
USE_RC_SUBR= mbmon
.endif
diff --git a/sysutils/xmbmon/files/patch-Makefile.in b/sysutils/xmbmon/files/patch-Makefile.in
index daae964a5e80..08bf5beda534 100644
--- a/sysutils/xmbmon/files/patch-Makefile.in
+++ b/sysutils/xmbmon/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig Wed Feb 1 20:12:01 2006
-+++ Makefile.in Wed Feb 1 20:12:22 2006
-@@ -27,9 +27,9 @@
+--- Makefile.in.orig 2004-08-13 07:04:21 UTC
++++ Makefile.in
+@@ -27,9 +27,9 @@ LIBSX=$(LIBS) @X_LIBS@ -lXt @X_PRE_LIBS@
#CC=/compat/linux/usr/bin/gcc
CC=@CC@
diff --git a/sysutils/xmbmon/files/patch-configure b/sysutils/xmbmon/files/patch-configure
index 809c657fd978..dcd89bc5a716 100644
--- a/sysutils/xmbmon/files/patch-configure
+++ b/sysutils/xmbmon/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Wed Feb 1 20:34:58 2006
-+++ configure Wed Feb 1 20:35:38 2006
-@@ -3487,7 +3487,6 @@
+--- configure.orig 2004-08-13 07:22:18 UTC
++++ configure
+@@ -3487,7 +3487,6 @@ host_os=`echo $ac_cv_host | sed 's/^\([^
case "${host}" in
i?86-*-freebsd*)
@@ -8,7 +8,7 @@
;;
i?86-*-linux-*)
CC=gcc
-@@ -3499,7 +3498,6 @@
+@@ -3499,7 +3498,6 @@ case "${host}" in
ADDLIBS="-li386"
;;
*)
@@ -16,7 +16,7 @@
;;
esac
-@@ -3946,7 +3944,7 @@
+@@ -3946,7 +3944,7 @@ fi
done
diff --git a/sysutils/xmbmon/files/patch-getMB-smb_ioctl.c b/sysutils/xmbmon/files/patch-getMB-smb_ioctl.c
index 4100bd544d59..e6df0d911706 100644
--- a/sysutils/xmbmon/files/patch-getMB-smb_ioctl.c
+++ b/sysutils/xmbmon/files/patch-getMB-smb_ioctl.c
@@ -1,5 +1,5 @@
---- getMB-smb_ioctl.c.orig Sat Jul 5 18:15:24 2003
-+++ getMB-smb_ioctl.c Sat May 2 00:35:54 2015
+--- getMB-smb_ioctl.c.orig 2003-07-05 15:15:24 UTC
++++ getMB-smb_ioctl.c
@@ -5,6 +5,7 @@
#ifdef HAVE_SMBUS
/* assume SMBus ioctl support, only for FreeBSD */
@@ -20,7 +20,7 @@
#include "methods.h"
-@@ -42,10 +47,12 @@
+@@ -42,10 +47,12 @@ static char buf[128];
static int OpenIO()
{
@@ -34,7 +34,7 @@
if ((iosmb = open(smb_devfile, 000)) < 0) {
strcpy(buf, "ioctl(");
-@@ -125,7 +132,12 @@
+@@ -125,7 +132,12 @@ int smbioctl_readB(int slave, int addr)
char ret;
cmd.slave = slave;
cmd.cmd = addr;
@@ -47,7 +47,7 @@
if (ioctl(iosmb, SMB_READB, &cmd) == -1) {
/* strcpy(buf, "ioctl(");
strcat(buf, smb_devfile + 5);
-@@ -142,7 +154,11 @@
+@@ -142,7 +154,11 @@ void smbioctl_writeB(int slave, int addr
struct smbcmd cmd;
cmd.slave = slave;
cmd.cmd = addr;
@@ -59,7 +59,7 @@
if (ioctl(iosmb, SMB_WRITEB, &cmd) == -1) {
strcpy(buf, "ioctl(");
strcat(buf, smb_devfile + 5);
-@@ -158,7 +174,12 @@
+@@ -158,7 +174,12 @@ int smbioctl_readW(int smb_slave, int ad
short ret;
cmd.slave = smb_slave;
cmd.cmd = addr;
@@ -72,7 +72,7 @@
if (ioctl(iosmb, SMB_READW, &cmd) == -1) {
/* strcpy(buf, "ioctl(");
strcat(buf, smb_devfile + 5);
-@@ -175,7 +196,11 @@
+@@ -175,7 +196,11 @@ void smbioctl_writeW(int slave, int addr
struct smbcmd cmd;
cmd.slave = slave;
cmd.cmd = addr;
diff --git a/sysutils/xmbmon/files/patch-mbmon.c b/sysutils/xmbmon/files/patch-mbmon.c
index 30d759104011..c40f899f09f9 100644
--- a/sysutils/xmbmon/files/patch-mbmon.c
+++ b/sysutils/xmbmon/files/patch-mbmon.c
@@ -1,6 +1,6 @@
---- mbmon.c.orig 2004-08-13 16:23:32.000000000 +0900
-+++ mbmon.c 2009-06-10 12:13:47.000000000 +0900
-@@ -315,7 +315,7 @@
+--- mbmon.c.orig 2015-05-28 10:06:29 UTC
++++ mbmon.c
+@@ -315,7 +315,7 @@ int main(int argc, char *argv[])
name = argv[0];
#if !defined(LINUX) && defined(HAVE_SMBUS) && defined(SMBUS_IOCTL)
@@ -9,15 +9,15 @@
#else
while ((ch = getopt(argc,argv,"VSIAfdDYe:p:c:T:F:tunNirhP:")) != -1) {
#endif
-@@ -641,6 +641,7 @@
- fprintf(out, "%4d\n%4d\n%4d\n", rot1, rot2, rot3);
+@@ -642,6 +642,7 @@ int main(int argc, char *argv[])
}
+ fflush(out);
if (port) {
+ fflush(out);
#ifdef LOGGING
if (nfd)
#endif
-@@ -659,6 +660,7 @@
+@@ -660,6 +661,7 @@ int main(int argc, char *argv[])
if (hostname_flag == 1) {
hostname(sh_flag);
}
diff --git a/sysutils/xmbmon/files/patch-pci__pm.c b/sysutils/xmbmon/files/patch-pci__pm.c
index 0d808ac4014c..ca05d3a33f8d 100644
--- a/sysutils/xmbmon/files/patch-pci__pm.c
+++ b/sysutils/xmbmon/files/patch-pci__pm.c
@@ -1,6 +1,6 @@
---- pci_pm.c.orig 2004-08-17 22:38:04.000000000 +0600
-+++ pci_pm.c 2013-12-05 23:58:00.000000000 +0600
-@@ -64,7 +64,7 @@
+--- pci_pm.c.orig 2004-08-17 16:38:04 UTC
++++ pci_pm.c
+@@ -64,7 +64,7 @@ char *chk_smb_chip(int chip)
comt = "Intel8XX(ICH/ICH2/ICH3/ICH4/ICH5/ICH6)";
break;
case AMD756SMB:
@@ -9,7 +9,7 @@
break;
case NFORCESMB:
comt = "NVidia nForce";
-@@ -158,6 +158,7 @@
+@@ -158,6 +158,7 @@ int pci_pm_smb_prob(int *hwm_base, int *
case ID_I801CA:
case ID_I801DB:
case ID_I801EB:
@@ -17,7 +17,7 @@
case ID_I6300ESB:
case ID_IICH6:
ret = ICH801SMB;
-@@ -166,6 +167,7 @@
+@@ -166,6 +167,7 @@ int pci_pm_smb_prob(int *hwm_base, int *
case ID_AMD756:
case ID_AMD766:
case ID_AMD768:
@@ -25,7 +25,7 @@
ret = AMD756SMB;
inq_smbba = getSMBBA3;
break;
-@@ -182,7 +184,7 @@
+@@ -182,7 +184,7 @@ int pci_pm_smb_prob(int *hwm_base, int *
inq_smbba = getSMBBA4;
}
break;
diff --git a/sysutils/xmbmon/files/patch-pci__pm.h b/sysutils/xmbmon/files/patch-pci__pm.h
index 1317e05f293c..de87c5ba6954 100644
--- a/sysutils/xmbmon/files/patch-pci__pm.h
+++ b/sysutils/xmbmon/files/patch-pci__pm.h
@@ -1,5 +1,5 @@
---- pci_pm.h.orig 2004-07-14 21:02:49.000000000 +0600
-+++ pci_pm.h 2013-12-05 23:53:34.000000000 +0600
+--- pci_pm.h.orig 2004-07-14 15:02:49 UTC
++++ pci_pm.h
@@ -32,10 +32,10 @@
#define getSMBBA0 0x90 /* PIIX4, VIA596,686 */
#define getSMBBA1 0xD0 /* VT8233/A/C */
diff --git a/sysutils/xmbmon/files/patch-sens_lm85.c b/sysutils/xmbmon/files/patch-sens_lm85.c
index fa82b7413c17..0f0b6b75ac97 100644
--- a/sysutils/xmbmon/files/patch-sens_lm85.c
+++ b/sysutils/xmbmon/files/patch-sens_lm85.c
@@ -1,6 +1,6 @@
---- sens_lm85.c Mon Oct 13 10:12:58 2003
-+++ sens_lm85.c Wed Dec 21 15:37:56 2005
-@@ -53,7 +53,6 @@
+--- sens_lm85.c.orig 2003-10-13 07:12:58 UTC
++++ sens_lm85.c
+@@ -53,7 +53,6 @@ extern int numSMBSlave, canSMBSlave[128]
#define ADM_24FAN(nr) (0x28 + (nr))
#define ADM_24FANDIV 0x47
#define ADM_24MODE 0x16
@@ -8,7 +8,7 @@
#define ADM_EXTRES1 0x76
#define ADM_EXTRES2 0x77
#define ADM_FANPPR 0x7B
-@@ -213,7 +212,7 @@
+@@ -213,7 +212,7 @@ ret0:
static float lm85_temp( LM_METHODS *method, int no )
{
int n, ne;
@@ -17,7 +17,7 @@
if (no < 0 || 2 < no)
return 0xFFFF;
-@@ -226,18 +225,20 @@
+@@ -226,18 +225,20 @@ static float lm85_temp( LM_METHODS *meth
} else if (lm85chipid >= ADM1027) {
ne = method->Read(ADM_EXTRES2);
ext = 0.25 * ((ne >> ((no + 1) * 2)) & 0x03);
@@ -44,7 +44,7 @@
}
-@@ -262,10 +263,20 @@
+@@ -262,10 +263,20 @@ static float lm85_volt(LM_METHODS *metho
return 0xFFFF;
if (lm85chipid >= ADM1027) {
diff --git a/sysutils/xmbmon/files/patch-sens_winbond.c b/sysutils/xmbmon/files/patch-sens_winbond.c
index be172fc9fc23..f759b5e32685 100644
--- a/sysutils/xmbmon/files/patch-sens_winbond.c
+++ b/sysutils/xmbmon/files/patch-sens_winbond.c
@@ -1,6 +1,6 @@
---- sens_winbond.c Fri Jul 9 07:34:41 2004
-+++ sens_winbond.c Wed May 3 16:43:40 2006
-@@ -245,6 +244,8 @@
+--- sens_winbond.c.orig 2004-07-09 05:34:41 UTC
++++ sens_winbond.c
+@@ -245,6 +245,8 @@ printf("DEBUG 49:0x%02X 58:0x%02X 4Fl:0x
case 0x20: /* 0x20 (or 0x21) 627HF */
case 0x90: /* 0x90 (or 0x91?) 627THF */
case 0x1A: /* 0x1A (??) 627THF-A */
diff --git a/sysutils/xmbmon/files/patch-testsmb.c b/sysutils/xmbmon/files/patch-testsmb.c
index 7829f4274321..f8632814bf26 100644
--- a/sysutils/xmbmon/files/patch-testsmb.c
+++ b/sysutils/xmbmon/files/patch-testsmb.c
@@ -1,6 +1,6 @@
---- testsmb.c Thu Aug 12 07:34:48 2004
-+++ testsmb.c Fri Dec 30 23:11:29 2005
-@@ -105,8 +105,9 @@
+--- testsmb.c.orig 2004-08-12 04:34:48 UTC
++++ testsmb.c
+@@ -105,8 +105,9 @@ int main()
case ID_AMD756:
case ID_AMD766:
case ID_AMD768:
@@ -11,7 +11,7 @@
break;
case ID_NFORCE:
smbus = &smbus_amd;
-@@ -116,9 +117,9 @@
+@@ -116,9 +117,9 @@ int main()
smbus = &smbus_ali;
fprintf(stderr, "ALi M1535D+ found.\n");
break;
@@ -23,7 +23,7 @@
break;
case ID_NFORCE2:
smbus = &smbus_amd8;
-@@ -126,7 +127,7 @@
+@@ -126,7 +127,7 @@ int main()
break;
default:
fprintf(stderr, "No known SMBus(I2C) chip found.\n");
@@ -32,7 +32,7 @@
}
if(OpenIO() == -1) return -1;
-@@ -141,7 +142,6 @@
+@@ -141,7 +142,6 @@ int main()
}
CloseIO();
diff --git a/sysutils/xmbmon/files/patch-xmbmon.c b/sysutils/xmbmon/files/patch-xmbmon.c
index dafca35f6e8c..9a31c144750f 100644
--- a/sysutils/xmbmon/files/patch-xmbmon.c
+++ b/sysutils/xmbmon/files/patch-xmbmon.c
@@ -1,5 +1,5 @@
---- xmbmon.c.orig Thu Aug 12 06:37:03 2004
-+++ xmbmon.c Wed Feb 1 20:44:54 2006
+--- xmbmon.c.orig 2004-08-12 04:37:03 UTC
++++ xmbmon.c
@@ -23,16 +23,16 @@
#define RES_NAME "XMBmon"
diff --git a/sysutils/xmbmon/files/patch-xmbmon.resources b/sysutils/xmbmon/files/patch-xmbmon.resources
index 85d1e73a236b..b3e097c6f820 100644
--- a/sysutils/xmbmon/files/patch-xmbmon.resources
+++ b/sysutils/xmbmon/files/patch-xmbmon.resources
@@ -1,6 +1,6 @@
---- xmbmon.resources.orig Wed Feb 1 20:45:24 2006
-+++ xmbmon.resources Wed Feb 1 20:45:36 2006
-@@ -8,7 +8,7 @@
+--- xmbmon.resources.orig 2003-06-08 14:25:18 UTC
++++ xmbmon.resources
+@@ -8,7 +8,7 @@ XMBmon*translations: #override \
<Key>Q: quit_proc()
! Add the followings to users default resources if one wishes
XMBmon*geometry: 100x140
@@ -9,7 +9,7 @@
XMBmon*count: 4
XMBmon*sec: 20
XMBmon*wsec: 1800
-@@ -32,5 +32,5 @@
+@@ -32,5 +32,5 @@ XMBmon*fahrn: False
XMBmon*probe:
XMBmon*TyanTigerMP: False
XMBmon*label: