aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xvidcap/files
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-10-31 23:51:16 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-10-31 23:51:16 +0000
commite0467e5a541411e476bda555be372c46c3f6148f (patch)
tree31aa50ba4f76cf7bb0636e1f139de06af1fea097 /sysutils/xvidcap/files
parent635ff557f57bd3dc4b181a512b090794693b53bd (diff)
Notes
Diffstat (limited to 'sysutils/xvidcap/files')
-rw-r--r--sysutils/xvidcap/files/patch-configure55
-rw-r--r--sysutils/xvidcap/files/patch-ffmpeg_configure21
-rw-r--r--sysutils/xvidcap/files/patch-src::Makefile.in27
-rw-r--r--sysutils/xvidcap/files/patch-src::capture.c11
4 files changed, 46 insertions, 68 deletions
diff --git a/sysutils/xvidcap/files/patch-configure b/sysutils/xvidcap/files/patch-configure
index 4885a826f91c..46f5ffaa8512 100644
--- a/sysutils/xvidcap/files/patch-configure
+++ b/sysutils/xvidcap/files/patch-configure
@@ -1,34 +1,29 @@
---- configure.orig Sat Jan 1 23:53:48 2005
-+++ configure Sun Jan 2 22:05:19 2005
-@@ -5297,7 +5297,7 @@
+--- configure.orig Mon Oct 30 09:11:11 2006
++++ configure Tue Oct 31 19:26:30 2006
+@@ -9078,7 +9078,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lXmu $LIBS"
++LIBS="-L$x_libraries -lXmu $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -9140,7 +9140,7 @@
+ #define HAVE_LIBXMU 1
+ _ACEOF
+
+- LIBS="-lXmu $LIBS"
++ LIBS="-L$x_libraries -lXmu $LIBS"
+
+ else
+ unset ac_cv_lib_Xmu_XmuClientWindow; echo "Couldn't find libXmu in LD_LIBRARY_PATH, checking X11 paths"; echo "$as_me:$LINENO: checking for XmuClientWindow in -lXmu" >&5
+@@ -9513,7 +9513,7 @@
# if cache empty (not tested or failed) and want static avcodec (then it failed) ...
- if ( `test \( \( x${ac_cv_lib_avcodec_img_convert+set} = x \) -a \( x$static_avcodec = xyes \) \)` ) ; then
+ if ( `test \( \( x${ac_cv_lib_avutil_av_rescale+set} = x \) -a \( x$static_avutil = xyes \) \)` ) ; then
# build embedded ffmpeg
-- echo "${MAKE-make}-ing prerequisite ffmpeg libraries" && ( cd ./ffmpeg/ && ./configure --disable-ffserver --disable-ffplay && ln -s libavcodec/avcodec.h && ln -s libavformat/avformat.h && ln -s libavformat/avio.h && ln -s libavformat/rt*.h ./ && ${MAKE-make} )
-+ echo "${MAKE-make}-ing prerequisite ffmpeg libraries" && ( cd ./ffmpeg/ && ./configure --cc=$CC --extra-libs=-lm --disable-opts --disable-ffserver --disable-ffplay && ln -s libavcodec/avcodec.h && ln -s libavformat/avformat.h && ln -s libavformat/avio.h && ln -s libavformat/rt*.h ./ && ${MAKE-gmake} )
+- echo "${MAKE-make}-ing prerequisite ffmpeg libraries" && ( cd ./ffmpeg/ && ./configure --cc=${CC} --enable-gpl ${ac_my_ffmpeg_cfg_lame_switch} --enable-pthreads --enable-swscaler --disable-ffserver --disable-ffplay && ln -s libavcodec/avcodec.h && ln -s libavformat/avformat.h && ln -s libavformat/avio.h && ln -s libavformat/rt*.h ./ && ln -s libavutil/common.h ./ && ln -s libavutil/avutil.h ./ && ln -s libavutil/mathematics.h ./ && ln -s libavutil/int*.h ./ && ln -s libavutil/rational.h ./ && ln -s libswscale/swscale.h ./ && ln -s libswscale/rgb2rgb.h . && ${MAKE-make} )
++ echo "${MAKE-make}-ing prerequisite ffmpeg libraries" && ( cd ./ffmpeg/ && ./configure --cc=${CC} --extra-libs=-lm --disable-opts --enable-gpl ${ac_my_ffmpeg_cfg_lame_switch} --enable-pthreads --enable-swscaler --disable-ffserver --disable-ffplay && ln -s libavcodec/avcodec.h && ln -s libavformat/avformat.h && ln -s libavformat/avio.h && ln -s libavformat/rt*.h ./ && ln -s libavutil/common.h ./ && ln -s libavutil/avutil.h ./ && ln -s libavutil/mathematics.h ./ && ln -s libavutil/int*.h ./ && ln -s libavutil/rational.h ./ && ln -s libswscale/swscale.h ./ && ln -s libswscale/rgb2rgb.h . && ${MAKE-make} )
+ #echo "${MAKE-make}-ing prerequisite ffmpeg libraries" && ( cd ./ffmpeg/ && ./configure --cc=${CC} ${ac_my_ffmpeg_cfg_lame_switch} --enable-pthreads --disable-ffserver --disable-ffplay && ln -s libavcodec/avcodec.h && ln -s libavformat/avformat.h && ln -s libavformat/avio.h && ln -s libavformat/rt*.h ./ && ln -s libavutil/common.h ./ && ln -s libavutil/avutil.h ./ && ln -s libavutil/mathematics.h ./ && ln -s libavutil/int*.h ./ && ln -s libavutil/rational.h ./ && ${MAKE-make} )
# try to link it statically, or reset cache, set static_avcodec=no
top_srcdir=`pwd`
- ac_my_ldflags_save=${LDFLAGS} ; LDFLAGS="${LDFLAGS} -L$top_srcdir/ffmpeg/libavcodec -L$top_srcdir/ffmpeg/libavformat"
-@@ -5658,9 +5658,6 @@
-
- echo "$as_me:$LINENO: checking for audio_init in -lavformat" >&5
- echo $ECHO_N "checking for audio_init in -lavformat... $ECHO_C" >&6
--if test "${ac_cv_lib_avformat_audio_init+set}" = set; then
-- echo $ECHO_N "(cached) $ECHO_C" >&6
--else
-
- echo -n "(static?) ... "
- ac_check_lib_save_LIBS=$LIBS
-@@ -5722,11 +5719,8 @@
- fi
- echo "$as_me:$LINENO: result: $ac_cv_lib_avformat_audio_init" >&5
- echo "${ECHO_T}$ac_cv_lib_avformat_audio_init" >&6
--else
-- ac_cv_lib_avformat_audio_init=no
--fi
-
--if test $ac_cv_lib_avformat_audio_init = yes; then
-+if test x$ac_cv_lib_avformat_audio_init = xyes; then
- ac_my_have_ffmpeg_audio="1"
- else
- unset ac_cv_lib_avformat_audio_init ; echo "$as_me:$LINENO: checking for audio_init in -lavformat" >&5
diff --git a/sysutils/xvidcap/files/patch-ffmpeg_configure b/sysutils/xvidcap/files/patch-ffmpeg_configure
new file mode 100644
index 000000000000..f156b07c7258
--- /dev/null
+++ b/sysutils/xvidcap/files/patch-ffmpeg_configure
@@ -0,0 +1,21 @@
+--- ffmpeg/configure.orig Wed Oct 25 21:31:11 2006
++++ ffmpeg/configure Mon Oct 30 23:32:55 2006
+@@ -556,7 +556,7 @@
+ audio_oss="yes"
+ dv1394="no"
+ make="gmake"
+-add_cflags "-pthread"
++add_cflags "-fomit-frame-pointer"
+ ;;
+ GNU/kFreeBSD)
+ v4l="no"
+@@ -1514,9 +1514,6 @@
+ check_cflags -Wall
+ check_cflags -Wno-switch
+ check_cflags -Wdisabled-optimization
+-check_cflags -Wpointer-arith
+-check_cflags -Wredundant-decls
+-check_cflags -Winline
+
+ # add some linker flags
+ check_ldflags '-Wl,-rpath-link,\$(BUILD_ROOT)/libavcodec' '-Wl,-rpath-link,\$(BUILD_ROOT)/libavformat' '-Wl,-rpath-link,\$(BUILD_ROOT)/libavutil'
diff --git a/sysutils/xvidcap/files/patch-src::Makefile.in b/sysutils/xvidcap/files/patch-src::Makefile.in
deleted file mode 100644
index e80ac02d8efb..000000000000
--- a/sysutils/xvidcap/files/patch-src::Makefile.in
+++ /dev/null
@@ -1,27 +0,0 @@
---- src/Makefile.in.orig Sat Jan 1 23:53:52 2005
-+++ src/Makefile.in Sun Jan 2 16:46:20 2005
-@@ -180,9 +180,9 @@
- sysconfdir = @sysconfdir@
- target_alias = @target_alias@
-
--AM_CFLAGS = @X_CFLAGS@ -DVERSION=\"@PACKAGE_VERSION@\" $(am__append_1)
-+AM_CFLAGS = @X_CFLAGS@ -DVERSION=\"@PACKAGE_VERSION@\" @PTHREAD_CFLAGS@ $(am__append_1)
-
--AM_LDFLAGS = @X_LIBS@ $(am__append_2) $(am__append_3)
-+AM_LDFLAGS = @X_LIBS@ @PTHREAD_LIBS@ $(am__append_2) $(am__append_3) -lm
-
-
- # specific xvidcap / gvidcap
-@@ -1805,9 +1805,9 @@
-
-
- install-data-hook:
-- mkdir -p ${datadir}/doc/${PACKAGE_TARNAME}_${PACKAGE_VERSION}
-- ./mkresfile.sh > XVidcap.ad && cp XVidcap.ad ${datadir}/doc/${PACKAGE_TARNAME}_${PACKAGE_VERSION}
-- cp ../README ../NEWS ../TODO ../INSTALL ../AUTHORS ../ChangeLog ${datadir}/doc/${PACKAGE_TARNAME}_${PACKAGE_VERSION}
-+ mkdir -p ${datadir}/doc/${PACKAGE_TARNAME}
-+ ./mkresfile.sh > XVidcap.ad && cp XVidcap.ad ${datadir}/doc/${PACKAGE_TARNAME}
-+ cp ../README ../NEWS ../TODO ../INSTALL ../AUTHORS ../ChangeLog ${datadir}/doc/${PACKAGE_TARNAME}
-
- uninstall-hook:
- rm -rf ${datadir}/doc/${PACKAGE_TARNAME}_${PACKAGE_VERSION}
diff --git a/sysutils/xvidcap/files/patch-src::capture.c b/sysutils/xvidcap/files/patch-src::capture.c
deleted file mode 100644
index 8d5db526a5ff..000000000000
--- a/sysutils/xvidcap/files/patch-src::capture.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/capture.c.orig Mon Mar 15 18:34:42 2004
-+++ src/capture.c Sun Jan 2 18:00:09 2005
-@@ -662,7 +662,7 @@
- #ifdef HAVE_FDATASYNC
- fdatasync(fileno(fp));
- #else
-- fsync(fileno(fp));
-+ fsync(fileno((FILE *) fp));
- #endif // HAVE_FDATASYNC
- }
-