aboutsummaryrefslogtreecommitdiff
path: root/sysutils/zisofs-tools
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-07 22:11:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-07 22:11:23 +0000
commit8c28316590e4fe958d2457816e89fcfaae471119 (patch)
treef928cfcb1548fd49c54c69ce2af75976a5691d49 /sysutils/zisofs-tools
parent1a0ddbb514d29a46cdb0c681954066f9208777c8 (diff)
downloadports-8c28316590e4fe958d2457816e89fcfaae471119.tar.gz
ports-8c28316590e4fe958d2457816e89fcfaae471119.zip
Notes
Diffstat (limited to 'sysutils/zisofs-tools')
-rw-r--r--sysutils/zisofs-tools/Makefile32
-rw-r--r--sysutils/zisofs-tools/distinfo1
-rw-r--r--sysutils/zisofs-tools/files/patch-compress.c10
-rw-r--r--sysutils/zisofs-tools/files/patch-walk.c10
-rw-r--r--sysutils/zisofs-tools/pkg-descr9
-rw-r--r--sysutils/zisofs-tools/pkg-plist5
6 files changed, 67 insertions, 0 deletions
diff --git a/sysutils/zisofs-tools/Makefile b/sysutils/zisofs-tools/Makefile
new file mode 100644
index 000000000000..b1a67e356903
--- /dev/null
+++ b/sysutils/zisofs-tools/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: zisofs-tools
+# Date created: 24 Nov 2003
+# Whom: Nosov Artem <chip-set@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zisofs-tools
+PORTVERSION= 1.0.4
+CATEGORIES= sysutils
+MASTER_SITES= http://www.kernel.org/pub/linux/utils/fs/zisofs/
+
+MAINTAINER= chip-set@mail.ru
+COMMENT= User utilities for zisofs
+
+USE_AUTOCONF_VER= 253
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GETOPT_LONG= yes
+GNU_CONFIGURE= yes
+
+MAN1= mkzftree.1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in CHANGES README INSTALL
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/zisofs-tools/distinfo b/sysutils/zisofs-tools/distinfo
new file mode 100644
index 000000000000..8ab2d42726a4
--- /dev/null
+++ b/sysutils/zisofs-tools/distinfo
@@ -0,0 +1 @@
+MD5 (zisofs-tools-1.0.4.tar.bz2) = 2a208a774245074223146a87dc94e550
diff --git a/sysutils/zisofs-tools/files/patch-compress.c b/sysutils/zisofs-tools/files/patch-compress.c
new file mode 100644
index 000000000000..1c7066e22da3
--- /dev/null
+++ b/sysutils/zisofs-tools/files/patch-compress.c
@@ -0,0 +1,10 @@
+--- compress.c.orig Mon Nov 24 13:26:57 2003
++++ compress.c Mon Nov 24 13:27:06 2003
+@@ -13,6 +13,7 @@
+
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <time.h>
+ #include <utime.h>
+ #include <unistd.h>
+ #include <zlib.h>
diff --git a/sysutils/zisofs-tools/files/patch-walk.c b/sysutils/zisofs-tools/files/patch-walk.c
new file mode 100644
index 000000000000..268545311cc2
--- /dev/null
+++ b/sysutils/zisofs-tools/files/patch-walk.c
@@ -0,0 +1,10 @@
+--- walk.c.orig Mon Nov 24 13:25:24 2003
++++ walk.c Mon Nov 24 13:25:40 2003
+@@ -20,6 +20,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <limits.h>
++#include <time.h>
+ #include <utime.h>
+ #include <string.h>
+ #include <errno.h>
diff --git a/sysutils/zisofs-tools/pkg-descr b/sysutils/zisofs-tools/pkg-descr
new file mode 100644
index 000000000000..0fc1fadd5338
--- /dev/null
+++ b/sysutils/zisofs-tools/pkg-descr
@@ -0,0 +1,9 @@
+The zisofs filesystem is an extension to the ISO9660 filesystem that allows
+files, on a file-by-file basis, to be stored compressed and decompressed in
+real time. The zisofs filesystem is supported by recent versions of Linux
+(2.4.14 or later).
+
+mkzftree - creates a zisofs/RockRidge compressed file tree
+
+- Nosov Artem
+chip-set@mail.ru
diff --git a/sysutils/zisofs-tools/pkg-plist b/sysutils/zisofs-tools/pkg-plist
new file mode 100644
index 000000000000..9eb3a0200fc1
--- /dev/null
+++ b/sysutils/zisofs-tools/pkg-plist
@@ -0,0 +1,5 @@
+bin/mkzftree
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%@dirrm %%DOCSDIR%%