aboutsummaryrefslogtreecommitdiff
path: root/sysutils/zisofs-tools
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2008-02-06 17:34:38 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2008-02-06 17:34:38 +0000
commitc05b93713e7cb296bea99be38589a6efa199bbcb (patch)
tree4ec308a30beecd15c4c4ba56aae5a72b7f3d9ca5 /sysutils/zisofs-tools
parent67b17690d290df0719eb73de58eb535fc319e3d6 (diff)
downloadports-c05b93713e7cb296bea99be38589a6efa199bbcb.tar.gz
ports-c05b93713e7cb296bea99be38589a6efa199bbcb.zip
Notes
Diffstat (limited to 'sysutils/zisofs-tools')
-rw-r--r--sysutils/zisofs-tools/Makefile15
-rw-r--r--sysutils/zisofs-tools/distinfo6
-rw-r--r--sysutils/zisofs-tools/files/patch-compress.c8
3 files changed, 16 insertions, 13 deletions
diff --git a/sysutils/zisofs-tools/Makefile b/sysutils/zisofs-tools/Makefile
index 5da648a1d7f5..c0ce879e20df 100644
--- a/sysutils/zisofs-tools/Makefile
+++ b/sysutils/zisofs-tools/Makefile
@@ -6,15 +6,14 @@
#
PORTNAME= zisofs-tools
-PORTVERSION= 1.0.7
-PORTREVISION= 1
+PORTVERSION= 1.0.8
CATEGORIES= sysutils
MASTER_SITES= http://www.kernel.org/pub/linux/utils/fs/zisofs/
MAINTAINER= chip-set@mail.ru
COMMENT= User utilities for zisofs
-PORTDOCS= README CHANGES INSTALL
+PORTDOCS= CHANGES COPYING INSTALL MRULES README
USE_AUTOTOOLS= autoconf:261
USE_BZIP2= yes
@@ -28,12 +27,16 @@ MAN1= mkzftree.1
PLIST_FILES= bin/mkzftree
+OPTIONS= LFS "Enable Large Files Support" on
+
+.if defined(WITHOUT_LFS)
+CONFIGURE_ARGS+= --disable-largefile
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
.endif
.include <bsd.port.mk>
diff --git a/sysutils/zisofs-tools/distinfo b/sysutils/zisofs-tools/distinfo
index dc1741f1644f..494f4e8a02a7 100644
--- a/sysutils/zisofs-tools/distinfo
+++ b/sysutils/zisofs-tools/distinfo
@@ -1,3 +1,3 @@
-MD5 (zisofs-tools-1.0.7.tar.bz2) = ce2abdd5bd139242b4a3e0abb42928d4
-SHA256 (zisofs-tools-1.0.7.tar.bz2) = b2b4b5eb2facf06963a1c871e2d3157b18fbf202311f26893d35c379b9c27dc9
-SIZE (zisofs-tools-1.0.7.tar.bz2) = 53176
+MD5 (zisofs-tools-1.0.8.tar.bz2) = 2d0ed8c9a1f60b45f949b136f9be1f6c
+SHA256 (zisofs-tools-1.0.8.tar.bz2) = ae4e53e4914934d41660248fb59d3c8761f1f1fd180d5ec993c17ddb3afd04f3
+SIZE (zisofs-tools-1.0.8.tar.bz2) = 52968
diff --git a/sysutils/zisofs-tools/files/patch-compress.c b/sysutils/zisofs-tools/files/patch-compress.c
index 87824b47494e..3606d9f3be0e 100644
--- a/sysutils/zisofs-tools/files/patch-compress.c
+++ b/sysutils/zisofs-tools/files/patch-compress.c
@@ -1,6 +1,6 @@
---- compress.c.orig Tue Jul 31 07:20:52 2001
-+++ compress.c Fri May 13 21:17:02 2005
-@@ -13,7 +13,7 @@
+--- compress.c.old 2008-01-17 17:19:55.000000000 -0200
++++ compress.c 2008-01-17 17:20:09.000000000 -0200
+@@ -15,7 +15,7 @@
#include <stdlib.h>
#include <stdio.h>
@@ -8,4 +8,4 @@
+#include <time.h>
#include <unistd.h>
#include <zlib.h>
- #include "mkzftree.h"
+