aboutsummaryrefslogtreecommitdiff
path: root/sysutils/zogftw
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-09 14:00:30 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-09 14:00:30 +0000
commit9a107beac56d9153f413398df0a3374332ebbeac (patch)
tree8e8d420cdebd40ede995798d9796f09453d532b1 /sysutils/zogftw
parentd2ea8253b9b078a941c254c7c1d25705e19b7c60 (diff)
downloadports-9a107beac56d9153f413398df0a3374332ebbeac.tar.gz
ports-9a107beac56d9153f413398df0a3374332ebbeac.zip
Notes
Diffstat (limited to 'sysutils/zogftw')
-rw-r--r--sysutils/zogftw/Makefile35
-rw-r--r--sysutils/zogftw/distinfo2
-rw-r--r--sysutils/zogftw/pkg-descr14
3 files changed, 51 insertions, 0 deletions
diff --git a/sysutils/zogftw/Makefile b/sysutils/zogftw/Makefile
new file mode 100644
index 000000000000..88dc8c6e8c18
--- /dev/null
+++ b/sysutils/zogftw/Makefile
@@ -0,0 +1,35 @@
+# Created by: Fabian Keil <fk@fabiankeil.de>
+# $FreeBSD$
+
+PORTNAME= zogftw
+PORTVERSION= 0.0.2013.01.08
+CATEGORIES= sysutils
+MASTER_SITES= http://www.fabiankeil.de/sourcecode/zogftw/
+DISTNAME= ${PORTNAME}-2013-01-08-ebee83e
+
+MAINTAINER= fk@fabiankeil.de
+COMMENT= Creates redundant backups on encrypted ZFS pools
+
+RUN_DEPENDS= mbuffer:${PORTSDIR}/misc/mbuffer \
+ sudo:${PORTSDIR}/security/sudo
+
+OPTIONS_DEFINE= GNUPG
+OPTIONS_DEFAULT= GNUPG
+
+PLIST_FILES= sbin/zogftw
+
+MAN8= zogftw.8
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGNUPG}
+RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg1 \
+ gpg-agent:${PORTSDIR}/security/gnupg
+.endif
+
+do-build:
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/zogftw ${PREFIX}/sbin/zogftw
+ ${INSTALL_MAN} ${WRKSRC}/zogftw.8 ${MAN8PREFIX}/man/man8
+
+.include <bsd.port.mk>
diff --git a/sysutils/zogftw/distinfo b/sysutils/zogftw/distinfo
new file mode 100644
index 000000000000..0abe83474e40
--- /dev/null
+++ b/sysutils/zogftw/distinfo
@@ -0,0 +1,2 @@
+SHA256 (zogftw-2013-01-08-ebee83e.tar.gz) = 892bfbda2c193c25cb27b6f7941ebf2581ba6f7174a804ce6f2e3a8f778c4aad
+SIZE (zogftw-2013-01-08-ebee83e.tar.gz) = 15292
diff --git a/sysutils/zogftw/pkg-descr b/sysutils/zogftw/pkg-descr
new file mode 100644
index 000000000000..d0289fe502bc
--- /dev/null
+++ b/sysutils/zogftw/pkg-descr
@@ -0,0 +1,14 @@
+zogftw makes using multiple geli-encrypted single-vdev ZFS pools
+for backups more convenient, mainly by automating creation, import
+and export of such pools and by synchronizing datasets without the
+user having to manually specify the names of the snapshots that
+should be sent.
+
+geli passphrases can be stored gpg-encrypted which allows importing
+several pools in a row without having to specify each passphrase
+manually.
+
+zogftw is extendable in shell. It can be sourced from other shell
+scripts or interactive shells.
+
+WWW: http://www.fabiankeil.de/gehacktes/zogftw/