aboutsummaryrefslogtreecommitdiff
path: root/sysutils/zol/Makefile
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2019-03-04 15:59:12 +0000
committerKris Moore <kmoore@FreeBSD.org>2019-03-04 15:59:12 +0000
commit6873795c6922686b0a86faffb52ba97f5201728c (patch)
treeec92921092bb9072bfe20325e38199a77b63035c /sysutils/zol/Makefile
parentf407de7a3196c0fee783df5ac62887476be86954 (diff)
downloadports-6873795c6922686b0a86faffb52ba97f5201728c.tar.gz
ports-6873795c6922686b0a86faffb52ba97f5201728c.zip
Notes
Diffstat (limited to 'sysutils/zol/Makefile')
-rw-r--r--sysutils/zol/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/sysutils/zol/Makefile b/sysutils/zol/Makefile
new file mode 100644
index 000000000000..62f65790e83e
--- /dev/null
+++ b/sysutils/zol/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= zol
+PORTVERSION= 2019030100
+DISTVERSIONPREFIX= v
+CATEGORIES= sysutils
+
+MAINTAINER= kmoore@FreeBSD.org
+COMMENT= ZFS
+
+LICENSE= CDDL
+
+RUN_DEPENDS= zol-kmod>=0:sysutils/zol-kmod
+
+USES= autoreconf:build libtool gmake gettext-runtime:run
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} --with-config="user"
+
+OPTIONS_DEFINE= DEBUG
+OPTIONS_SUB= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= zfsonfreebsd
+GH_PROJECT= ZoF
+GH_TAGNAME= e10a5fb
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1300013
+IGNORE= needs FreeBSD 13 with AES-CCM support
+.endif
+
+.if ${PORT_OPTIONS:MDEBUG}
+CONFIGURE_ARGS+= --enable-debug --enable-debuginfo
+.endif
+
+pre-configure:
+ cd ${WRKSRC} && ./autogen.sh
+
+.include <bsd.port.post.mk>