aboutsummaryrefslogtreecommitdiff
path: root/sysutils/zxfer
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-04-04 15:03:51 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-04-04 15:03:51 +0000
commitbccf5e9212eafe55d694cb3583f3bb2d2776ffdb (patch)
treef30f9634ae71e33c6fdc195896f37ebfe5d3ee5d /sysutils/zxfer
parent70f5b467d0c07468addd0d75e5c9035867c4095e (diff)
Notes
Diffstat (limited to 'sysutils/zxfer')
-rw-r--r--sysutils/zxfer/Makefile32
-rw-r--r--sysutils/zxfer/distinfo2
-rw-r--r--sysutils/zxfer/pkg-descr24
3 files changed, 58 insertions, 0 deletions
diff --git a/sysutils/zxfer/Makefile b/sysutils/zxfer/Makefile
new file mode 100644
index 000000000000..7222ddc0afb7
--- /dev/null
+++ b/sysutils/zxfer/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: zxfer
+# Date created: 02 April 2011
+# Whom: Ivan Dreckman <ivannashdreckman@fastmail.fm>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zxfer
+PORTVERSION= 0.9.6
+CATEGORIES= sysutils
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= ivannashdreckman@fastmail.fm
+COMMENT= Easily and reliably transfer ZFS filesystems
+
+RUN_DEPENDS= ${LOCALBASE}/bin/rsync:${PORTSDIR}/net/rsync
+
+USE_BZIP2= yes
+NO_BUILD= yes
+
+LICENSE= BSD
+
+PLIST_FILES= sbin/zxfer
+
+MAN8= zxfer.8
+MANCOMPRESSED= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/zxfer ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/zxfer.8.gz ${MAN8PREFIX}/man/man8
+
+.include <bsd.port.mk>
diff --git a/sysutils/zxfer/distinfo b/sysutils/zxfer/distinfo
new file mode 100644
index 000000000000..878b2be8dba2
--- /dev/null
+++ b/sysutils/zxfer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (zxfer-0.9.6.tar.bz2) = d64d08bdff513ebe391f8aa3361636a328670cb5179a36fedb1de144cc18c6f1
+SIZE (zxfer-0.9.6.tar.bz2) = 44871
diff --git a/sysutils/zxfer/pkg-descr b/sysutils/zxfer/pkg-descr
new file mode 100644
index 000000000000..a698092ed2fa
--- /dev/null
+++ b/sysutils/zxfer/pkg-descr
@@ -0,0 +1,24 @@
+Zxfer is a fork of zfs-replicate. It allows the easy and reliable backup,
+restore or transfer of zfs filesystems, either locally or remotely.
+
+Zxfer has the following features:
+ * Written in sh with only one dependency, rsync. Rsync mode is not used
+ in a typical restore, hence in that situation all you need is the
+ zxfer script, your backup and an install CD/DVD.
+ * Reliability is first priority - the only methods of transfer allowed
+ are those that checksum/hash the transferred data.
+ * Transfer to or from a remote host via ssh.
+ * Recursive and incremental transfer of filesystems (via snapshots).
+ * Transfer properties and sources of those properties (e.g. local or
+ inherited).
+ * Override properties in the transfer, e.g. for archival purposes
+ it is useful to override "copies" and "compression".
+ * Create all filesystems on the destination as necessary.
+ * Write backup files to aid in automatically restoring the original
+ properties that have been overridden.
+ * A comprehensive man page with examples.
+ * Can be set to beep on error or when done, useful for long transfers.
+ * Features an rsync mode for when two different snapshotting regimes are on
+ source and destination, and zfs send/receive won't work.
+
+WWW: http://www.zxfer.org