aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-03-30 09:07:53 +0000
committerWill Andrews <will@FreeBSD.org>2002-03-30 09:07:53 +0000
commit97e6d164088095904ab49eafe23f9e1c67c494de (patch)
tree2a01fc85decccff8ce009661334e22692c899251 /sysutils
parent8b392d97c6346a46347c1582408f145698da0544 (diff)
downloadports-97e6d164088095904ab49eafe23f9e1c67c494de.tar.gz
ports-97e6d164088095904ab49eafe23f9e1c67c494de.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/kdeadmin/Makefile8
-rw-r--r--sysutils/kdeadmin3/Makefile8
-rw-r--r--sysutils/kdeadmin4/Makefile8
-rw-r--r--sysutils/kdf/Makefile8
-rw-r--r--sysutils/kfloppy/Makefile8
-rw-r--r--sysutils/sweeper/Makefile8
6 files changed, 42 insertions, 6 deletions
diff --git a/sysutils/kdeadmin/Makefile b/sysutils/kdeadmin/Makefile
index cf8832c0e7d3..01435bfaaeef 100644
--- a/sysutils/kdeadmin/Makefile
+++ b/sysutils/kdeadmin/Makefile
@@ -23,6 +23,12 @@ USE_GMAKE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500029
+_NO_KDE_OBJPRELINK=yes
+.endif
+
.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
pre-configure:
@@ -39,4 +45,4 @@ pre-configure:
find ${WRKSRC}/kpackage -name "*.cpp" -or -name "*.c" -or -name "*.h" \
| xargs ${PERL} -pi -e "s#typedef __off64_t off64_t;##g"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/kdeadmin3/Makefile b/sysutils/kdeadmin3/Makefile
index cf8832c0e7d3..01435bfaaeef 100644
--- a/sysutils/kdeadmin3/Makefile
+++ b/sysutils/kdeadmin3/Makefile
@@ -23,6 +23,12 @@ USE_GMAKE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500029
+_NO_KDE_OBJPRELINK=yes
+.endif
+
.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
pre-configure:
@@ -39,4 +45,4 @@ pre-configure:
find ${WRKSRC}/kpackage -name "*.cpp" -or -name "*.c" -or -name "*.h" \
| xargs ${PERL} -pi -e "s#typedef __off64_t off64_t;##g"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/kdeadmin4/Makefile b/sysutils/kdeadmin4/Makefile
index cf8832c0e7d3..01435bfaaeef 100644
--- a/sysutils/kdeadmin4/Makefile
+++ b/sysutils/kdeadmin4/Makefile
@@ -23,6 +23,12 @@ USE_GMAKE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500029
+_NO_KDE_OBJPRELINK=yes
+.endif
+
.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
pre-configure:
@@ -39,4 +45,4 @@ pre-configure:
find ${WRKSRC}/kpackage -name "*.cpp" -or -name "*.c" -or -name "*.h" \
| xargs ${PERL} -pi -e "s#typedef __off64_t off64_t;##g"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/kdf/Makefile b/sysutils/kdf/Makefile
index 858ca8e566a6..fd18c7ac3fb0 100644
--- a/sysutils/kdf/Makefile
+++ b/sysutils/kdf/Makefile
@@ -24,6 +24,12 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
MAN1= efax.1 efix.1 fax.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500029
+_NO_KDE_OBJPRELINK=yes
+.endif
+
.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
pre-configure:
@@ -37,4 +43,4 @@ pre-configure:
cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
${GMAKE} -f Makefile.cvs
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/kfloppy/Makefile b/sysutils/kfloppy/Makefile
index 858ca8e566a6..fd18c7ac3fb0 100644
--- a/sysutils/kfloppy/Makefile
+++ b/sysutils/kfloppy/Makefile
@@ -24,6 +24,12 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
MAN1= efax.1 efix.1 fax.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500029
+_NO_KDE_OBJPRELINK=yes
+.endif
+
.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
pre-configure:
@@ -37,4 +43,4 @@ pre-configure:
cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
${GMAKE} -f Makefile.cvs
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/sweeper/Makefile b/sysutils/sweeper/Makefile
index 858ca8e566a6..fd18c7ac3fb0 100644
--- a/sysutils/sweeper/Makefile
+++ b/sysutils/sweeper/Makefile
@@ -24,6 +24,12 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
MAN1= efax.1 efix.1 fax.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500029
+_NO_KDE_OBJPRELINK=yes
+.endif
+
.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
pre-configure:
@@ -37,4 +43,4 @@ pre-configure:
cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
${GMAKE} -f Makefile.cvs
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>