aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorLars Koeller <lkoeller@FreeBSD.org>2004-02-08 18:36:40 +0000
committerLars Koeller <lkoeller@FreeBSD.org>2004-02-08 18:36:40 +0000
commit8095c6b9fe321f4d593a7ca0b84ec0cdade357dd (patch)
tree3c64dfa56d0158edd90cc33404dc63ae7a131147 /sysutils
parentfe6254122ae9a573d1728dee0bbcb51957b3e75f (diff)
downloadports-8095c6b9fe321f4d593a7ca0b84ec0cdade357dd.tar.gz
ports-8095c6b9fe321f4d593a7ca0b84ec0cdade357dd.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/bacula-server/Makefile9
-rw-r--r--sysutils/bacula/Makefile9
2 files changed, 12 insertions, 6 deletions
diff --git a/sysutils/bacula-server/Makefile b/sysutils/bacula-server/Makefile
index 060be1e89513..f7599efd3bb1 100644
--- a/sysutils/bacula-server/Makefile
+++ b/sysutils/bacula-server/Makefile
@@ -36,6 +36,11 @@ CONFIGURE_ARGS= --with-tcp-wrappers=/usr/lib \
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+OPTIONS= CLIENT_ONLY "Build bacule file daemon only" off
+OPTIONS+= MYSQL "Build for MySQL database instead of SqLite" off
+
+.include <bsd.port.pre.mk>
+
# Default is full build with sqlite
.if defined(WITH_CLIENT_ONLY)
CONFIGURE_ARGS+= --enable-client-only
@@ -54,8 +59,6 @@ PLIST_SUB+= DBTYPE=${DBTYPE}
PLIST_SUB+= SERVER=""
.endif
-.include <bsd.port.pre.mk>
-
PORTDOCS= bacula.pdf html-manual/*
pre-everything::
@@ -65,7 +68,7 @@ pre-everything::
@${ECHO_MSG} "===> of data at the end of an tape. This is corrected in FreeBSD"
@${ECHO_MSG} "===> 4.9-RELEASE and 5.2-RELEASE or use the -stable or -current tree."
@${ECHO_MSG} ""
- @${ECHO_MSG} "You may use the following build options:"
+ @${ECHO_MSG} "You may use the following build options (or make config):"
@${ECHO_MSG} ""
@${ECHO_MSG} " WITH_CLIENT_ONLY=yes if you only want the file daemon."
.if !defined(WITH_MYSQL)
diff --git a/sysutils/bacula/Makefile b/sysutils/bacula/Makefile
index 060be1e89513..f7599efd3bb1 100644
--- a/sysutils/bacula/Makefile
+++ b/sysutils/bacula/Makefile
@@ -36,6 +36,11 @@ CONFIGURE_ARGS= --with-tcp-wrappers=/usr/lib \
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+OPTIONS= CLIENT_ONLY "Build bacule file daemon only" off
+OPTIONS+= MYSQL "Build for MySQL database instead of SqLite" off
+
+.include <bsd.port.pre.mk>
+
# Default is full build with sqlite
.if defined(WITH_CLIENT_ONLY)
CONFIGURE_ARGS+= --enable-client-only
@@ -54,8 +59,6 @@ PLIST_SUB+= DBTYPE=${DBTYPE}
PLIST_SUB+= SERVER=""
.endif
-.include <bsd.port.pre.mk>
-
PORTDOCS= bacula.pdf html-manual/*
pre-everything::
@@ -65,7 +68,7 @@ pre-everything::
@${ECHO_MSG} "===> of data at the end of an tape. This is corrected in FreeBSD"
@${ECHO_MSG} "===> 4.9-RELEASE and 5.2-RELEASE or use the -stable or -current tree."
@${ECHO_MSG} ""
- @${ECHO_MSG} "You may use the following build options:"
+ @${ECHO_MSG} "You may use the following build options (or make config):"
@${ECHO_MSG} ""
@${ECHO_MSG} " WITH_CLIENT_ONLY=yes if you only want the file daemon."
.if !defined(WITH_MYSQL)