aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-07-21 09:29:36 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-07-21 09:29:36 +0000
commitee35ae9ae697209ffee4be84a88223d8bf11dd44 (patch)
treeea53b3b419ae559638b17dad11c97b913cfb2e0d /sysutils
parentc0475e9a04d94e14bd7824a75d475c411af3ceb3 (diff)
downloadports-ee35ae9ae697209ffee4be84a88223d8bf11dd44.tar.gz
ports-ee35ae9ae697209ffee4be84a88223d8bf11dd44.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/pecl-fileinfo/Makefile27
-rw-r--r--sysutils/pecl-fileinfo/distinfo2
-rw-r--r--sysutils/pecl-fileinfo/files/patch-config.m411
-rw-r--r--sysutils/pecl-fileinfo/pkg-descr11
5 files changed, 52 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 168d1e360f1e..ed208c493442 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -288,6 +288,7 @@
SUBDIR += pear-File
SUBDIR += pear-File_Find
SUBDIR += pear-Log
+ SUBDIR += pecl-fileinfo
SUBDIR += penv
SUBDIR += perf
SUBDIR += personality
diff --git a/sysutils/pecl-fileinfo/Makefile b/sysutils/pecl-fileinfo/Makefile
new file mode 100644
index 000000000000..5d45a5d15360
--- /dev/null
+++ b/sysutils/pecl-fileinfo/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: pecl-fileinfo
+# Date created: 21 Jul 2004
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fileinfo
+PORTVERSION= 0.2
+CATEGORIES= sysutils pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+DISTNAME= Fileinfo-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= A PECL extension to retrieve info about files
+
+LIB_DEPENDS= magic.1:${PORTSDIR}/sysutils/file
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+CONFIGURE_ARGS= --with-fileinfo=${LOCALBASE}
+
+.include <bsd.port.mk>
diff --git a/sysutils/pecl-fileinfo/distinfo b/sysutils/pecl-fileinfo/distinfo
new file mode 100644
index 000000000000..360e5410534e
--- /dev/null
+++ b/sysutils/pecl-fileinfo/distinfo
@@ -0,0 +1,2 @@
+MD5 (PECL/Fileinfo-0.2.tgz) = e228172c2486c4866c1242d752bae54d
+SIZE (PECL/Fileinfo-0.2.tgz) = 5491
diff --git a/sysutils/pecl-fileinfo/files/patch-config.m4 b/sysutils/pecl-fileinfo/files/patch-config.m4
new file mode 100644
index 000000000000..bac8f5ed97b8
--- /dev/null
+++ b/sysutils/pecl-fileinfo/files/patch-config.m4
@@ -0,0 +1,11 @@
+--- config.m4.orig Wed Jul 21 11:20:04 2004
++++ config.m4 Wed Jul 21 11:20:13 2004
+@@ -36,7 +36,7 @@
+ ],[
+ AC_MSG_ERROR([wrong magic lib version or lib not found])
+ ],[
+- -L$FILEINFO_DIR/lib -lm -ldl
++ -L$FILEINFO_DIR/lib -lm
+ ])
+
+ MAGIC_MIME_LOCATIONS="/usr/local/share/file/magic /usr/share/file/magic /etc/magic"
diff --git a/sysutils/pecl-fileinfo/pkg-descr b/sysutils/pecl-fileinfo/pkg-descr
new file mode 100644
index 000000000000..f14123366996
--- /dev/null
+++ b/sysutils/pecl-fileinfo/pkg-descr
@@ -0,0 +1,11 @@
+The Fileinfo extension allows retrieval of information regarding
+vast majority of file.
+This information may include dimensions, quality, length etc...
+
+Additionally it can also be used to retrieve the mime type for a
+particular file and for text files proper language encoding.
+
+WWW: http://pecl.php.net/package/Fileinfo/
+
+- Alex Dupre
+ale@FreeBSD.org