aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2013-03-28 23:43:25 +0000
committerEitan Adler <eadler@FreeBSD.org>2013-03-28 23:43:25 +0000
commit7bbaa17039a57912609914a1ed4b23b0ef798754 (patch)
tree9cb12b8e7778fe6301057c0268e599a7523682b3 /sysutils
parent00882f1bf11ea3654b5dcb627aa291d9e6c7c309 (diff)
downloadports-7bbaa17039a57912609914a1ed4b23b0ef798754.tar.gz
ports-7bbaa17039a57912609914a1ed4b23b0ef798754.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/moreutils-parallel/Makefile8
-rw-r--r--sysutils/moreutils-parallel/distinfo4
-rw-r--r--sysutils/moreutils-parallel/files/parallel.112
-rw-r--r--sysutils/moreutils-parallel/files/patch-Makefile49
4 files changed, 42 insertions, 31 deletions
diff --git a/sysutils/moreutils-parallel/Makefile b/sysutils/moreutils-parallel/Makefile
index 8f9137218e04..24cd3c47ed4b 100644
--- a/sysutils/moreutils-parallel/Makefile
+++ b/sysutils/moreutils-parallel/Makefile
@@ -2,9 +2,10 @@
# $FreeBSD$
PORTNAME= moreutils-parallel
-PORTVERSION= 0.44
+PORTVERSION= 0.47
CATEGORIES= sysutils
-MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
+MASTER_SITES= DEBIAN
+MASTER_SITE_SUBDIR= pool/main/m/moreutils
DISTNAME= moreutils_${PORTVERSION}
MAINTAINER= eadler@FreeBSD.org
@@ -12,7 +13,6 @@ COMMENT= Run programs in parallel
CONFLICTS= parallel-[0-9]*
-ALL_TARGET= bins
WRKSRC= ${WRKDIR}/moreutils
MAN1= parallel.1
@@ -22,7 +22,7 @@ PLIST_FILES= bin/parallel
MAKE_JOBS_SAFE= yes
post-patch:
- cd ${FILESDIR} && ${CP} ${MAN1} ${WRKSRC}/
+ ${CP} ${FILESDIR}/parallel.1 ${WRKSRC}/
post-install:
cd ${WRKSRC} && ${INSTALL_MAN} ${MAN1} ${MANPREFIX}/man/man1/
diff --git a/sysutils/moreutils-parallel/distinfo b/sysutils/moreutils-parallel/distinfo
index b39d6b70b2b2..090bf09ff6f4 100644
--- a/sysutils/moreutils-parallel/distinfo
+++ b/sysutils/moreutils-parallel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (moreutils_0.44.tar.gz) = 53ec2a967b4ab39cd29e5f9116b6f7b75eefdb97e768fe7b1b04fb688d236604
-SIZE (moreutils_0.44.tar.gz) = 44685
+SHA256 (moreutils_0.47.tar.gz) = 277058c99d76c58f850f48dfbc1ad4a7a384f5b95f3569842ec4ce1c9f077266
+SIZE (moreutils_0.47.tar.gz) = 46115
diff --git a/sysutils/moreutils-parallel/files/parallel.1 b/sysutils/moreutils-parallel/files/parallel.1
index a206a8b0640d..81afb708800b 100644
--- a/sysutils/moreutils-parallel/files/parallel.1
+++ b/sysutils/moreutils-parallel/files/parallel.1
@@ -44,15 +44,15 @@ Use to limit the number of jobs
that are run at the same time.
.TP
\*(T<\fB\-l maxload\fR\*(T>
-Avoid starting new jobs when
-the system's load average is not below
-the specified limit.
+Wait as needed to avoid starting
+new jobs when the system's load average
+is not below the specified limit.
.TP
\*(T<\fB\-i\fR\*(T>
Normally the command is passed the
argument at the end of its command line. With
-this option, the first instance of "{}" in
-the command is replaced with the argument.
+this option, any instances of "{}" in
+the command are replaced with the argument.
.TP
\*(T<\fB\-n\fR\*(T>
Number of arguments to pass to a
@@ -103,3 +103,5 @@ This runs three independent commands in parallel.
Its exit status is the combination of the exit statuses of each
command ran, ORed together. (Thus, if any one command
exits nonzero, \fBparallel\fR as a whole will exit nonzero.)
+.SH AUTHOR
+Tollef Fog Heen
diff --git a/sysutils/moreutils-parallel/files/patch-Makefile b/sysutils/moreutils-parallel/files/patch-Makefile
index 8c833ab1bd19..a344fcec0402 100644
--- a/sysutils/moreutils-parallel/files/patch-Makefile
+++ b/sysutils/moreutils-parallel/files/patch-Makefile
@@ -1,40 +1,38 @@
---- ./Makefile.orig 2010-10-29 12:47:09.000000000 -0700
-+++ ./Makefile 2010-12-09 13:08:46.000000000 -0800
-@@ -1,51 +1,18 @@
--BINS=isutf8 ifdata ifne pee sponge mispipe lckdo parallel
+--- Makefile.orig 2012-06-06 01:55:53.000000000 +0800
++++ Makefile 2013-03-11 14:38:14.415417395 +0800
+@@ -1,60 +1,21 @@
+-BINS=isutf8 ifdata ifne pee sponge mispipe lckdo parallel errno
-PERLSCRIPTS=vidir vipe ts combine zrun chronic
--MANS=sponge.1 vidir.1 vipe.1 isutf8.1 ts.1 combine.1 ifdata.1 ifne.1 pee.1 zrun.1 chronic.1 mispipe.1 lckdo.1 parallel.1
+-MANS=sponge.1 vidir.1 vipe.1 isutf8.1 ts.1 combine.1 ifdata.1 ifne.1 pee.1 zrun.1 chronic.1 mispipe.1 lckdo.1 parallel.1 errno.1
-CFLAGS=-O2 -g -Wall
+BINS=parallel
+MANS=parallel.1
-+CFLAGS+= -Wall
++CFLAGS+=-Wall
INSTALL_BIN?=install -s
-PREFIX=/usr
--
+
-DOCBOOK2XMAN=docbook2x-man
++.SUFFIXES: .1 .docbook
- all: $(BINS) $(MANS)
-+
-+bins: ${BINS}
-+
-+mans: ${MANS}
+-all: $(BINS) $(MANS)
++all: $(BINS)
clean:
- rm -f $(BINS) $(MANS)
+ rm -f $(BINS) $(MANS) dump.c errnos.h errno.o
install:
- mkdir -p $(DESTDIR)$(PREFIX)/bin
- $(INSTALL_BIN) $(BINS) $(DESTDIR)$(PREFIX)/bin
- install $(PERLSCRIPTS) $(DESTDIR)$(PREFIX)/bin
-+ mkdir -p $(PREFIX)/bin
-+ $(INSTALL_BIN) $(BINS) $(PREFIX)/bin
-
+-
- mkdir -p $(DESTDIR)$(PREFIX)/share/man/man1
- install $(MANS) $(DESTDIR)$(PREFIX)/share/man/man1
--
--check: isutf8
-- ./check-isutf8
--
++ mkdir -p $(PREFIX)/bin
++ $(INSTALL_BIN) $(BINS) $(PREFIX)/bin
+
+ check: isutf8
+ ./check-isutf8
+
-isutf8.1: isutf8.docbook
- $(DOCBOOK2XMAN) $<
-
@@ -58,6 +56,17 @@
-
-parallel.1: parallel.docbook
- $(DOCBOOK2XMAN) $<
+-
+-errno.o: errnos.h
+-errnos.h:
+- echo '#include <errno.h>' > dump.c
+- $(CC) -E -dD dump.c | awk '/^#define E/ { printf "{\"%s\",%s},\n", $$2, $$2 }' > errnos.h
+- rm -f dump.c
+-
+-errno.1: errno.docbook
+- $(DOCBOOK2XMAN) $<
-
-%.1: %
- pod2man --center=" " --release="moreutils" $< > $@;
++.docbook.1:
++ $(DOCBOOK2XMAN) ${.IMPSRC}