aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2012-09-22 13:53:22 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2012-09-22 13:53:22 +0000
commit4095fe36df47bdadcb0d8de9f697d3b2397162dd (patch)
treeee16c7206d3fd9302cf020c21c87a1542ae956b0 /sysutils
parent322b5a1e6291736776e70012858b004d7634f5c7 (diff)
downloadports-4095fe36df47bdadcb0d8de9f697d3b2397162dd.tar.gz
ports-4095fe36df47bdadcb0d8de9f697d3b2397162dd.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/py-glances/Makefile29
-rw-r--r--sysutils/py-glances/distinfo2
-rw-r--r--sysutils/py-glances/pkg-descr4
4 files changed, 36 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index e4eb35fc76fa..d0899c2961a2 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -725,6 +725,7 @@
SUBDIR += py-danzfs
SUBDIR += py-drmaa
SUBDIR += py-filelike
+ SUBDIR += py-glances
SUBDIR += py-iowait
SUBDIR += py-nagiosplugin
SUBDIR += py-psutil
diff --git a/sysutils/py-glances/Makefile b/sysutils/py-glances/Makefile
new file mode 100644
index 000000000000..c75fc9702e37
--- /dev/null
+++ b/sysutils/py-glances/Makefile
@@ -0,0 +1,29 @@
+# Created by: Gasol Wu <gasol.wu@gmail.com>
+# $FreeBSD$
+
+PORTNAME= glances
+PORTVERSION= 1.4.1.1
+CATEGORIES= sysutils python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gasol.wu@gmail.com
+COMMENT= A CLI curses based monitoring tool for GNU/Linux and BSD OS
+
+LICENSE= LGPL3
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>=2.0.0:${PORTSDIR}/devel/py-Jinja2 \
+ ${PYTHON_PKGNAMEPREFIX}psutil>=0.4.1:${PORTSDIR}/sysutils/py-psutil
+
+USE_GITHUB= yes
+GH_ACCOUNT= nicolargo
+GH_PROJECT= glances
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= 2920dcc
+USE_PYTHON= 2.6+
+USE_PYDISTUTILS=easy_install
+PYDISTUTILS_PKGNAME= Glances
+
+PLIST_FILES= bin/glances \
+ %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-glances/distinfo b/sysutils/py-glances/distinfo
new file mode 100644
index 000000000000..25166e423520
--- /dev/null
+++ b/sysutils/py-glances/distinfo
@@ -0,0 +1,2 @@
+SHA256 (glances-1.4.1.1.tar.gz) = 1681c7702c8d47f0774c855a811eed46acf628e8b31ccfed922ed77f3d419301
+SIZE (glances-1.4.1.1.tar.gz) = 568516
diff --git a/sysutils/py-glances/pkg-descr b/sysutils/py-glances/pkg-descr
new file mode 100644
index 000000000000..eee9e07dd4ae
--- /dev/null
+++ b/sysutils/py-glances/pkg-descr
@@ -0,0 +1,4 @@
+Glances is a CLI curses based monitoring tool for GNU/Linux and BSD OS.
+Glances uses the PsUtil library to get information from your system.
+
+WWW: http://nicolargo.github.com/glances