aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-11-09 12:30:28 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-11-09 12:30:28 +0000
commitebdc13af208615f7ee345fc471dc2ae2362ff08b (patch)
tree0719dbc23e31297386c67531277ce05bd70bea05 /sysutils
parent8be041e13ae4168c3bed7a39c69b2226333a9cbd (diff)
downloadports-ebdc13af208615f7ee345fc471dc2ae2362ff08b.tar.gz
ports-ebdc13af208615f7ee345fc471dc2ae2362ff08b.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/heartbeat/Makefile8
-rw-r--r--sysutils/heartbeat/files/patch-tools-Makefile.am11
2 files changed, 15 insertions, 4 deletions
diff --git a/sysutils/heartbeat/Makefile b/sysutils/heartbeat/Makefile
index 9ec65c91e121..cac05343e750 100644
--- a/sysutils/heartbeat/Makefile
+++ b/sysutils/heartbeat/Makefile
@@ -16,10 +16,10 @@ COMMENT= Subsystem for High-Availability Clustering
BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison
-LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls \
- net:${PORTSDIR}/net/libnet \
- uuid:${PORTSDIR}/misc/e2fsprogs-libuuid \
- xml2:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls \
+ libnet.so:${PORTSDIR}/net/libnet \
+ libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid \
+ libxml2.so:${PORTSDIR}/textproc/libxml2
PATCH_DEPENDS= libtool:${PORTSDIR}/devel/libtool
USE_AUTOTOOLS= autoconf autoheader automake aclocal libtool libltdl
diff --git a/sysutils/heartbeat/files/patch-tools-Makefile.am b/sysutils/heartbeat/files/patch-tools-Makefile.am
new file mode 100644
index 000000000000..1d759a29c24d
--- /dev/null
+++ b/sysutils/heartbeat/files/patch-tools-Makefile.am
@@ -0,0 +1,11 @@
+--- tools/Makefile.am.orig 2008-08-18 12:32:19.000000000 +0000
++++ tools/Makefile.am 2013-11-08 13:57:58.000000000 +0000
+@@ -43,7 +43,7 @@
+
+ ## SOURCES
+ ccdv: $(top_srcdir)/tools/ccdv.c
+- gcc $(AM_CFLAGS) $(CFLAGS) -o ccdv $(top_srcdir)/tools/ccdv.c
++ $(CC) $(AM_CFLAGS) $(CFLAGS) -o ccdv $(top_srcdir)/tools/ccdv.c
+
+ cl_status_SOURCES = cl_status.c
+ # A little trick. Now ccdv can be auto-built but not auto-cleaned.