aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-05-31 20:26:11 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-05-31 20:26:11 +0000
commit29be8bff1f654b97b561bff60db5e9abcbc83952 (patch)
tree76e620f2b9aa7a86b14a0097ee4494e5c3d8d705 /sysutils
parent013dedb112f837a613200a3afc573ad5e648a661 (diff)
downloadports-29be8bff1f654b97b561bff60db5e9abcbc83952.tar.gz
ports-29be8bff1f654b97b561bff60db5e9abcbc83952.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/ipmitool/Makefile4
-rw-r--r--sysutils/ipmitool/distinfo4
-rw-r--r--sysutils/ipmitool/files/patch-lib_helper.c25
3 files changed, 29 insertions, 4 deletions
diff --git a/sysutils/ipmitool/Makefile b/sysutils/ipmitool/Makefile
index fefef043d49e..2693f129d1c5 100644
--- a/sysutils/ipmitool/Makefile
+++ b/sysutils/ipmitool/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ipmitool
-PORTVERSION= 1.8.1
+PORTVERSION= 1.8.2
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,7 +14,6 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= frolov@riss-telecom.ru
COMMENT= CLI to manage IPMI systems
-USE_BZIP2= yes
USE_GMAKE= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
@@ -26,6 +25,7 @@ PLIST_FILES= bin/ipmitool sbin/ipmievd
PLIST_DIRS= share/${PORTNAME}
PORTDOCS= README AUTHORS ChangeLog COPYING
MAN1+= ${PORTNAME}.1
+MAN8+= ipmievd.8
DATAFILES= bmclanconf ipmi.init.basic ipmi.init.redhat README \
collect_data.sh create_rrds.sh create_webpage_compact.sh \
diff --git a/sysutils/ipmitool/distinfo b/sysutils/ipmitool/distinfo
index 3c8b9475dee6..7c782cb04eeb 100644
--- a/sysutils/ipmitool/distinfo
+++ b/sysutils/ipmitool/distinfo
@@ -1,2 +1,2 @@
-MD5 (ipmitool-1.8.1.tar.bz2) = e24e00b077af2f00590cb09c4cfe5f7d
-SIZE (ipmitool-1.8.1.tar.bz2) = 387013
+MD5 (ipmitool-1.8.2.tar.gz) = d249ddd2176385fcea93753f5e103160
+SIZE (ipmitool-1.8.2.tar.gz) = 556042
diff --git a/sysutils/ipmitool/files/patch-lib_helper.c b/sysutils/ipmitool/files/patch-lib_helper.c
new file mode 100644
index 000000000000..268de36d0030
--- /dev/null
+++ b/sysutils/ipmitool/files/patch-lib_helper.c
@@ -0,0 +1,25 @@
+--- lib/helper.c.orig Wed May 18 03:58:05 2005
++++ lib/helper.c Tue May 31 22:01:31 2005
+@@ -34,17 +34,20 @@
+ * facility.
+ */
+
++#include <sys/types.h>
++#include <sys/stat.h>
++#include <sys/ioctl.h> /* For TIOCNOTTY */
++
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <inttypes.h>
+ #include <signal.h>
+ #include <string.h>
+ #include <strings.h>
+-#include <sys/types.h>
+-#include <sys/stat.h>
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <errno.h>
++#include <paths.h> /* For _PATH_TTY */
+
+ #include <ipmitool/helper.h>
+ #include <ipmitool/log.h>