aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorPhilip Paeps <philip@FreeBSD.org>2005-10-21 14:24:02 +0000
committerPhilip Paeps <philip@FreeBSD.org>2005-10-21 14:24:02 +0000
commit41ea7ff3f8b22d96acad9cb3b39be205984abbf6 (patch)
tree274d714abcb7aed8e33c171d0db7fb680803a23d /sysutils
parent447aca510269c7ff67d1674e2c3cc05a44f12af5 (diff)
downloadports-41ea7ff3f8b22d96acad9cb3b39be205984abbf6.tar.gz
ports-41ea7ff3f8b22d96acad9cb3b39be205984abbf6.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/screen/Makefile2
-rw-r--r--sysutils/screen/files/patch-utmp.c17
2 files changed, 18 insertions, 1 deletions
diff --git a/sysutils/screen/Makefile b/sysutils/screen/Makefile
index 64db128c44a2..883b99a9f814 100644
--- a/sysutils/screen/Makefile
+++ b/sysutils/screen/Makefile
@@ -7,7 +7,7 @@
PORTNAME= screen
PORTVERSION= 4.0.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc
MASTER_SITES= ftp://ftp.uni-erlangen.de/pub/utilities/screen/ \
${MASTER_SITE_GNU}
diff --git a/sysutils/screen/files/patch-utmp.c b/sysutils/screen/files/patch-utmp.c
new file mode 100644
index 000000000000..caedb6c1ec50
--- /dev/null
+++ b/sysutils/screen/files/patch-utmp.c
@@ -0,0 +1,17 @@
+--- utmp.c.orig Mon Sep 8 16:27:17 2003
++++ utmp.c Wed Oct 19 14:58:40 2005
+@@ -726,9 +728,12 @@
+ char *line, *user;
+ int pid;
+ {
++ time_t temp;
++
+ strncpy(u->ut_line, line, sizeof(u->ut_line));
+ strncpy(u->ut_name, user, sizeof(u->ut_name));
+- (void)time((time_t *)&u->ut_time);
++ (void)time(&temp);
++ u->ut_time = temp;
+ }
+
+ static slot_t
+