aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2011-01-18 21:07:36 +0000
committerCy Schubert <cy@FreeBSD.org>2011-01-18 21:07:36 +0000
commit8339e4b9bc2e2dc3131467a3c6fbe1bb45c2ac27 (patch)
treec79b5d490d9a0bff828c6806a286218096af0520 /sysutils
parent5af52ba53a3dadc207749b6e26ba0fe151751438 (diff)
downloadports-8339e4b9bc2e2dc3131467a3c6fbe1bb45c2ac27.tar.gz
ports-8339e4b9bc2e2dc3131467a3c6fbe1bb45c2ac27.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/syslog-ng3/Makefile3
-rw-r--r--sysutils/syslog-ng3/distinfo4
-rw-r--r--sysutils/syslog-ng3/files/patch-lib-misc.c13
-rw-r--r--sysutils/syslog-ng3/files/patch-modules-affile-affile.c34
-rw-r--r--sysutils/syslog-ng3/files/patch-modules-affile-affile.h17
-rw-r--r--sysutils/syslog-ng3/files/patch-modules-afsocket-afunix.c13
-rw-r--r--sysutils/syslog-ng3/files/patch-modules-afsocket-afunix.h13
-rw-r--r--sysutils/syslog-ng3/files/patch-modules-dbparser-patternize.c43
-rw-r--r--sysutils/syslog-ng3/files/syslog-ng.conf.sample2
-rw-r--r--sysutils/syslog-ng3/pkg-plist3
10 files changed, 7 insertions, 138 deletions
diff --git a/sysutils/syslog-ng3/Makefile b/sysutils/syslog-ng3/Makefile
index 62cabb23ddeb..c60b27b6b033 100644
--- a/sysutils/syslog-ng3/Makefile
+++ b/sysutils/syslog-ng3/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= syslog-ng
-PORTVERSION= 3.2.1
-PORTREVISION= 2
+PORTVERSION= 3.2.2
CATEGORIES= sysutils
MASTER_SITES= http://www.balabit.com/downloads/files/syslog-ng/sources/$(PORTVERSION)/source/
PKGNAMESUFFIX= 3
diff --git a/sysutils/syslog-ng3/distinfo b/sysutils/syslog-ng3/distinfo
index ae62a2add4d1..144085d32bfd 100644
--- a/sysutils/syslog-ng3/distinfo
+++ b/sysutils/syslog-ng3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (syslog-ng_3.2.1.tar.gz) = d2457b8836fe16a6e8103b13bf5fe146ac8dea623778441722424eea4c5db9af
-SIZE (syslog-ng_3.2.1.tar.gz) = 1376735
+SHA256 (syslog-ng_3.2.2.tar.gz) = fa5abd4d99acee8fff8217061fb2407698a5bc89804d69f3ae97bffc72fcce48
+SIZE (syslog-ng_3.2.2.tar.gz) = 1387691
diff --git a/sysutils/syslog-ng3/files/patch-lib-misc.c b/sysutils/syslog-ng3/files/patch-lib-misc.c
deleted file mode 100644
index 6a8e536e3193..000000000000
--- a/sysutils/syslog-ng3/files/patch-lib-misc.c
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/lib/misc.c b/lib/misc.c
-index 91361e0..4aac9e3 100644
---- lib/misc.c
-+++ lib/misc.c
-@@ -411,7 +411,7 @@ create_containing_directory(gchar *name, gint dir_uid, gint dir_gid, gint dir_mo
- }
- else if (errno == ENOENT)
- {
-- if (mkdir(name, (mode_t) dir_mode) == -1)
-+ if (mkdir(name, dir_mode < 0 ? 0700 : (mode_t) dir_mode) == -1)
- return FALSE;
- saved_caps = g_process_cap_save();
- g_process_cap_modify(CAP_CHOWN, TRUE);
diff --git a/sysutils/syslog-ng3/files/patch-modules-affile-affile.c b/sysutils/syslog-ng3/files/patch-modules-affile-affile.c
deleted file mode 100644
index c0b4d6c02610..000000000000
--- a/sysutils/syslog-ng3/files/patch-modules-affile-affile.c
+++ /dev/null
@@ -1,34 +0,0 @@
-diff --git a/modules/affile/affile.c b/modules/affile/affile.c
-index 7746897..e145324 100644
---- modules/affile/affile.c
-+++ modules/affile/affile.c
-@@ -607,7 +607,7 @@ affile_dd_set_file_gid(LogDriver *s, const gchar *file_gid)
- }
-
- void
--affile_dd_set_file_perm(LogDriver *s, mode_t file_perm)
-+affile_dd_set_file_perm(LogDriver *s, gint file_perm)
- {
- AFFileDestDriver *self = (AFFileDestDriver *) s;
-
-@@ -643,7 +643,7 @@ affile_dd_set_dir_gid(LogDriver *s, const gchar *dir_gid)
- }
-
- void
--affile_dd_set_dir_perm(LogDriver *s, mode_t dir_perm)
-+affile_dd_set_dir_perm(LogDriver *s, gint dir_perm)
- {
- AFFileDestDriver *self = (AFFileDestDriver *) s;
-
-@@ -957,9 +957,9 @@ affile_dd_new(gchar *filename, guint32 flags)
- self->filename_template = log_template_new(configuration, NULL, filename);
- self->flags = flags;
- self->file_uid = self->file_gid = -1;
-- self->file_perm = (mode_t) -1;
-+ self->file_perm = -1;
- self->dir_uid = self->dir_gid = -1;
-- self->dir_perm = (mode_t) -1;
-+ self->dir_perm = -1;
- log_writer_options_defaults(&self->writer_options);
- if (strchr(filename, '$') == NULL)
- {
diff --git a/sysutils/syslog-ng3/files/patch-modules-affile-affile.h b/sysutils/syslog-ng3/files/patch-modules-affile-affile.h
deleted file mode 100644
index 150a31f08e95..000000000000
--- a/sysutils/syslog-ng3/files/patch-modules-affile-affile.h
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/modules/affile/affile.h b/modules/affile/affile.h
-index 1c1ff1e..9ec1493 100644
---- modules/affile/affile.h
-+++ modules/affile/affile.h
-@@ -83,10 +83,10 @@ void affile_dd_set_compress(LogDriver *s, gboolean compress);
- void affile_dd_set_encrypt(LogDriver *s, gboolean enable);
- void affile_dd_set_file_uid(LogDriver *s, const gchar *file_uid);
- void affile_dd_set_file_gid(LogDriver *s, const gchar *file_gid);
--void affile_dd_set_file_perm(LogDriver *s, mode_t file_perm);
-+void affile_dd_set_file_perm(LogDriver *s, gint file_perm);
- void affile_dd_set_dir_uid(LogDriver *s, const gchar *dir_uid);
- void affile_dd_set_dir_gid(LogDriver *s, const gchar *dir_gid);
--void affile_dd_set_dir_perm(LogDriver *s, mode_t dir_perm);
-+void affile_dd_set_dir_perm(LogDriver *s, gint dir_perm);
- void affile_dd_set_create_dirs(LogDriver *s, gboolean create_dirs);
- void affile_dd_set_fsync(LogDriver *s, gboolean enable);
- void affile_dd_set_overwrite_if_older(LogDriver *s, gint overwrite_if_older);
diff --git a/sysutils/syslog-ng3/files/patch-modules-afsocket-afunix.c b/sysutils/syslog-ng3/files/patch-modules-afsocket-afunix.c
deleted file mode 100644
index 2dc52df82b4f..000000000000
--- a/sysutils/syslog-ng3/files/patch-modules-afsocket-afunix.c
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/modules/afsocket/afunix.c b/modules/afsocket/afunix.c
-index bf54441..b486b6b 100644
---- modules/afsocket/afunix.c
-+++ modules/afsocket/afunix.c
-@@ -55,7 +55,7 @@ afunix_sd_set_gid(LogDriver *s, gchar *group)
- }
-
- void
--afunix_sd_set_perm(LogDriver *s, mode_t perm)
-+afunix_sd_set_perm(LogDriver *s, gint perm)
- {
- AFUnixSourceDriver *self = (AFUnixSourceDriver *) s;
-
diff --git a/sysutils/syslog-ng3/files/patch-modules-afsocket-afunix.h b/sysutils/syslog-ng3/files/patch-modules-afsocket-afunix.h
deleted file mode 100644
index ec059b54e4fc..000000000000
--- a/sysutils/syslog-ng3/files/patch-modules-afsocket-afunix.h
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/modules/afsocket/afunix.h b/modules/afsocket/afunix.h
-index ddb63bc..fba3e02 100644
---- modules/afsocket/afunix.h
-+++ modules/afsocket/afunix.h
-@@ -40,7 +40,7 @@ typedef struct _AFUnixSourceDriver
-
- void afunix_sd_set_uid(LogDriver *self, gchar *owner);
- void afunix_sd_set_gid(LogDriver *self, gchar *group);
--void afunix_sd_set_perm(LogDriver *self, mode_t perm);
-+void afunix_sd_set_perm(LogDriver *self, gint perm);
-
- LogDriver *afunix_sd_new(gchar *filename, guint32 flags);
-
diff --git a/sysutils/syslog-ng3/files/patch-modules-dbparser-patternize.c b/sysutils/syslog-ng3/files/patch-modules-dbparser-patternize.c
deleted file mode 100644
index aee20261f3a8..000000000000
--- a/sysutils/syslog-ng3/files/patch-modules-dbparser-patternize.c
+++ /dev/null
@@ -1,43 +0,0 @@
-diff --git modules/dbparser/patternize.c.orig modules/dbparser/patternize.c
-index 1a433c2..b22a9c7 100644
---- modules/dbparser/patternize.c.orig
-+++ modules/dbparser/patternize.c
-@@ -27,7 +27,6 @@
-
- #include <stdlib.h>
- #include <string.h>
--#include <openssl/rand.h>
-
- /*
- * NOTE: most of the algorithms come from SLCT and LogHound, written by Risto Vaarandi
-@@ -45,6 +44,10 @@
- static LogTagId cluster_tag_id;
-
-
-+#if ENABLE_SSL_MODULE
-+
-+#include <openssl/rand.h>
-+
- static void
- uuid_gen_random(gchar *buf, gsize buflen)
- {
-@@ -77,6 +80,19 @@ uuid_gen_random(gchar *buf, gsize buflen)
-
- }
-
-+#else
-+
-+#warning "openssl seems to be missing on your system, UUID generation will be disabled in pdbtool patternize"
-+
-+static void
-+uuid_gen_random(gchar *buf, gsize buflen)
-+{
-+ static int counter = 1;
-+
-+ g_snprintf(buf, buflen, "unable-to-generate-uuid-without-random-source-%d", counter++);
-+}
-+#endif
-+
- #if 0
- static void _ptz_debug_print_word(gpointer key, gpointer value, gpointer dummy)
- {
diff --git a/sysutils/syslog-ng3/files/syslog-ng.conf.sample b/sysutils/syslog-ng3/files/syslog-ng.conf.sample
index 0ba913185c6c..a58743dad624 100644
--- a/sysutils/syslog-ng3/files/syslog-ng.conf.sample
+++ b/sysutils/syslog-ng3/files/syslog-ng.conf.sample
@@ -1,4 +1,4 @@
-@version:3.0
+@version:3.2
#
# This sample configuration file is essentially equilivent to the stock
diff --git a/sysutils/syslog-ng3/pkg-plist b/sysutils/syslog-ng3/pkg-plist
index b9e9336ecc53..921398208695 100644
--- a/sysutils/syslog-ng3/pkg-plist
+++ b/sysutils/syslog-ng3/pkg-plist
@@ -9,6 +9,9 @@ bin/pdbtool
lib/libsyslog-ng.la
lib/libsyslog-ng.so
lib/libsyslog-ng.so.0
+lib/libsyslog-ng-patterndb.la
+lib/libsyslog-ng-patterndb.so
+lib/libsyslog-ng-patterndb.so.0
lib/syslog-ng/libaffile.la
lib/syslog-ng/libaffile.so
lib/syslog-ng/libafprog.la