aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2013-09-12 09:45:44 +0000
committerKevin Lo <kevlo@FreeBSD.org>2013-09-12 09:45:44 +0000
commit8c9c5a701e9d26b035bd3f5fbb7b2d44c169fa25 (patch)
tree8209f19cc896dffbcf37d7697c7422a80a17987a /sysutils
parent1f9270b0bc803581e176fc526f72bd46d6f2cc14 (diff)
downloadports-8c9c5a701e9d26b035bd3f5fbb7b2d44c169fa25.tar.gz
ports-8c9c5a701e9d26b035bd3f5fbb7b2d44c169fa25.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/synergy/Makefile10
-rw-r--r--sysutils/synergy/files/patch-CConfig.cpp14
-rw-r--r--sysutils/synergy/files/patch-CConfig.h11
-rw-r--r--sysutils/synergy/files/patch-gtest-port.h11
4 files changed, 41 insertions, 5 deletions
diff --git a/sysutils/synergy/Makefile b/sysutils/synergy/Makefile
index 19325a459695..7530eb0185df 100644
--- a/sysutils/synergy/Makefile
+++ b/sysutils/synergy/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: synergy
-# Date created: 26 March 2003
-# Whom: Kevin Lo <kevlo@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= synergy
PORTVERSION= 1.3.8
@@ -14,9 +9,14 @@ MASTER_SITES= GOOGLE_CODE
MAINTAINER= kevlo@FreeBSD.org
COMMENT= Mouse and keyboard sharing utility
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USES= cmake
USE_XORG= ice xtst x11 sm
+MAKE_JOBS_UNSAFE=yes
+
CFLAGS+= -L${LOCALBASE}/lib -I${LOCALBASE}/include
PLIST_FILES= bin/synergys bin/synergyc
diff --git a/sysutils/synergy/files/patch-CConfig.cpp b/sysutils/synergy/files/patch-CConfig.cpp
new file mode 100644
index 000000000000..985bdf499b31
--- /dev/null
+++ b/sysutils/synergy/files/patch-CConfig.cpp
@@ -0,0 +1,14 @@
+--- src/lib/server/CConfig.cpp.orig 2011-01-21 11:51:35.000000000 +0800
++++ src/lib/server/CConfig.cpp 2013-09-12 17:23:04.000000000 +0800
+@@ -1908,9 +1908,9 @@
+ return m_line;
+ }
+
+-CConfigReadContext::operator void*() const
++CConfigReadContext::operator bool() const
+ {
+- return m_stream;
++ return !m_stream.bad();
+ }
+
+ bool
diff --git a/sysutils/synergy/files/patch-CConfig.h b/sysutils/synergy/files/patch-CConfig.h
new file mode 100644
index 000000000000..aa825a9bdb68
--- /dev/null
+++ b/sysutils/synergy/files/patch-CConfig.h
@@ -0,0 +1,11 @@
+--- src/lib/server/CConfig.h.orig 2013-09-12 16:03:30.000000000 +0800
++++ src/lib/server/CConfig.h 2013-09-12 16:04:07.000000000 +0800
+@@ -483,7 +483,7 @@
+ bool readLine(CString&);
+ UInt32 getLineNumber() const;
+
+- operator void*() const;
++ operator bool() const;
+ bool operator!() const;
+
+ OptionValue parseBoolean(const CString&) const;
diff --git a/sysutils/synergy/files/patch-gtest-port.h b/sysutils/synergy/files/patch-gtest-port.h
new file mode 100644
index 000000000000..08e6ff80ec78
--- /dev/null
+++ b/sysutils/synergy/files/patch-gtest-port.h
@@ -0,0 +1,11 @@
+--- tools/gtest-1.6.0/include/gtest/internal/gtest-port.h.orig 2011-05-07 10:25:30.000000000 +0800
++++ tools/gtest-1.6.0/include/gtest/internal/gtest-port.h 2013-09-12 17:39:09.000000000 +0800
+@@ -204,6 +204,8 @@
+ #define GTEST_NAME_ "Google Test"
+ #define GTEST_PROJECT_URL_ "http://code.google.com/p/googletest/"
+
++#define GTEST_USE_OWN_TR1_TUPLE 1
++
+ // Determines the version of gcc that is used to compile this.
+ #ifdef __GNUC__
+ // 40302 means version 4.3.2.