aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2019-07-31 01:01:39 +0000
committerMatthias Andree <mandree@FreeBSD.org>2019-07-31 01:01:39 +0000
commitd8a9a66a0f4c596758d23bc607ec3d1fe7417d99 (patch)
treebe5b91f82a41cef501927704737f8ccbff632445 /sysutils
parentb12be4a5089bf21c80924d752d86a35ee51ea36c (diff)
downloadports-d8a9a66a0f4c596758d23bc607ec3d1fe7417d99.tar.gz
ports-d8a9a66a0f4c596758d23bc607ec3d1fe7417d99.zip
MFH: r507631 sysutils/e2fsprogs:
Fix f_pre_1970_date_encoding on all 32-bit architectures but i386. e2fsck would misparse the E2FSCK_TIME environment variable on architectures where sizeof(long) < sizeof(time_t), i. e. all 32-bit architectures but i386. This led to f_pre_1970_date_encoding test failures. Note that I haven't tested the change for lack of respective hardware or qemu rigs, and prior to receiving the reporter feedback, but it would appear the fix is safe and plausible in itself. Bump PORTREVISION as this changes the code on all architectures, and to trigger version-based rebuild attempts where needed. (For the MFH, bump all the way to PORTREVISION?=2 to align with the SVN trunk, portrev. 1 was just to chase GCC updates on the trunk.) See also: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=932906 Reported by: Thorsten Glaser <tg@mirbsd.de> against Debian Reported by: Stanislav S. Grinkin (privately) against FreeBSD Reported by: prior fall-out and BROKEN_<ARCH> tags Obtained from: https://git.kernel.org/pub/scm/fs/ext2/e2fsprogs.git/commit/?id=a368e0cbfb33d3050dcccccf0bf5a5539d3dac39 Approved by: ports-secteam (joneum)
Notes
Notes: svn path=/branches/2019Q3/; revision=507688
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/e2fsprogs/Makefile2
-rw-r--r--sysutils/e2fsprogs/files/patch-e2fsck_e2fsck.c21
-rw-r--r--sysutils/e2fsprogs/files/patch-tests_Makefile.in6
3 files changed, 25 insertions, 4 deletions
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index dae33f6c32b4..a680ed061c49 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= e2fsprogs
PORTVERSION= 1.45.3
-PORTREVISION?= 0
+PORTREVISION?= 2
CATEGORIES?= sysutils
MASTER_SITES= KERNEL_ORG/linux/kernel/people/tytso/${PORTNAME}/v${PORTVERSION}
diff --git a/sysutils/e2fsprogs/files/patch-e2fsck_e2fsck.c b/sysutils/e2fsprogs/files/patch-e2fsck_e2fsck.c
new file mode 100644
index 000000000000..c40e19ec1810
--- /dev/null
+++ b/sysutils/e2fsprogs/files/patch-e2fsck_e2fsck.c
@@ -0,0 +1,21 @@
+commit a368e0cbfb33d3050dcccccf0bf5a5539d3dac39
+Author: Theodore Ts'o <tytso@mit.edu>
+Date: Wed Jul 24 22:25:11 2019 -0400
+
+ e2fsck: set E2FSCK_TIME correctly on a 32-bit arch with a 64-bit time_t
+
+ Addresses-Debian-Bug: #932906
+
+ Signed-off-by: Theodore Ts'o <tytso@mit.edu>
+
+--- e2fsck/e2fsck.c.orig 2019-07-15 01:03:14 UTC
++++ e2fsck/e2fsck.c
+@@ -37,7 +37,7 @@ errcode_t e2fsck_allocate_context(e2fsck_t *ret)
+
+ time_env = getenv("E2FSCK_TIME");
+ if (time_env)
+- context->now = strtoul(time_env, NULL, 0);
++ context->now = (time_t) strtoull(time_env, NULL, 0);
+ else {
+ context->now = time(0);
+ if (context->now < 1262322000) /* January 1 2010 */
diff --git a/sysutils/e2fsprogs/files/patch-tests_Makefile.in b/sysutils/e2fsprogs/files/patch-tests_Makefile.in
index 3ed4f24b8732..b265f8124a28 100644
--- a/sysutils/e2fsprogs/files/patch-tests_Makefile.in
+++ b/sysutils/e2fsprogs/files/patch-tests_Makefile.in
@@ -1,7 +1,7 @@
---- tests/Makefile.in.orig 2018-07-10 05:14:26 UTC
+--- tests/Makefile.in.orig 2019-07-15 01:03:14 UTC
+++ tests/Makefile.in
-@@ -16,7 +16,7 @@ all:: @DO_TEST_SUITE@ test_one test_scri
- test_one: $(srcdir)/test_one.in Makefile mke2fs.conf
+@@ -16,7 +16,7 @@ all:: @DO_TEST_SUITE@ test_one test_script
+ test_one: $(srcdir)/test_one.in Makefile mke2fs.conf test_data.tmp
@echo "Creating test_one script..."
@[ -f test_one ] && chmod u+w test_one || true
- @echo "#!/bin/sh" > test_one