aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2017-08-15 14:17:54 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2017-08-15 14:17:54 +0000
commit5e7dd87f8c97975e94007fefd5cc1d2a900f5903 (patch)
treecab4d4a9c81b7037ce6329c99afd0b6c09bbfe45 /sysutils
parentee5773d5747daa69908a1f3c7d5ef7528ea2ff4c (diff)
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/doctl/Makefile22
-rw-r--r--sysutils/doctl/distinfo3
-rw-r--r--sysutils/doctl/pkg-descr5
4 files changed, 31 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index f8fcacb92492..8e0c29ff3244 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -244,6 +244,7 @@
SUBDIR += docker-compose
SUBDIR += docker-freebsd
SUBDIR += docker-machine
+ SUBDIR += doctl
SUBDIR += doinkd
SUBDIR += dolly
SUBDIR += downtime
diff --git a/sysutils/doctl/Makefile b/sysutils/doctl/Makefile
new file mode 100644
index 000000000000..516146494c62
--- /dev/null
+++ b/sysutils/doctl/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= doctl
+DISTVERSION= 1.7.0
+CATEGORIES= sysutils
+
+MAINTAINER= jrm@FreeBSD.org
+COMMENT= Command line tool for DigitalOcean services
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= go
+USE_GITHUB= yes
+GH_ACCOUNT= digitalocean
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+GO_TARGET= ${GO_PKGNAME}/cmd/${PORTNAME}
+
+PLIST_FILES= bin/doctl
+
+.include <bsd.port.mk>
diff --git a/sysutils/doctl/distinfo b/sysutils/doctl/distinfo
new file mode 100644
index 000000000000..bde1fa8aa954
--- /dev/null
+++ b/sysutils/doctl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1502802855
+SHA256 (digitalocean-doctl-1.7.0_GH0.tar.gz) = 216c3d731cd2e999353d420ac2aea94c750d3a0774c42304a1721bf5c6c76c8e
+SIZE (digitalocean-doctl-1.7.0_GH0.tar.gz) = 13128824
diff --git a/sysutils/doctl/pkg-descr b/sysutils/doctl/pkg-descr
new file mode 100644
index 000000000000..490253c27bc7
--- /dev/null
+++ b/sysutils/doctl/pkg-descr
@@ -0,0 +1,5 @@
+doctl is a command line interface for the DigitalOcean API. It is able to
+interact with all of your DigitalOcean resources. To learn more about the
+features available, see the full tutorial on the DigitalOcean community site.
+
+WWW: https://github.com/digitalocean/doctl