aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-19 09:10:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-19 09:10:15 +0000
commit88604c70587a8af86cfe24912bf4a1a078d53367 (patch)
tree0fceeeeb22fecdba45ed4717156fbbc085350ab1 /sysutils
parentbb02f8b91f400006a5877eda4956fed5745b21fa (diff)
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/fusefs-encfs/Makefile1
-rw-r--r--sysutils/fusefs-encfs/files/patch-encfs-PtrImpl.h32
2 files changed, 33 insertions, 0 deletions
diff --git a/sysutils/fusefs-encfs/Makefile b/sysutils/fusefs-encfs/Makefile
index 0273878d2cb3..0462963eb7e2 100644
--- a/sysutils/fusefs-encfs/Makefile
+++ b/sysutils/fusefs-encfs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= encfs
PORTVERSION= 1.3.1
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://arg0.net/users/vgough/download/
PKGNAMEPREFIX= fusefs-
diff --git a/sysutils/fusefs-encfs/files/patch-encfs-PtrImpl.h b/sysutils/fusefs-encfs/files/patch-encfs-PtrImpl.h
new file mode 100644
index 000000000000..38713cc2933d
--- /dev/null
+++ b/sysutils/fusefs-encfs/files/patch-encfs-PtrImpl.h
@@ -0,0 +1,32 @@
+--- encfs/PtrImpl.h.orig Fri Apr 15 11:34:22 2005
++++ encfs/PtrImpl.h Thu Jan 18 22:34:52 2007
+@@ -26,6 +26,16 @@
+
+ #include "OpaqueValue.h"
+
++#include "config.h"
++#if defined(HAVE_ATOMIC_GCC) || defined(HAVE_ATOMIC_GCC_PRIVATE)
++#include <bits/atomicity.h>
++#define HAVE_ATOMIC_FUNCS
++#endif
++
++#if defined(HAVE_ATOMIC_GCC_PRIVATE)
++using namespace __gnu_cxx;
++#endif
++
+ namespace rel
+ {
+
+@@ -55,7 +65,12 @@
+ virtual void destroy() =0;
+
+ protected:
++
++#ifdef HAVE_ATOMIC_FUNCS
++ volatile _Atomic_word refCnt;
++#else
+ int refCnt;
++#endif
+ };
+
+ /*