aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2011-08-26 07:55:06 +0000
committerMartin Matuska <mm@FreeBSD.org>2011-08-26 07:55:06 +0000
commitc4c652e40f1fc559c73b837203d4cf1efd3bd9bb (patch)
tree67027f9f4012910773b37e6b804c5eec692b63bb /sysutils
parentf6c77ebb56b54642f2d3960290e793692e6437f3 (diff)
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/debootstrap/Makefile2
-rw-r--r--sysutils/debootstrap/distinfo4
-rw-r--r--sysutils/debootstrap/files/patch-Makefile24
-rw-r--r--sysutils/debootstrap/files/patch-debootstrap22
-rw-r--r--sysutils/debootstrap/files/patch-functions122
5 files changed, 20 insertions, 154 deletions
diff --git a/sysutils/debootstrap/Makefile b/sysutils/debootstrap/Makefile
index 2400875818bc..42bc745d505a 100644
--- a/sysutils/debootstrap/Makefile
+++ b/sysutils/debootstrap/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= debootstrap
-PORTVERSION= 1.0.32
+PORTVERSION= 1.0.36
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_DEBIAN}
MASTER_SITE_SUBDIR= pool/main/d/${PORTNAME}
diff --git a/sysutils/debootstrap/distinfo b/sysutils/debootstrap/distinfo
index 8719da1feea9..e26a1b5ed90b 100644
--- a/sysutils/debootstrap/distinfo
+++ b/sysutils/debootstrap/distinfo
@@ -1,2 +1,2 @@
-SHA256 (debootstrap_1.0.32.tar.gz) = 3e235b1feb126ded2cf7ffe1d9a52562463a1136bb8ef615aafa406ed3ca3a51
-SIZE (debootstrap_1.0.32.tar.gz) = 55252
+SHA256 (debootstrap_1.0.36.tar.gz) = 40c0e4a2d8bcc82bf6a9cf6a1da7fde47a31684bb838acee45119d5b1aef445a
+SIZE (debootstrap_1.0.36.tar.gz) = 55185
diff --git a/sysutils/debootstrap/files/patch-Makefile b/sysutils/debootstrap/files/patch-Makefile
index e76aff95799e..654d0b926cf1 100644
--- a/sysutils/debootstrap/files/patch-Makefile
+++ b/sysutils/debootstrap/files/patch-Makefile
@@ -1,16 +1,6 @@
---- Makefile.orig 2011-01-20 23:53:15.000000000 +0100
-+++ Makefile 2011-02-26 21:33:51.766311773 +0100
-@@ -3,31 +3,23 @@
-
- MAKEDEV := /sbin/MAKEDEV
-
--ifneq ($(shell uname),GNU)
--all: devices.tar.gz
--else
- all:
--endif
-
- clean:
+--- Makefile.orig 2011-08-15 20:29:37.000000000 +0200
++++ Makefile 2011-08-25 19:19:09.951348991 +0200
+@@ -13,17 +13,17 @@
rm -f devices.tar.gz
rm -rf dev
@@ -28,13 +18,9 @@
- sed 's/@VERSION@/$(VERSION)/g' debootstrap >$(DESTDIR)/usr/sbin/debootstrap
- chown root:root $(DESTDIR)/usr/sbin/debootstrap
- chmod 0755 $(DESTDIR)/usr/sbin/debootstrap
--
--ifneq ($(shell uname),GNU)
-- install -o root -g root -m 0644 devices.tar.gz $(DSDIR)/
--endif
+ sed 's/@VERSION@/$(VERSION)/g' debootstrap >$(PREFIX)/sbin/debootstrap
+ chown root:wheel $(PREFIX)/sbin/debootstrap
+ chmod 0755 $(PREFIX)/sbin/debootstrap
- devices.tar.gz:
- rm -rf dev
+ ifeq ($(shell uname),Linux)
+ install -o root -g root -m 0644 devices.tar.gz $(DSDIR)/
diff --git a/sysutils/debootstrap/files/patch-debootstrap b/sysutils/debootstrap/files/patch-debootstrap
index 98f20a269ed5..c5d324651423 100644
--- a/sysutils/debootstrap/files/patch-debootstrap
+++ b/sysutils/debootstrap/files/patch-debootstrap
@@ -1,11 +1,13 @@
---- debootstrap.orig 2011-02-26 21:36:23.197635062 +0100
-+++ debootstrap 2011-02-26 21:50:23.274213717 +0100
-@@ -384,6 +384,8 @@
+--- debootstrap.orig 2011-08-25 20:19:23.294346076 +0200
++++ debootstrap 2011-08-25 20:22:42.850735086 +0200
+@@ -419,6 +419,10 @@
+ esac
+ fi
- if [ "$ARCH" != "" ]; then
- true
-+elif [ "`uname -s`" = "FreeBSD" ]; then
-+ ARCH=kfreebsd-`/sbin/sysctl -n hw.machine_arch`
- elif [ -x /usr/bin/dpkg ] && \
- /usr/bin/dpkg --print-architecture >/dev/null 2>&1; then
- ARCH=`/usr/bin/dpkg --print-architecture`
++if [ "$HOST_OS" = "freebsd" -a -z "$HOST_ARCH" ]; then
++ HOST_ARCH=kfreebsd-`/sbin/sysctl -n hw.machine_arch`
++fi
++
+ if [ -z "$ARCH" ]; then
+ ARCH=$HOST_ARCH
+ fi
diff --git a/sysutils/debootstrap/files/patch-functions b/sysutils/debootstrap/files/patch-functions
deleted file mode 100644
index 2f97c92dd75e..000000000000
--- a/sysutils/debootstrap/files/patch-functions
+++ /dev/null
@@ -1,122 +0,0 @@
---- functions.orig 2011-05-20 19:57:18.000000000 +0200
-+++ functions 2011-07-15 17:15:49.989386001 +0200
-@@ -236,9 +236,17 @@
- local expchecksum="$2"
- local expsize="$3"
- if [ "$DEBOOTSTRAP_CHECKSUM_FIELD" = "MD5SUM" ]; then
-- relchecksum=`md5sum < "$1" | sed 's/ .*$//'`
-+ if [ "`uname -s`" = "FreeBSD" ]; then
-+ relchecksum=`md5 < "$1"`
-+ else
-+ relchecksum=`md5sum < "$1" | sed 's/ .*$//'`
-+ fi
- else
-- relchecksum=`sha${SHA_SIZE}sum < "$1" | sed 's/ .*$//'`
-+ if [ "`uname -s`" = "FreeBSD" ]; then
-+ relchecksum=`sha${SHA_SIZE} < "$1"`
-+ else
-+ relchecksum=`sha${SHA_SIZE}sum < "$1" | sed 's/ .*$//'`
-+ fi
- fi
- relsize=`wc -c < "$1"`
- if [ "$expsize" -ne "$relsize" ] || [ "$expchecksum" != "$relchecksum" ]; then
-@@ -524,9 +532,9 @@
- local i=
- if [ "$normi" != "" ]; then
- i="$normi"
-- elif [ -x /bin/bunzip2 ] && [ "$bz2i" != "" ]; then
-+ elif [ -x /bin/bunzip2 -o -x /usr/bin/bunzip2 ] && [ "$bz2i" != "" ]; then
- i="$bz2i"
-- elif [ -x /bin/gunzip ] && [ "$gzi" != "" ]; then
-+ elif [ -x /bin/gunzip -o -x /usr/bin/gunzip ] && [ "$gzi" != "" ]; then
- i="$gzi"
- fi
- if [ "$i" != "" ]; then
-@@ -552,11 +560,11 @@
- ext="$ext $normi ."
- i="$normi"
- fi
-- if [ -x /bin/bunzip2 ] && [ "$bz2i" != "" ]; then
-+ if [ -x /bin/bunzip2 -o -x /usr/bin/bunzip2 ] && [ "$bz2i" != "" ]; then
- ext="$ext $bz2i bz2"
- i="${i:-$bz2i}"
- fi
-- if [ -x /bin/gunzip ] && [ "$gzi" != "" ]; then
-+ if [ -x /bin/gunzip -o -x /usr/bin/gunzip ] && [ "$gzi" != "" ]; then
- ext="$ext $gzi gz"
- i="${i:-$gzi}"
- fi
-@@ -690,7 +698,7 @@
- for c in $COMPONENTS; do
- local path="dists/$SUITE/$c/binary-$ARCH/Packages"
- local pkgdest="$TARGET/$($DLDEST pkg "$SUITE" "$c" "$ARCH" "$m" "$path")"
-- if [ -x /bin/gunzip ] && get "$m/${path}.gz" "${pkgdest}.gz"; then
-+ if [ -x /bin/gunzip -o -x /usr/bin/gunzip ] && get "$m/${path}.gz" "${pkgdest}.gz"; then
- rm -f "$pkgdest"
- gunzip "$pkgdest.gz"
- elif get "$m/$path" "$pkgdest"; then
-@@ -948,12 +956,16 @@
- hurd-*)
- ;;
- *)
-- umount_on_exit /dev/pts
-- umount_on_exit /dev/shm
-- umount_on_exit /proc/bus/usb
-- umount_on_exit /proc
-- umount "$TARGET/proc" 2>/dev/null || true
-- in_target mount -t proc proc /proc
-+ if [ `uname -s` = "FreeBSD" ] ; then
-+ mount -t linprocfs proc $TARGET/proc
-+ else
-+ umount_on_exit /dev/pts
-+ umount_on_exit /dev/shm
-+ umount_on_exit /proc/bus/usb
-+ umount_on_exit /proc
-+ umount "$TARGET/proc" 2>/dev/null || true
-+ in_target mount -t proc proc /proc
-+ fi
- if [ -d "$TARGET/sys" ] && \
- grep -q '[[:space:]]sysfs' /proc/filesystems 2>/dev/null; then
- umount_on_exit /sys
-@@ -978,13 +990,17 @@
- hurd-*)
- setup_devices_hurd ;;
- *)
-- if [ -e "$DEVICES_TARGZ" ]; then
-- zcat "$DEVICES_TARGZ" | (cd "$TARGET"; tar -xf -)
-+ if [ "`uname -s`" = "FreeBSD" ]; then
-+ mount -t devfs devfs $TARGET/dev
- else
-- if [ -e /dev/.devfsd ] ; then
-- in_target mount -t devfs devfs /dev
-+ if [ -e "$DEVICES_TARGZ" ]; then
-+ zcat "$DEVICES_TARGZ" | (cd "$TARGET"; tar -xf -)
- else
-- error 1 NODEVTGZ "no %s. cannot create devices" "$DEVICES_TARGZ"
-+ if [ -e /dev/.devfsd ] ; then
-+ in_target mount -t devfs devfs /dev
-+ else
-+ error 1 NODEVTGZ "no %s. cannot create devices" "$DEVICES_TARGZ"
-+ fi
- fi
- fi
- ;;
-@@ -1197,12 +1213,14 @@
- kfreebsd-*|hurd-*)
- ;;
- *)
-- mknod "$1/test-dev-null" c 1 3 || return 1
-- if ! echo test > "$1/test-dev-null"; then
-+ if [ "`uname -s`" != "FreeBSD" ]; then
-+ mknod "$1/test-dev-null" c 1 3 || return 1
-+ if ! echo test > "$1/test-dev-null"; then
-+ rm -f "$1/test-dev-null"
-+ return 1
-+ fi
- rm -f "$1/test-dev-null"
-- return 1
- fi
-- rm -f "$1/test-dev-null"
- ;;
- esac
-