aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-12-27 07:14:31 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-12-27 07:14:31 +0000
commit66f25d9d10797a0ff490b4fbee1f1fa92ab336e5 (patch)
treeb931ae8f2d9d2ac5ab6bc181a850d914287f2f89 /sysutils
parentb69057eb78008ba973b724504ec44d48f1921c45 (diff)
downloadports-66f25d9d10797a0ff490b4fbee1f1fa92ab336e5.tar.gz
ports-66f25d9d10797a0ff490b4fbee1f1fa92ab336e5.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile3
-rw-r--r--sysutils/py-upt-freebsd/Makefile28
-rw-r--r--sysutils/py-upt-freebsd/distinfo3
-rw-r--r--sysutils/py-upt-freebsd/pkg-descr5
-rw-r--r--sysutils/py-upt-pypi/Makefile26
-rw-r--r--sysutils/py-upt-pypi/distinfo3
-rw-r--r--sysutils/py-upt-pypi/pkg-descr5
-rw-r--r--sysutils/py-upt/Makefile27
-rw-r--r--sysutils/py-upt/distinfo3
-rw-r--r--sysutils/py-upt/files/patch-setup.cfg15
-rw-r--r--sysutils/py-upt/pkg-descr5
11 files changed, 123 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 553dfc0580f5..59533d0f6bd9 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1023,6 +1023,9 @@
SUBDIR += py-supervisor
SUBDIR += py-tarsnapper
SUBDIR += py-tmuxp
+ SUBDIR += py-upt
+ SUBDIR += py-upt-freebsd
+ SUBDIR += py-upt-pypi
SUBDIR += py-uptime
SUBDIR += py-zdaemon
SUBDIR += pydf
diff --git a/sysutils/py-upt-freebsd/Makefile b/sysutils/py-upt-freebsd/Makefile
new file mode 100644
index 000000000000..6808b9bb7af4
--- /dev/null
+++ b/sysutils/py-upt-freebsd/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= upt-freebsd
+DISTVERSION= 0.3
+CATEGORIES= sysutils ports-mgmt python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= tipecaml@gmail.com
+COMMENT= FreeBSD backend for upt
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}upt>=0.4:sysutils/py-upt@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+TEST_ENV= PORTSDIR="/nonexistent"
+
+do-test:
+ @cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m unittest -v
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-upt-freebsd/distinfo b/sysutils/py-upt-freebsd/distinfo
new file mode 100644
index 000000000000..ae6d3b364563
--- /dev/null
+++ b/sysutils/py-upt-freebsd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1577071801
+SHA256 (upt-freebsd-0.3.tar.gz) = 0fd55ea5d9d9c83aa2507bb330dfb9c4d4a5e93aea54bd02453061bc9706fdf4
+SIZE (upt-freebsd-0.3.tar.gz) = 8830
diff --git a/sysutils/py-upt-freebsd/pkg-descr b/sysutils/py-upt-freebsd/pkg-descr
new file mode 100644
index 000000000000..bce16429878d
--- /dev/null
+++ b/sysutils/py-upt-freebsd/pkg-descr
@@ -0,0 +1,5 @@
+Universal Packaging Tool: FreeBSD Ports backend
+
+This is a FreeBSD backend for upt.
+
+WWW: https://framagit.org/upt/upt-freebsd
diff --git a/sysutils/py-upt-pypi/Makefile b/sysutils/py-upt-pypi/Makefile
new file mode 100644
index 000000000000..707031849a0b
--- /dev/null
+++ b/sysutils/py-upt-pypi/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= upt-pypi
+DISTVERSION= 0.5
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= tipecaml@gmail.com
+COMMENT= PyPI frontend for upt
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}upt>=0.9:sysutils/py-upt@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m unittest -v
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-upt-pypi/distinfo b/sysutils/py-upt-pypi/distinfo
new file mode 100644
index 000000000000..1ad8a3b45355
--- /dev/null
+++ b/sysutils/py-upt-pypi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1574701220
+SHA256 (upt-pypi-0.5.tar.gz) = 6cfe91ab916ab190d4d6440b829c2c13d42855724f681c39483e98a506cd9c94
+SIZE (upt-pypi-0.5.tar.gz) = 12414
diff --git a/sysutils/py-upt-pypi/pkg-descr b/sysutils/py-upt-pypi/pkg-descr
new file mode 100644
index 000000000000..50aa5df35e44
--- /dev/null
+++ b/sysutils/py-upt-pypi/pkg-descr
@@ -0,0 +1,5 @@
+Universal Packaging Tool: PyPI frontend
+
+This is a PyPI frontend for upt.
+
+WWW: https://framagit.org/upt/upt-pypi
diff --git a/sysutils/py-upt/Makefile b/sysutils/py-upt/Makefile
new file mode 100644
index 000000000000..15c1eef8f807
--- /dev/null
+++ b/sysutils/py-upt/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= upt
+DISTVERSION= 0.11
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= tipecaml@gmail.com
+COMMENT= Package software from any package manager to any distribution
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}colorlog>0:devel/py-colorlog@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>0:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}spdx-lookup>0:misc/py-spdx-lookup@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils concurrent
+
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m unittest -v
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-upt/distinfo b/sysutils/py-upt/distinfo
new file mode 100644
index 000000000000..99966ec51243
--- /dev/null
+++ b/sysutils/py-upt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1577053933
+SHA256 (upt-0.11.tar.gz) = 65ef84ec7d8ba5f563bd6e2d522f055b80b143063f7cd96663bf8ad2c424df79
+SIZE (upt-0.11.tar.gz) = 29366
diff --git a/sysutils/py-upt/files/patch-setup.cfg b/sysutils/py-upt/files/patch-setup.cfg
new file mode 100644
index 000000000000..7153b6a12140
--- /dev/null
+++ b/sysutils/py-upt/files/patch-setup.cfg
@@ -0,0 +1,15 @@
+# Uses/python.py (concurrent) doesnt find
+# share/* stuff for concurrent processing
+# only ^man/man*
+
+--- setup.cfg.orig 2019-12-27 05:05:29 UTC
++++ setup.cfg
+@@ -42,7 +42,7 @@ backends =
+ upt-openbsd
+
+ [options.data_files]
+-share/man/man1 =
++man/man1 =
+ upt.1
+
+ [egg_info]
diff --git a/sysutils/py-upt/pkg-descr b/sysutils/py-upt/pkg-descr
new file mode 100644
index 000000000000..2d5978c51000
--- /dev/null
+++ b/sysutils/py-upt/pkg-descr
@@ -0,0 +1,5 @@
+A unified CLI tool that converts a package from a language-specific package
+manager (such as PyPI or NPM) to an almost ready-to-use package for Free
+Unix-based operating systems (such as a GNU/Linux distribution or *BSD).
+
+WWW: https://framagit.org/upt/upt