aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2004-06-21 17:38:48 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2004-06-21 17:38:48 +0000
commit67b44cc4ca2b54b05923e7df299eb92aeb0cbbb9 (patch)
tree8c25aa115eceafa73cf4496032fc98d6d6ce6e1f /sysutils
parent8c86deb0d451efcd2eeec460f1b4f49f5e1254e0 (diff)
downloadports-67b44cc4ca2b54b05923e7df299eb92aeb0cbbb9.tar.gz
ports-67b44cc4ca2b54b05923e7df299eb92aeb0cbbb9.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/portupgrade-devel/Makefile1
-rw-r--r--sysutils/portupgrade-devel/files/patch-portinfo.rb19
-rw-r--r--sysutils/portupgrade/Makefile1
-rw-r--r--sysutils/portupgrade/files/patch-portinfo.rb19
4 files changed, 40 insertions, 0 deletions
diff --git a/sysutils/portupgrade-devel/Makefile b/sysutils/portupgrade-devel/Makefile
index 62a8e1c0588f..cc5d42fbc9bb 100644
--- a/sysutils/portupgrade-devel/Makefile
+++ b/sysutils/portupgrade-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= portupgrade
PORTVERSION= 20040529
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.iDaemons.org/pub/distfiles/ \
${MASTER_SITE_LOCAL}
diff --git a/sysutils/portupgrade-devel/files/patch-portinfo.rb b/sysutils/portupgrade-devel/files/patch-portinfo.rb
new file mode 100644
index 000000000000..2465672975fb
--- /dev/null
+++ b/sysutils/portupgrade-devel/files/patch-portinfo.rb
@@ -0,0 +1,19 @@
+Index: lib/portinfo.rb
+===================================================================
+RCS file: /home/cvs/pkgtools/lib/portinfo.rb,v
+retrieving revision 1.16
+diff -u -r1.16 portinfo.rb
+--- lib/portinfo.rb 8 Nov 2002 17:18:27 -0000 1.16
++++ lib/portinfo.rb 21 Jun 2004 17:36:11 -0000
+@@ -17,9 +17,9 @@
+ line.is_a?(String) or raise ArgumentError,
+ "You must specify a one line text of port info."
+
+- values = line.chomp.split(FIELD_SEPARATOR, NFIELDS)
++ values = line.chomp.split(FIELD_SEPARATOR)
+
+- if values.size != NFIELDS || values[NFIELDS - 1].index(FIELD_SEPARATOR)
++ if values.size < NFIELDS || values[NFIELDS - 1].index(FIELD_SEPARATOR)
+ raise ArgumentError, "Port info line must consist of #{NFIELDS} fields."
+ end
+
diff --git a/sysutils/portupgrade/Makefile b/sysutils/portupgrade/Makefile
index 62a8e1c0588f..cc5d42fbc9bb 100644
--- a/sysutils/portupgrade/Makefile
+++ b/sysutils/portupgrade/Makefile
@@ -7,6 +7,7 @@
PORTNAME= portupgrade
PORTVERSION= 20040529
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.iDaemons.org/pub/distfiles/ \
${MASTER_SITE_LOCAL}
diff --git a/sysutils/portupgrade/files/patch-portinfo.rb b/sysutils/portupgrade/files/patch-portinfo.rb
new file mode 100644
index 000000000000..2465672975fb
--- /dev/null
+++ b/sysutils/portupgrade/files/patch-portinfo.rb
@@ -0,0 +1,19 @@
+Index: lib/portinfo.rb
+===================================================================
+RCS file: /home/cvs/pkgtools/lib/portinfo.rb,v
+retrieving revision 1.16
+diff -u -r1.16 portinfo.rb
+--- lib/portinfo.rb 8 Nov 2002 17:18:27 -0000 1.16
++++ lib/portinfo.rb 21 Jun 2004 17:36:11 -0000
+@@ -17,9 +17,9 @@
+ line.is_a?(String) or raise ArgumentError,
+ "You must specify a one line text of port info."
+
+- values = line.chomp.split(FIELD_SEPARATOR, NFIELDS)
++ values = line.chomp.split(FIELD_SEPARATOR)
+
+- if values.size != NFIELDS || values[NFIELDS - 1].index(FIELD_SEPARATOR)
++ if values.size < NFIELDS || values[NFIELDS - 1].index(FIELD_SEPARATOR)
+ raise ArgumentError, "Port info line must consist of #{NFIELDS} fields."
+ end
+