aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-12-28 07:55:47 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-12-28 07:55:47 +0000
commit93b7ed7f504a49dd67ffe3ac687750a2cf3de9af (patch)
tree8da4bd11526f4a4c8953d4db2c3e091588172722 /sysutils
parent8f2582a5696b97b61eaf3829d827c8b0ba5bc289 (diff)
[PATCH] simplify pear-* ports
These patches do the following things for PEAR ports: * devel-pear-PEAR-Makefile.common.patch - provides a do-install target and all that jazz in devel/pear-PEAR/Makefile.common - individual PEAR ports now just set a few variables: * pear-ports-Makefile.common-ng.patch contains changes for all pear-* ports including devel/pear-PEAR See http://smradoch.innuendo.cz/FreeBSD/ for complete description. Note: still missing are: devel/pear-HTML_Common devel/pear-I18N net/pear-Net_NNTP security/pear-Auth PR: ports/59213 Submitted by: Roman Neuhauser <neuhauser@bellavista.cz>
Notes
Notes: svn path=/head/; revision=96732
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/pear-File/Makefile13
-rw-r--r--sysutils/pear-File/pkg-plist8
-rw-r--r--sysutils/pear-File_Find/Makefile10
-rw-r--r--sysutils/pear-File_Find/pkg-plist3
-rw-r--r--sysutils/pear-Log/Makefile12
-rw-r--r--sysutils/pear-Log/pkg-plist14
6 files changed, 16 insertions, 44 deletions
diff --git a/sysutils/pear-File/Makefile b/sysutils/pear-File/Makefile
index 5dfbf6370f82..71bc0e578f29 100644
--- a/sysutils/pear-File/Makefile
+++ b/sysutils/pear-File/Makefile
@@ -7,7 +7,7 @@
PORTNAME= File
PORTVERSION= 1.0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils www pear
MAINTAINER= ports@FreeBSD.org
@@ -16,12 +16,9 @@ COMMENT= PEAR common file and directory routines
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
-
-do-install:
- @${CP} -Rp ${WRKSRC}/* ${PEARDIR}
- @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/${PORTNAME}*
- @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/tests
+FILES= File.php File/CSV.php
+TESTS= parser.php test.csv
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.include <bsd.port.post.mk>
diff --git a/sysutils/pear-File/pkg-plist b/sysutils/pear-File/pkg-plist
deleted file mode 100644
index 9d55bdae8898..000000000000
--- a/sysutils/pear-File/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-%%PEARDIR%%/File/CSV.php
-%%PEARDIR%%/File.php
-%%PKGREGDIR%%/package.xml
-%%PEARDIR%%/tests/parser.php
-%%PEARDIR%%/tests/test.csv
-@dirrm %%PKGREGDIR%%
-@unexec rmdir %D/share/pear/tests 2> /dev/null || true
-@unexec rmdir %D/share/pear/File 2> /dev/null || true
diff --git a/sysutils/pear-File_Find/Makefile b/sysutils/pear-File_Find/Makefile
index eff775237b72..b4204f959ae4 100644
--- a/sysutils/pear-File_Find/Makefile
+++ b/sysutils/pear-File_Find/Makefile
@@ -7,6 +7,7 @@
PORTNAME= File_Find
PORTVERSION= 0.2.0
+PORTREVISION= 1
CATEGORIES= sysutils www pear
MASTER_SITES= http://pear.php.net/get/
PKGNAMEPREFIX= pear-
@@ -19,10 +20,9 @@ COMMENT= A PEAR Class to facilitate the search of filesystems
BUILD_DEPENDS= ${PEARDIR}/File.php:${PORTSDIR}/sysutils/pear-File
RUN_DEPENDS= ${BUILD_DEPENDS}
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
-
-do-install:
- @${INSTALL_DATA} ${WRKSRC}/Find.php ${PEARDIR}/File/Find.php
+CATEGORY= File
+FILES= Find.php
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.include <bsd.port.post.mk>
diff --git a/sysutils/pear-File_Find/pkg-plist b/sysutils/pear-File_Find/pkg-plist
deleted file mode 100644
index e785fa8126c1..000000000000
--- a/sysutils/pear-File_Find/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-%%PEARDIR%%/File/Find.php
-%%PKGREGDIR%%/package.xml
-@dirrm %%PKGREGDIR%%
diff --git a/sysutils/pear-Log/Makefile b/sysutils/pear-Log/Makefile
index 4b377a581986..f4d5b330040c 100644
--- a/sysutils/pear-Log/Makefile
+++ b/sysutils/pear-Log/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Log
PORTVERSION= 1.7.1
+PORTREVISION= 1
CATEGORIES= sysutils www pear
MAINTAINER= ports@FreeBSD.org
@@ -15,11 +16,10 @@ COMMENT= PEAR logging utilities
BUILD_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
RUN_DEPENDS= ${BUILD_DEPENDS}
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
-
-do-install:
- @${CP} -Rp ${WRKSRC}/* ${PEARDIR}
- @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/${PORTNAME}*
+FILES= Log.php Log/composite.php Log/console.php Log/error_log.php \
+ Log/file.php Log/mail.php Log/mcal.php Log/observer.php \
+ Log/sql.php Log/syslog.php Log/win.php
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.include <bsd.port.post.mk>
diff --git a/sysutils/pear-Log/pkg-plist b/sysutils/pear-Log/pkg-plist
deleted file mode 100644
index 731f8fafdc0c..000000000000
--- a/sysutils/pear-Log/pkg-plist
+++ /dev/null
@@ -1,14 +0,0 @@
-%%PEARDIR%%/Log/composite.php
-%%PEARDIR%%/Log/console.php
-%%PEARDIR%%/Log/error_log.php
-%%PEARDIR%%/Log/file.php
-%%PEARDIR%%/Log/mail.php
-%%PEARDIR%%/Log/mcal.php
-%%PEARDIR%%/Log/observer.php
-%%PEARDIR%%/Log/sql.php
-%%PEARDIR%%/Log/syslog.php
-%%PEARDIR%%/Log/win.php
-%%PEARDIR%%/Log.php
-%%PKGREGDIR%%/package.xml
-@dirrm %%PEARDIR%%/Log
-@dirrm %%PKGREGDIR%%