aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-12-20 18:47:43 +0000
committerSteve Wills <swills@FreeBSD.org>2013-12-20 18:47:43 +0000
commitd96a4f1b31daed286260b4f66d17c551be1f46d0 (patch)
tree98bab27f429b293641143d70ad682943d57df47d /sysutils
parent491ba8c3a65a9d9bddbcbeb3e3064571b4d55abd (diff)
downloadports-d96a4f1b31daed286260b4f66d17c551be1f46d0.tar.gz
ports-d96a4f1b31daed286260b4f66d17c551be1f46d0.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/puppet/Makefile4
-rw-r--r--sysutils/puppet/files/patch-ext__rack__files__config.ru13
-rw-r--r--sysutils/puppet/files/patch-lib__puppet__rails__resource.rb15
3 files changed, 31 insertions, 1 deletions
diff --git a/sysutils/puppet/Makefile b/sysutils/puppet/Makefile
index 7c7697f22f96..c7b423413adb 100644
--- a/sysutils/puppet/Makefile
+++ b/sysutils/puppet/Makefile
@@ -3,7 +3,7 @@
PORTNAME= puppet
PORTVERSION= 3.3.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils
MASTER_SITES= http://downloads.puppetlabs.com/puppet/
@@ -68,6 +68,8 @@ post-patch:
${WRKSRC}/lib/puppet/util/run_mode.rb
@${REINPLACE_CMD} -e "s|\$$confdir/ssl|/var/puppet/ssl|" \
${WRKSRC}/lib/puppet/defaults.rb
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" \
+ ${WRKSRC}/ext/rack/files/config.ru
do-install:
@cd ${WRKSRC} && ${SETENV} PREFIX=${PREFIX} ${RUBY} ${WRKSRC}/install.rb --no-configs --destdir=${STAGEDIR}
diff --git a/sysutils/puppet/files/patch-ext__rack__files__config.ru b/sysutils/puppet/files/patch-ext__rack__files__config.ru
new file mode 100644
index 000000000000..135f279ca1e5
--- /dev/null
+++ b/sysutils/puppet/files/patch-ext__rack__files__config.ru
@@ -0,0 +1,13 @@
+--- ./ext/rack/files/config.ru.orig 2013-12-20 16:47:22.876896492 +0000
++++ ./ext/rack/files/config.ru 2013-12-20 16:47:33.826895721 +0000
+@@ -14,8 +14,8 @@
+ # Rack applications typically don't start as root. Set --confdir and --vardir
+ # to prevent reading configuration from ~puppet/.puppet/puppet.conf and writing
+ # to ~puppet/.puppet
+-ARGV << "--confdir" << "/etc/puppet"
+-ARGV << "--vardir" << "/var/lib/puppet"
++ARGV << "--confdir" << "%%PREFIX%%/etc/puppet"
++ARGV << "--vardir" << "/var/puppet"
+
+ # NOTE: it's unfortunate that we have to use the "CommandLine" class
+ # here to launch the app, but it contains some initialization logic
diff --git a/sysutils/puppet/files/patch-lib__puppet__rails__resource.rb b/sysutils/puppet/files/patch-lib__puppet__rails__resource.rb
new file mode 100644
index 000000000000..4f7edf4d7731
--- /dev/null
+++ b/sysutils/puppet/files/patch-lib__puppet__rails__resource.rb
@@ -0,0 +1,15 @@
+--- ./lib/puppet/rails/resource.rb.orig 2013-10-07 18:00:47.000000000 +0000
++++ ./lib/puppet/rails/resource.rb 2013-12-20 16:47:14.340897154 +0000
+@@ -84,7 +84,11 @@
+ end
+
+ def [](param)
+- super || parameter(param)
++ if param == 'id'
++ super
++ else
++ super || parameter(param)
++ end
+ end
+
+ # Make sure this resource is equivalent to the provided Parser resource.