aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-11-02 23:00:53 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-11-02 23:00:53 +0000
commit05ca77bc933651fa865f0ddcc2f4e9987cb92650 (patch)
tree545ae90e5b6918f8ea41d097186d46da653a17ce /sysutils
parent1811827135468d77abe9633800da49edcc3072d2 (diff)
sysutils/duplicity: fix for python 3.x
PR: ports/182765 Submitted by: Kurt Jaeger <fbsd-ports opsec.eu> Approved by: maintainer (timeout)
Notes
Notes: svn path=/head/; revision=332550
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/duplicity/Makefile6
-rw-r--r--sysutils/duplicity/files/patch-setup.py12
2 files changed, 12 insertions, 6 deletions
diff --git a/sysutils/duplicity/Makefile b/sysutils/duplicity/Makefile
index 727ed9dccc9f..22be4c7466dc 100644
--- a/sysutils/duplicity/Makefile
+++ b/sysutils/duplicity/Makefile
@@ -9,14 +9,14 @@ MASTER_SITES= http://launchpad.net/duplicity/0.6-series/${PORTVERSION}/+download
MAINTAINER= jase@FreeBSD.org
COMMENT= Backup tool that uses librsync and GnuPG
-LIB_DEPENDS= rsync:${PORTSDIR}/net/librsync
+LIB_DEPENDS= librsync.so:${PORTSDIR}/net/librsync
RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
FETCH_ARGS= -pRr
CONFLICTS= duplicity-0.5.* duplicity-devel-[0-9]*
-USE_PYTHON= 2.5+
+USE_PYTHON= yes
USE_PYDISTUTILS=yes
USE_LDCONFIG= yes
@@ -32,7 +32,7 @@ SSH_DESC= Install SSH/SCP/SFTP backend
U1_DESC= Install Ubuntu One backend
NO_STAGE= yes
-.include "bsd.port.options.mk"
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
diff --git a/sysutils/duplicity/files/patch-setup.py b/sysutils/duplicity/files/patch-setup.py
index 3a86163122d2..d128a8724631 100644
--- a/sysutils/duplicity/files/patch-setup.py
+++ b/sysutils/duplicity/files/patch-setup.py
@@ -1,6 +1,12 @@
---- setup.py.orig 2011-11-25 23:58:57.147597966 +0000
-+++ setup.py 2011-11-26 00:00:43.169721395 +0000
-@@ -31,6 +31,10 @@
+--- setup.py.orig 2013-08-22 15:30:09.000000000 +0200
++++ setup.py 2013-10-06 19:43:39.000000000 +0200
+@@ -26,11 +26,15 @@
+ version_string = "0.6.22"
+
+ if sys.version_info[:2] < (2,4):
+- print "Sorry, duplicity requires version 2.4 or later of python"
++ print("Sorry, duplicity requires version 2.4 or later of python")
+ sys.exit(1)
incdir_list = libdir_list = None