aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2017-05-07 15:04:55 +0000
committerRene Ladan <rene@FreeBSD.org>2017-05-07 15:04:55 +0000
commit3a40ebcff8cf321075c6f1d5e99328a31d9a9a05 (patch)
treeababd7fbc1714aa25094f891d88e30b8d78cd11b /sysutils
parent91d5b3a2846bec5289edae162aac194b279413b0 (diff)
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/grok/Makefile46
-rw-r--r--sysutils/grok/distinfo2
-rw-r--r--sysutils/grok/files/patch-Makefile22
-rw-r--r--sysutils/grok/files/patch-discover_main.c11
-rw-r--r--sysutils/grok/files/patch-grok_discover.c12
-rw-r--r--sysutils/grok/files/pkg-message.in8
-rw-r--r--sysutils/grok/pkg-descr4
-rw-r--r--sysutils/grok/pkg-plist13
9 files changed, 0 insertions, 119 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index c2eec2aa6634..3335aa28fdf9 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -410,7 +410,6 @@
SUBDIR += graid5
SUBDIR += graveman
SUBDIR += graylog
- SUBDIR += grok
SUBDIR += grub2
SUBDIR += grub2-bhyve
SUBDIR += grub2-efi
diff --git a/sysutils/grok/Makefile b/sysutils/grok/Makefile
deleted file mode 100644
index e694f1ba2a51..000000000000
--- a/sysutils/grok/Makefile
+++ /dev/null
@@ -1,46 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= grok
-PORTVERSION= 1.20110708.1
-PORTREVISION= 6
-PORTEPOCH= 1
-CATEGORIES= sysutils
-MASTER_SITES= GOOGLE_CODE
-
-MAINTAINER= wxs@FreeBSD.org
-COMMENT= Expert system for real-time log analysis
-
-BROKEN= Unfetchable (google code has gone away)
-DEPRECATED= Unfetchable for more than six months (google code has gone away)
-EXPIRATION_DATE= 2017-04-30
-
-OPTIONS_DEFINE= DOCS
-
-BUILD_DEPENDS= gperf>=3.0.3:devel/gperf
-LIB_DEPENDS= libpcre.so:devel/pcre \
- libevent.so:devel/libevent \
- libtokyocabinet.so:databases/tokyocabinet
-RUN_DEPENDS:= ${BUILD_DEPENDS}
-
-MAKE_ENV+= GPERF=${LOCALBASE}/bin/gperf \
- EXTRA_CFLAGS=-I${LOCALBASE}/include \
- EXTRA_LDFLAGS=-L${LOCALBASE}/lib
-
-USES= gmake pkgconfig
-USE_LDCONFIG= yes
-
-SUB_FILES= pkg-message
-
-PROJECTHOST= semicomplete
-PORTDOCS= CHANGELIST INSTALL
-
-post-patch:
- @${REINPLACE_CMD} 's|PREFIX=|PREFIX?=|; s|-g root|-g wheel|; ' \
- ${WRKSRC}/Makefile
-
-post-install:
- ${INSTALL_MAN} ${WRKSRC}/grok.1 ${STAGEDIR}${PREFIX}/man/man1
- @${INSTALL} -d ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-
-.include <bsd.port.mk>
diff --git a/sysutils/grok/distinfo b/sysutils/grok/distinfo
deleted file mode 100644
index 27b776a28862..000000000000
--- a/sysutils/grok/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (grok-1.20110708.1.tar.gz) = 3362857a03115029df76c3a3f0587b2ed1f9977f963bb1bd701e2bf59ad701c8
-SIZE (grok-1.20110708.1.tar.gz) = 1445902
diff --git a/sysutils/grok/files/patch-Makefile b/sysutils/grok/files/patch-Makefile
deleted file mode 100644
index 784a0be3d965..000000000000
--- a/sysutils/grok/files/patch-Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
---- Makefile.orig 2009-12-25 20:50:34.181480177 -0500
-+++ Makefile 2009-12-25 20:51:40.171173802 -0500
-@@ -12,7 +12,7 @@
- # On FreeBSD, you may want to set GPERF=/usr/local/bin/gperf since
- # the base system gperf is too old.
- ifeq ($(PLATFORM), FreeBSD)
--GPERF?=/usr/local/bin/gperf
-+GPERF?=${LOCALBASE}/bin/gperf
- else
- GPERF?=/usr/bin/gperf
- endif
-@@ -28,8 +28,8 @@
- LDFLAGS+=-lpcre -levent -rdynamic -ltokyocabinet
-
- # Sane includes
--CFLAGS+=-I/usr/local/include
--LDFLAGS+=-L/usr/local/lib
-+CFLAGS+=-I. -I${LOCALBASE}/include
-+LDFLAGS+=-L${LOCALBASE}/lib
-
- # Uncomment to totally disable logging features
- #CFLAGS+=-DNOLOGGING
diff --git a/sysutils/grok/files/patch-discover_main.c b/sysutils/grok/files/patch-discover_main.c
deleted file mode 100644
index 7875f999292c..000000000000
--- a/sysutils/grok/files/patch-discover_main.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./discover_main.c.orig 2013-10-10 13:25:59.000000000 -0400
-+++ ./discover_main.c 2013-10-10 13:26:13.000000000 -0400
-@@ -33,7 +33,7 @@
- grok_init(&grok);
-
- int pattern_count = 0;
-- while ((opt = getopt_long_only(argc, argv, "hp:v", options, &optind)) != -1) {
-+ while ((opt = getopt_long_only(argc, argv, "hp:v", options, NULL)) != -1) {
- switch (opt) {
- case 'h':
- usage();
diff --git a/sysutils/grok/files/patch-grok_discover.c b/sysutils/grok/files/patch-grok_discover.c
deleted file mode 100644
index 000e7c2d0707..000000000000
--- a/sysutils/grok/files/patch-grok_discover.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./grok_discover.c.orig 2013-10-10 13:26:22.000000000 -0400
-+++ ./grok_discover.c 2013-10-10 13:27:24.000000000 -0400
-@@ -187,6 +187,9 @@
- if (first_match_endpos > 0) {
- offset += first_match_endpos;
- }
-+ else {
-+ offset += 1;
-+ }
- } else { /* We found a match, replace it in the pattern */
- grok_log(gdt, LOG_DISCOVER, "%d: Matched %s on '%.*s'",
- rounds, best_match.grok->pattern,
diff --git a/sysutils/grok/files/pkg-message.in b/sysutils/grok/files/pkg-message.in
deleted file mode 100644
index 7e86945280a9..000000000000
--- a/sysutils/grok/files/pkg-message.in
+++ /dev/null
@@ -1,8 +0,0 @@
-============================================================
-Examples and documentation are available at:
-
-http://code.google.com/p/semicomplete/wiki/Grok
-
-Also, modifications to syslog.conf may be necessary.
-Usually "user.info /var/log/messages" is enough.
-============================================================
diff --git a/sysutils/grok/pkg-descr b/sysutils/grok/pkg-descr
deleted file mode 100644
index 4665a3e20c79..000000000000
--- a/sysutils/grok/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-An expert system for real-time log analysis that allows for user-defined
-actions to happen when a log rule is matched.
-
-WWW: http://code.google.com/p/semicomplete/wiki/Grok
diff --git a/sysutils/grok/pkg-plist b/sysutils/grok/pkg-plist
deleted file mode 100644
index 1030addd8f81..000000000000
--- a/sysutils/grok/pkg-plist
+++ /dev/null
@@ -1,13 +0,0 @@
-bin/discogrok
-bin/grok
-include/grok.h
-include/grok_capture.h
-include/grok_capture_xdr.h
-include/grok_discover.h
-include/grok_logging.h
-include/grok_match.h
-include/grok_pattern.h
-include/grok_version.h
-lib/libgrok.so
-man/man1/grok.1.gz
-%%DATADIR%%/patterns/base