aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-07-09 12:28:18 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-07-09 12:28:18 +0000
commit3aaf42683776e00435fdb2108e26a26fdda7a396 (patch)
tree16f2930dce75823d9061bc2807750bd6d5381e49 /sysutils
parentf057d309cdf57297c190ff1b7d3576f2ea02aed6 (diff)
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/zccron/Makefile41
-rw-r--r--sysutils/zccron/distinfo3
-rw-r--r--sysutils/zccron/pkg-descr13
4 files changed, 58 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index b48e6b93ec80..c15ba1bc11c2 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -831,6 +831,7 @@
SUBDIR += xwipower
SUBDIR += xwlans
SUBDIR += yawho
+ SUBDIR += zccron
SUBDIR += zeroer
SUBDIR += zfs-replicate
SUBDIR += zidrav
diff --git a/sysutils/zccron/Makefile b/sysutils/zccron/Makefile
new file mode 100644
index 000000000000..9f393c9b8896
--- /dev/null
+++ b/sysutils/zccron/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: zccron
+# Date created: 24 June 2008
+# Whom: Zane C. Bowers
+#
+# $FreeBSD$
+#
+
+PORTNAME= zccron
+PORTVERSION= 0.0.0
+CATEGORIES= sysutils deskutils
+MASTER_SITES= http://cpan.org/authors/id/V/VV/VVELOX/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.pl
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= A cron like tool that performs a single pass on a crontab stored in ZConf
+
+RUN_DEPENDS= ${SITE_PERL}/DateTime/Event/Cron.pm:${PORTSDIR}/devel/p5-DateTime-Event-Cron \
+ ${SITE_PERL}/${PERL_ARCH}/DateTime/Duration.pm:${PORTSDIR}/devel/p5-DateTime \
+ ${SITE_PERL}/DateTime/Format/Strptime.pm:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
+ ${SITE_PERL}/ZConf.pm:${PORTSDIR}/devel/p5-ZConf
+
+USE_PERL5= yes
+NO_WRKSUBDIR= yes
+MAN1= ${PORTNAME}.1
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-extract:
+ @${CP} -v ${DISTDIR}/${DISTNAME} ${WRKSRC}
+
+do-build:
+ @${EXEC} pod2man --section=1 --release=${PORTVERSION} --name=${PORTNAME} --center=${PORTNAME}" user guide" ${WRKSRC}/${DISTNAME} ${WRKSRC}/${PORTNAME}.1
+
+do-install:
+ @${CP} -v ${WRKSRC}/${DISTNAME} ${PREFIX}/bin/${PORTNAME}
+ @${CP} -v ${WRKSRC}/${PORTNAME}.1 ${PREFIX}/man/man1/${PORTNAME}.1
+ @${CHMOD} +x ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/sysutils/zccron/distinfo b/sysutils/zccron/distinfo
new file mode 100644
index 000000000000..d9f73d49a621
--- /dev/null
+++ b/sysutils/zccron/distinfo
@@ -0,0 +1,3 @@
+MD5 (zccron-0.0.0.pl) = ef921509b137f377237e2715ca14bdf4
+SHA256 (zccron-0.0.0.pl) = 4ba1aec97dc55e23b9dd27abde48f73a014d985b26a068101c1d1323522135d5
+SIZE (zccron-0.0.0.pl) = 7322
diff --git a/sysutils/zccron/pkg-descr b/sysutils/zccron/pkg-descr
new file mode 100644
index 000000000000..33f76b3a9e6a
--- /dev/null
+++ b/sysutils/zccron/pkg-descr
@@ -0,0 +1,13 @@
+This is like comiccron, but stores the tabs in ZConf. For it to run the
+command, the last or next time it will be will have to be within a minute
+and 15 seconds. For most usages, you will want to have the hour and minute
+set to *. This allows a user to do something how ever many times they want
+any time during the period it is active.
+
+After running through every entry in the crontab, it then exits.
+
+Why not cron?
+
+You can have cron open opera or the like on a specific display by either
+switch or enviromental options, but it will always open it. This allows
+you to open it any time along the point it is active.