aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorColin Percival <cperciva@FreeBSD.org>2013-11-04 08:57:06 +0000
committerColin Percival <cperciva@FreeBSD.org>2013-11-04 08:57:06 +0000
commit604b1dfaa8301c78d5b308b05d4df57463745d80 (patch)
tree1ed71681cb3845321b411401d605266ec54533de /sysutils
parentf027257d68fb6c9b6fb5faab7248172e59b59c28 (diff)
When rebooting after a panic, send an encrypted email containing basic
dump metadata along with a kernel backtrace, in order to assist FreeBSD developers in identifying and fixing common panics. Discussed on: freebsd-hackers
Notes
Notes: svn path=/head/; revision=332673
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/panicmail/Makefile25
-rw-r--r--sysutils/panicmail/distinfo2
-rw-r--r--sysutils/panicmail/pkg-descr3
-rw-r--r--sysutils/panicmail/pkg-message9
5 files changed, 40 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 57ac210869c3..efc988b8481d 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -644,6 +644,7 @@
SUBDIR += pacman
SUBDIR += paicc
SUBDIR += pam_mount
+ SUBDIR += panicmail
SUBDIR += parallel
SUBDIR += password-store
SUBDIR += patchelf
diff --git a/sysutils/panicmail/Makefile b/sysutils/panicmail/Makefile
new file mode 100644
index 000000000000..2f61c9346a22
--- /dev/null
+++ b/sysutils/panicmail/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= panicmail
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= http://www.daemonology.net/panicmail/
+
+MAINTAINER= cperciva@FreeBSD.org
+COMMENT= Automatically report kernel panics
+
+LICENSE= BSD
+
+RUN_DEPENDS= pkesh:${PORTSDIR}/security/pkesh
+
+NO_BUILD= yes
+NO_INSTALL= yes
+
+PLIST_FILES= etc/rc.d/panicmail \
+ etc/cperciva-panicmail.pem
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/panicmail ${STAGEDIR}${PREFIX}/etc/rc.d/
+ ${INSTALL_DATA} ${WRKSRC}/cperciva-panicmail.pem ${STAGEDIR}${PREFIX}/etc
+
+.include <bsd.port.mk>
diff --git a/sysutils/panicmail/distinfo b/sysutils/panicmail/distinfo
new file mode 100644
index 000000000000..b9ff0d10629b
--- /dev/null
+++ b/sysutils/panicmail/distinfo
@@ -0,0 +1,2 @@
+SHA256 (panicmail-1.0.tar.gz) = 3b27995cdb72c211a7b7061335b6f0933e1cbc6546d1aa0d48c9bd87bd845541
+SIZE (panicmail-1.0.tar.gz) = 2934
diff --git a/sysutils/panicmail/pkg-descr b/sysutils/panicmail/pkg-descr
new file mode 100644
index 000000000000..e70764a96cb4
--- /dev/null
+++ b/sysutils/panicmail/pkg-descr
@@ -0,0 +1,3 @@
+When rebooting after a panic, send an encrypted email containing basic
+dump metadata along with a kernel backtrace, in order to assist FreeBSD
+developers in identifying and fixing common panics.
diff --git a/sysutils/panicmail/pkg-message b/sysutils/panicmail/pkg-message
new file mode 100644
index 000000000000..b9c4731bd060
--- /dev/null
+++ b/sysutils/panicmail/pkg-message
@@ -0,0 +1,9 @@
+To enable sending of panic reports, add
+ panicmail_enable="YES"
+to your /etc/rc.conf.
+
+By default panic reports will be sent to root with instructions to forward
+them if they do not contain any sensitive information. To automatically
+submit panic reports directly, add
+ panicmail_autosubmit="YES"
+to your /etc/rc.conf in addition.