aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-08-16 12:13:45 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-08-16 12:13:45 +0000
commit84af058d2679ae0780d6a08910f66f99f5df2886 (patch)
tree32be9ed2cded70977d58687f4d620ad64e9961dc /sysutils
parent66b938e43ca01bfd8c26d181c54eef2990a5b18a (diff)
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/ddrescue/Makefile37
-rw-r--r--sysutils/ddrescue/distinfo3
-rw-r--r--sysutils/ddrescue/pkg-descr21
4 files changed, 62 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 8f768a9acaf9..82c29c2c77aa 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -115,6 +115,7 @@
SUBDIR += dc42wrap
SUBDIR += dcfldd
SUBDIR += dd_rescue
+ SUBDIR += ddrescue
SUBDIR += deleted
SUBDIR += deltup
SUBDIR += desktopbsd-tools
diff --git a/sysutils/ddrescue/Makefile b/sysutils/ddrescue/Makefile
new file mode 100644
index 000000000000..5e3365263e7e
--- /dev/null
+++ b/sysutils/ddrescue/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: ddrescue
+# Date created: 16 August 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ddrescue
+DISTVERSION= 1.5
+CATEGORIES= sysutils
+MASTER_SITES= GNU
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Data recovery tool
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS}"\
+ CXXFLAGS="${CXXFLAGS}"
+USE_BZIP2= yes
+PLIST_FILES= bin/${PORTNAME}
+MAN1= ${PORTNAME}.1
+INFO= ${PORTNAME}
+PORTDOCS= AUTHORS ChangeLog NEWS README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|LONG_LONG|LLONG|' ${WRKSRC}/main.cc
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ @${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1 ${MAN1PREFIX}/man/man1/
+ @${INSTALL_DATA} ${WRKSRC}/doc/${PORTNAME}.info ${PREFIX}/${INFO_PATH}/
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ @cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/ddrescue/distinfo b/sysutils/ddrescue/distinfo
new file mode 100644
index 000000000000..8890ffa191e5
--- /dev/null
+++ b/sysutils/ddrescue/distinfo
@@ -0,0 +1,3 @@
+MD5 (ddrescue-1.5.tar.bz2) = 91931e2b2163c8d7a5adc1959da3023f
+SHA256 (ddrescue-1.5.tar.bz2) = d334b5edc52962bdfed3ff155631c5658feae12f8f77814498264269a58c93b8
+SIZE (ddrescue-1.5.tar.bz2) = 34086
diff --git a/sysutils/ddrescue/pkg-descr b/sysutils/ddrescue/pkg-descr
new file mode 100644
index 000000000000..0480cebe0b48
--- /dev/null
+++ b/sysutils/ddrescue/pkg-descr
@@ -0,0 +1,21 @@
+GNU ddrescue is a data recovery tool. It copies data from one file or
+block device (hard disc, cdrom, etc) to another, trying hard to rescue
+data in case of read errors. Ddrescue does not truncate the output file
+if not asked to. So, every time you run it on the same output file, it
+tries to fill in the gaps. The basic operation of ddrescue is fully
+automatic. That is, you don't have to wait for an error, stop the
+program, read the log, run it in reverse mode, etc. If you use the
+logfile feature of ddrescue, the data is rescued very efficiently (only
+the needed blocks are read). Also you can interrupt the rescue at any
+time and resume it later at the same point.
+
+Automatic merging of backups: If you have two or more damaged copies of
+a file, cdrom, etc, and run ddrescue on all of them, one at a time,
+with the same output file, you will probably obtain a complete and
+error-free file. This is so because the probability of having damaged
+areas at the same places on different input files is very low. Using
+the logfile, only the needed blocks are read from the second and
+successive copies.
+
+WWW: http://www.gnu.org/software/ddrescue/ddrescue.html
+Author: Antonio Diaz Diaz <ant_diaz@teleline.es>