aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-12-11 22:17:49 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-12-11 22:17:49 +0000
commitae037399df85fef0e4ff388dcf3e039be44ca168 (patch)
tree0bf32f35ca8908dcc438923135c731525cab3897 /sysutils
parent7c5c62948d2c19ee42f8ef343aa85de5553597ce (diff)
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/ansible/Makefile47
-rw-r--r--sysutils/ansible/distinfo6
-rw-r--r--sysutils/ansible/files/ansible.desktop10
3 files changed, 20 insertions, 43 deletions
diff --git a/sysutils/ansible/Makefile b/sysutils/ansible/Makefile
index c79206635ac3..7f4e990a244e 100644
--- a/sysutils/ansible/Makefile
+++ b/sysutils/ansible/Makefile
@@ -2,39 +2,30 @@
# $FreeBSD$
PORTNAME= ansible
-PORTVERSION= 1.7.2
+PORTVERSION= 1.8.2
CATEGORIES= sysutils python
-MASTER_SITES= SF/lifanov-ports-distfiles/sysutils/${PORTNAME}/:icons
-DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
- ${PORTNAME}.png:icons
-EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
MAINTAINER= lifanov@mail.lifanov.com
-COMMENT= Simple ssh-based configuration management and orchestration system
+COMMENT= Radically simple IT automation
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml \
+ ${PYTHON_PKGNAMEPREFIX}pycrypto>0:${PORTSDIR}/security/py-pycrypto \
${PYTHON_PKGNAMEPREFIX}paramiko>0:${PORTSDIR}/security/py-paramiko \
${PYTHON_PKGNAMEPREFIX}Jinja2>0:${PORTSDIR}/devel/py-Jinja2
-OPTIONS_DEFINE= ACCELERATE EXAMPLES
-OPTIONS_DEFAULT= ACCELERATE
-
-ACCELERATE_DESC= Enable Accelerated Mode (Uses pycrypto and keyczar)
-ACCELERATE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>0:${PORTSDIR}/security/py-pycrypto \
- ${PYTHON_PKGNAMEPREFIX}keyczar>0:${PORTSDIR}/security/py-keyczar
+OPTIONS_DEFINE= EXAMPLES
USE_GITHUB= yes
GH_ACCOUNT= ${PORTNAME}
-GH_PROJECT= ${PORTNAME}
GH_TAGNAME= ${GH_COMMIT}
-GH_COMMIT= d3c28fe
+GH_COMMIT= 6f568bd
USES= cpe python:2 shebangfix
USE_PYTHON= autoplist distutils
-SHEBANG_FILES= library/*/* \
- lib/ansible/runner/action_plugins/synchronize.py
+SHEBANG_FILES= lib/ansible/runner/action_plugins/synchronize.py
CPE_VENDOR= ansibleworks
SUB_FILES= pkg-message
@@ -44,24 +35,26 @@ PLIST_FILES+= man/man1/ansible-doc.1.gz \
man/man1/ansible-playbook.1.gz \
man/man1/ansible-pull.1.gz \
man/man1/ansible-vault.1.gz \
- man/man1/ansible.1.gz \
- ${DESKTOPDIR:S,^${PREFIX}/,,}/${PORTNAME}.desktop \
- share/pixmaps/${PORTNAME}.png
+ man/man1/ansible.1.gz
PORTEXAMPLES= ansible.cfg hosts
post-patch:
-.for f in bin/ansible-galaxy docs/man/man1/ansible-playbook.1 \
- docs/man/man1/ansible.1 examples/ansible.cfg \
- examples/hosts lib/ansible/constants.py \
- lib/ansible/playbook/__init__.py lib/ansible/runner/__init__.py \
- library/system/setup
+.for f in bin/ansible-galaxy docs/man/man1/ansible-galaxy.1 \
+ docs/man/man1/ansible-playbook.1 docs/man/man1/ansible.1 \
+ examples/ansible.cfg examples/hosts lib/ansible/constants.py \
+ lib/ansible/module_utils/urls.py lib/ansible/playbook/__init__.py \
+ lib/ansible/runner/__init__.py plugins/README.md \
+ plugins/inventory/cobbler.py plugins/inventory/collins.py \
+ plugins/inventory/nova.py plugins/inventory/spacewalk.py \
+ v2/ansible/constants.py v2/ansible/playbook/role/definition.py
@${REINPLACE_CMD} -e 's|/etc/ansible|${ETCDIR}|' ${WRKSRC}/${f}
.endfor
.for f in docs/man/man1/ansible-playbook.1 docs/man/man1/ansible.1 \
examples/ansible.cfg lib/ansible/constants.py \
- lib/ansible/playbook/__init__.py lib/ansible/runner/__init__.py
+ lib/ansible/playbook/__init__.py lib/ansible/runner/__init__.py \
+ v2/ansible/constants.py
@${REINPLACE_CMD} -e 's|/usr/share/ansible|${DATADIR}|' ${WRKSRC}/${f}
.endfor
@@ -72,9 +65,5 @@ post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/ansible.cfg ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/hosts ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
- ${STAGEDIR}${PREFIX}/share/pixmaps/
- ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.desktop \
- ${STAGEDIR}${DESKTOPDIR}
.include <bsd.port.mk>
diff --git a/sysutils/ansible/distinfo b/sysutils/ansible/distinfo
index 3526f5fff9c3..ae764f3f53f8 100644
--- a/sysutils/ansible/distinfo
+++ b/sysutils/ansible/distinfo
@@ -1,4 +1,2 @@
-SHA256 (ansible-1.7.2.tar.gz) = e27afa6074cf5c4451d0ae2002413d6328357daa0b5c678490d56b45a4ba2179
-SIZE (ansible-1.7.2.tar.gz) = 1267016
-SHA256 (ansible.png) = 9bf68abd2c95db4dc8dfc091c0e0e0a9716891f28d157e3f04e541d96e1c6850
-SIZE (ansible.png) = 1160
+SHA256 (ansible-1.8.2.tar.gz) = 629d88f44e60b1a581a6164762447635121d4dd272bf2fd0a55f681895daa5b1
+SIZE (ansible-1.8.2.tar.gz) = 934386
diff --git a/sysutils/ansible/files/ansible.desktop b/sysutils/ansible/files/ansible.desktop
deleted file mode 100644
index a0d9816dd2fe..000000000000
--- a/sysutils/ansible/files/ansible.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Type=Application
-Version=1.0
-Name=ansible
-GenericName=ansible
-Comment=Simple ssh-based configuration management and orchestration system
-Icon=ansible
-Exec=ansible
-Categories=System;ConsoleOnly;
-Terminal=true