aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-07-24 15:15:41 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-07-24 15:15:41 +0000
commit000836e31f27fcd63ed1b76c153a2d3006ba545c (patch)
tree44d675e9c6786308117bac93ab3233627276b05e /sysutils
parent3ed93d2cde99971f42241c5002b3965f05dd5989 (diff)
downloadports-000836e31f27fcd63ed1b76c153a2d3006ba545c.tar.gz
ports-000836e31f27fcd63ed1b76c153a2d3006ba545c.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/tartarus/Makefile19
-rw-r--r--sysutils/tartarus/files/patch-bin__tartarus9
-rw-r--r--sysutils/tartarus/pkg-descr2
3 files changed, 20 insertions, 10 deletions
diff --git a/sysutils/tartarus/Makefile b/sysutils/tartarus/Makefile
index 0136a2700dbd..71bef50a4139 100644
--- a/sysutils/tartarus/Makefile
+++ b/sysutils/tartarus/Makefile
@@ -3,29 +3,30 @@
PORTNAME= tartarus
PORTVERSION= 0.9.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= http://wertarbyte.de/tartarus/ \
- http://ftp.wilbury.sk/pub/FreeBSD/local/distfiles/
+ http://ftp.wilbury.sk/pub/FreeBSD/local/distfiles/
MAINTAINER= otis@sk.FreeBSD.org
-COMMENT= Wrappers around common unix tools for simplified backup solution
+COMMENT= Wrappers around common Unix tools for simplified backup solution
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash \
- ${LOCALBASE}/bin/gtar:${PORTSDIR}/archivers/gtar \
- ${LOCALBASE}/bin/curl:${PORTSDIR}/ftp/curl
+ ${LOCALBASE}/bin/gtar:${PORTSDIR}/archivers/gtar \
+ ${LOCALBASE}/bin/curl:${PORTSDIR}/ftp/curl
USES= gmake perl5 shebangfix tar:bzip2
SHEBANG_FILES= ${WRKSRC}/bin/*
do-install:
- cd ${WRKSRC}/bin; ${INSTALL_SCRIPT} charon charon.ftp charon.local \
+ cd ${WRKSRC}/bin && ${INSTALL_SCRIPT} charon charon.ftp charon.local \
charon.pipe orpheus tartarus ${STAGEDIR}${PREFIX}/bin
- cd ${WRKSRC}/lib; ${COPYTREE_SHARE} Tartarus ${STAGEDIR}${SITE_PERL}
- cd ${WRKSRC}/man; ${INSTALL_MAN} charon.1 charon.ftp.1 charon.local.1 \
- charon.pipe.1 tartarus.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ cd ${WRKSRC}/lib && ${COPYTREE_SHARE} Tartarus ${STAGEDIR}${SITE_PERL}
+ cd ${WRKSRC}/man && ${INSTALL_MAN} charon.ftp.1 charon.local.1 \
+ charon.pipe.1 tartarus.1 ${STAGEDIR}${PREFIX}/man/man1
+ ${LN} -sf charon.ftp.1 ${STAGEDIR}${PREFIX}/man/man1/charon.1
.include <bsd.port.mk>
diff --git a/sysutils/tartarus/files/patch-bin__tartarus b/sysutils/tartarus/files/patch-bin__tartarus
index a8098b86ef60..0b0a44b39c2a 100644
--- a/sysutils/tartarus/files/patch-bin__tartarus
+++ b/sysutils/tartarus/files/patch-bin__tartarus
@@ -56,6 +56,15 @@
#=back
#
#=cut
+@@ -616,7 +649,7 @@
+ constructFilename() {
+ local INC=""
+ if isEnabled "$INCREMENTAL_BACKUP"; then
+- local BASEDON=$(date -r "$INCREMENTAL_TIMESTAMP_FILE" '+%Y%m%d-%H%M')
++ local BASEDON=$(stat -f '%Sm' -t '%Y%m%d-%H%M' "$INCREMENTAL_TIMESTAMP_FILE")
+ INC="-inc-${BASEDON}"
+ fi
+ local CHUNK=""
@@ -638,10 +671,10 @@
case "$ASSEMBLY_METHOD" in
tar|"")
diff --git a/sysutils/tartarus/pkg-descr b/sysutils/tartarus/pkg-descr
index a3862f8aeba5..fe19082a9ac4 100644
--- a/sysutils/tartarus/pkg-descr
+++ b/sysutils/tartarus/pkg-descr
@@ -6,7 +6,7 @@ It has the ability to do full as well as incremental backups and is published
by Stefan Tomanek under the rules of the GPL.
Instead of relying on single usage backup scripts or complicated command lines,
-tartarus reads its configuration from easily managable configuration files.
+tartarus reads its configuration from easily manageable configuration files.
It can store gathered data in regular files, or upload the backup directly (on
the fly) to an FTP server. For more specific usage scenarios, custom methods
can also be defined within the config file.