aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorSerhii (Sergey) Kozlov <skozlov@FreeBSD.org>2020-06-29 22:06:57 +0000
committerSerhii (Sergey) Kozlov <skozlov@FreeBSD.org>2020-06-29 22:06:57 +0000
commit0157b050b1696113e2849ffdd6eecd42741c2278 (patch)
tree1aade0a756346afa8b1a1730927e2c1b2c9cfd82 /sysutils
parentab98b57492e7d2420c6d6e1f78656d8e038d833f (diff)
downloadports-0157b050b1696113e2849ffdd6eecd42741c2278.tar.gz
ports-0157b050b1696113e2849ffdd6eecd42741c2278.zip
New port: sysutils/fusefs-securefs
securefs is a filesystem in userspace (FUSE) with transparent encryption (when writing) and decryption (when reading). securefs mounts a regular directory onto a mount point. The mount point appears as a regular filesystem, where one can read/write/create files, directories and symbolic links. The underlying directory will be automatically updated to contain the encrypted and authenticated contents. WWW: https://github.com/netheril96/securefs
Notes
Notes: svn path=/head/; revision=540836
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/fusefs-securefs/Makefile27
-rw-r--r--sysutils/fusefs-securefs/distinfo3
-rw-r--r--sysutils/fusefs-securefs/files/patch-CMakeLists.txt12
-rw-r--r--sysutils/fusefs-securefs/files/patch-sources_commands.cpp11
-rw-r--r--sysutils/fusefs-securefs/files/patch-sources_mystring.cpp11
-rw-r--r--sysutils/fusefs-securefs/pkg-descr6
7 files changed, 71 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 23da7115d2a1..58a815926322 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -390,6 +390,7 @@
SUBDIR += fusefs-s3backer
SUBDIR += fusefs-s3fs
SUBDIR += fusefs-sandboxfs
+ SUBDIR += fusefs-securefs
SUBDIR += fusefs-simple-mtpfs
SUBDIR += fusefs-smbnetfs
SUBDIR += fusefs-sqlfs
diff --git a/sysutils/fusefs-securefs/Makefile b/sysutils/fusefs-securefs/Makefile
new file mode 100644
index 000000000000..f6af8f0fb82a
--- /dev/null
+++ b/sysutils/fusefs-securefs/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= securefs
+PORTVERSION= 0.11.1
+CATEGORIES= sysutils
+PKGNAMEPREFIX= fusefs-
+
+MAINTAINER= skozlov@FreeBSD.org
+COMMENT= Filesystem in userspace with transparent encryption and decryption
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+LIB_DEPENDS= libutf8proc.so:textproc/utf8proc \
+ libjsoncpp.so:devel/jsoncpp
+
+USES= cmake fuse
+LDFLAGS+= -L${LOCALBASE}/lib -lutf8proc -ljsoncpp
+USE_GITHUB= yes
+GH_ACCOUNT= netheril96
+PLIST_FILES= bin/securefs
+
+post-patch:
+ ${REINPLACE_CMD} "s|@GIT_VERSION@|${PORTVERSION}|" ${WRKSRC}/sources/git-version.cpp.in
+ ${MV} ${WRKSRC}/sources/git-version.cpp.in ${WRKSRC}/sources/git-version.cpp
+
+.include <bsd.port.mk>
diff --git a/sysutils/fusefs-securefs/distinfo b/sysutils/fusefs-securefs/distinfo
new file mode 100644
index 000000000000..6583797598c3
--- /dev/null
+++ b/sysutils/fusefs-securefs/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1593453049
+SHA256 (netheril96-securefs-0.11.1_GH0.tar.gz) = 32624fc5ebb78e6cb2f9780c92b1196ba87eb8ce224631957574ee2c8df7e435
+SIZE (netheril96-securefs-0.11.1_GH0.tar.gz) = 1846447
diff --git a/sysutils/fusefs-securefs/files/patch-CMakeLists.txt b/sysutils/fusefs-securefs/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..97e96e66fb6b
--- /dev/null
+++ b/sysutils/fusefs-securefs/files/patch-CMakeLists.txt
@@ -0,0 +1,12 @@
+--- CMakeLists.txt.orig 2020-06-29 19:00:51 UTC
++++ CMakeLists.txt
+@@ -13,9 +13,6 @@ execute_process (
+ )
+
+ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake-modules/")
+-include(GetGitRevisionDescription)
+-git_describe(GIT_VERSION --tags)
+-configure_file(${CMAKE_SOURCE_DIR}/sources/git-version.cpp.in ${CMAKE_BINARY_DIR}/git-version.cpp)
+
+ if (UNIX)
+ find_path(FUSE_INCLUDE_DIR fuse.h PATHS /usr/local/include PATH_SUFFIXES osxfuse)
diff --git a/sysutils/fusefs-securefs/files/patch-sources_commands.cpp b/sysutils/fusefs-securefs/files/patch-sources_commands.cpp
new file mode 100644
index 000000000000..3087ecb9053b
--- /dev/null
+++ b/sysutils/fusefs-securefs/files/patch-sources_commands.cpp
@@ -0,0 +1,11 @@
+--- sources/commands.cpp.orig 2020-06-29 17:57:42 UTC
++++ sources/commands.cpp
+@@ -14,7 +14,7 @@
+ #include <fuse.h>
+ #include <json/json.h>
+ #include <tclap/CmdLine.h>
+-#include <utf8proc/utf8proc.h>
++#include <utf8proc.h>
+
+ #include <algorithm>
+ #include <memory>
diff --git a/sysutils/fusefs-securefs/files/patch-sources_mystring.cpp b/sysutils/fusefs-securefs/files/patch-sources_mystring.cpp
new file mode 100644
index 000000000000..a14bff7cc43d
--- /dev/null
+++ b/sysutils/fusefs-securefs/files/patch-sources_mystring.cpp
@@ -0,0 +1,11 @@
+--- sources/mystring.cpp.orig 2020-06-29 17:57:55 UTC
++++ sources/mystring.cpp
+@@ -3,7 +3,7 @@
+ #include "logger.h"
+ #include "myutils.h"
+
+-#include <utf8proc/utf8proc.h>
++#include <utf8proc.h>
+
+ #include <ctype.h>
+ #include <errno.h>
diff --git a/sysutils/fusefs-securefs/pkg-descr b/sysutils/fusefs-securefs/pkg-descr
new file mode 100644
index 000000000000..517bcc6ae1cf
--- /dev/null
+++ b/sysutils/fusefs-securefs/pkg-descr
@@ -0,0 +1,6 @@
+securefs mounts a regular directory onto a mount point. The mount point appears
+as a regular filesystem, where one can read/write/create files, directories and
+symbolic links. The underlying directory will be automatically updated to
+contain the encrypted and authenticated contents.
+
+WWW: https://github.com/netheril96/securefs