aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2012-02-01 18:46:36 +0000
committerXin LI <delphij@FreeBSD.org>2012-02-01 18:46:36 +0000
commit03dda0ef51e4ceba1a9672885e2084e4d31881a5 (patch)
treebd787a2231304546dfb64d8c53c88a606d6af7d9 /sysutils
parent66028a1da935ef29a39e015f08fb46e2cecfdd16 (diff)
downloadports-03dda0ef51e4ceba1a9672885e2084e4d31881a5.tar.gz
ports-03dda0ef51e4ceba1a9672885e2084e4d31881a5.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/smp_utils/Makefile58
-rw-r--r--sysutils/smp_utils/distinfo2
-rw-r--r--sysutils/smp_utils/pkg-descr7
-rw-r--r--sysutils/smp_utils/pkg-plist35
5 files changed, 103 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 5924ab5ae9de..e3cb951bbf7c 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -822,6 +822,7 @@
SUBDIR += sloth
SUBDIR += slst
SUBDIR += smartmontools
+ SUBDIR += smp_utils
SUBDIR += snap
SUBDIR += snowlog
SUBDIR += socket
diff --git a/sysutils/smp_utils/Makefile b/sysutils/smp_utils/Makefile
new file mode 100644
index 000000000000..84cff38961cc
--- /dev/null
+++ b/sysutils/smp_utils/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: smp_utils
+# Date created: Feb 1, 2012
+# Whom: Xin LI <delphij@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= smp_utils
+PORTVERSION= 0.97
+CATEGORIES= sysutils
+MASTER_SITES= http://sg.danny.cz/sg/p/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= delphij@FreeBSD.org
+COMMENT= Utilities to send SAS Serial Management Protocol requests
+
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+MAN8= smp_conf_general.8
+MAN8+= smp_conf_phy_event.8
+MAN8+= smp_conf_route_info.8
+MAN8+= smp_conf_zone_man_pass.8
+MAN8+= smp_conf_zone_perm_tbl.8
+MAN8+= smp_conf_zone_phy_info.8
+MAN8+= smp_discover.8
+MAN8+= smp_discover_list.8
+MAN8+= smp_ena_dis_zoning.8
+MAN8+= smp_phy_control.8
+MAN8+= smp_phy_test.8
+MAN8+= smp_read_gpio.8
+MAN8+= smp_rep_broadcast.8
+MAN8+= smp_rep_exp_route_tbl.8
+MAN8+= smp_rep_general.8
+MAN8+= smp_rep_manufacturer.8
+MAN8+= smp_rep_phy_err_log.8
+MAN8+= smp_rep_phy_event.8
+MAN8+= smp_rep_phy_event_list.8
+MAN8+= smp_rep_phy_sata.8
+MAN8+= smp_rep_route_info.8
+MAN8+= smp_rep_self_conf_stat.8
+MAN8+= smp_rep_zone_man_pass.8
+MAN8+= smp_rep_zone_perm_tbl.8
+MAN8+= smp_utils.8
+MAN8+= smp_write_gpio.8
+MAN8+= smp_zone_activate.8
+MAN8+= smp_zoned_broadcast.8
+MAN8+= smp_zone_lock.8
+MAN8+= smp_zone_unlock.8
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 900000
+IGNORE= requires FreeBSD 9.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/smp_utils/distinfo b/sysutils/smp_utils/distinfo
new file mode 100644
index 000000000000..9229b499841b
--- /dev/null
+++ b/sysutils/smp_utils/distinfo
@@ -0,0 +1,2 @@
+SHA256 (smp_utils-0.97.tgz) = 0e10d304cfa8789bcf16537e8f72d9afdf8838fca20ae68103c317432d00915b
+SIZE (smp_utils-0.97.tgz) = 473489
diff --git a/sysutils/smp_utils/pkg-descr b/sysutils/smp_utils/pkg-descr
new file mode 100644
index 000000000000..20cb0fa77c46
--- /dev/null
+++ b/sysutils/smp_utils/pkg-descr
@@ -0,0 +1,7 @@
+This is a package of utilities. Each utility sends a Serial Attached
+SCSI (SAS) Serial Management Protocol (SMP) request to an SMP target.
+If the request fails then the error is decoded. If the request succeeds
+then the response is either decoded, printed out in hexadecimal or
+output in binary.
+
+WWW: http://sg.danny.cz/sg/smp_utils.html
diff --git a/sysutils/smp_utils/pkg-plist b/sysutils/smp_utils/pkg-plist
new file mode 100644
index 000000000000..e60b170c38ae
--- /dev/null
+++ b/sysutils/smp_utils/pkg-plist
@@ -0,0 +1,35 @@
+include/scsi/smp_lib.h
+lib/libsmputils1.so.1
+lib/libsmputils1.so
+lib/libsmputils1.la
+lib/libsmputils1.a
+sbin/smp_conf_general
+sbin/smp_conf_phy_event
+sbin/smp_conf_route_info
+sbin/smp_conf_zone_man_pass
+sbin/smp_conf_zone_perm_tbl
+sbin/smp_conf_zone_phy_info
+sbin/smp_discover
+sbin/smp_discover_list
+sbin/smp_ena_dis_zoning
+sbin/smp_phy_control
+sbin/smp_phy_test
+sbin/smp_read_gpio
+sbin/smp_rep_broadcast
+sbin/smp_rep_exp_route_tbl
+sbin/smp_rep_general
+sbin/smp_rep_manufacturer
+sbin/smp_rep_phy_err_log
+sbin/smp_rep_phy_event
+sbin/smp_rep_phy_event_list
+sbin/smp_rep_phy_sata
+sbin/smp_rep_route_info
+sbin/smp_rep_self_conf_stat
+sbin/smp_rep_zone_man_pass
+sbin/smp_rep_zone_perm_tbl
+sbin/smp_write_gpio
+sbin/smp_zone_activate
+sbin/smp_zoned_broadcast
+sbin/smp_zone_lock
+sbin/smp_zone_unlock
+@dirrmtry include/scsi