aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorAlexander Botero-Lowry <alexbl@FreeBSD.org>2006-11-30 04:56:43 +0000
committerAlexander Botero-Lowry <alexbl@FreeBSD.org>2006-11-30 04:56:43 +0000
commit1ff6a80ea43d833f2e5ea8f94f89c9f58c21ad1f (patch)
tree8f9374992eb7a2554e8e98385fed674ad7867c99 /sysutils
parent01f1c535cb97cb24d849d99b862d7502322d6025 (diff)
downloadports-1ff6a80ea43d833f2e5ea8f94f89c9f58c21ad1f.tar.gz
ports-1ff6a80ea43d833f2e5ea8f94f89c9f58c21ad1f.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/farbot/Makefile33
-rw-r--r--sysutils/farbot/distinfo3
-rw-r--r--sysutils/farbot/pkg-descr15
-rw-r--r--sysutils/farbot/pkg-plist35
5 files changed, 87 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index a7bc5b7af924..d80ccc701014 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -167,6 +167,7 @@
SUBDIR += extrackt
SUBDIR += ezjail
SUBDIR += fanout
+ SUBDIR += farbot
SUBDIR += fastest_cvsup
SUBDIR += fatback
SUBDIR += fcron
diff --git a/sysutils/farbot/Makefile b/sysutils/farbot/Makefile
new file mode 100644
index 000000000000..b58090448685
--- /dev/null
+++ b/sysutils/farbot/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: farbot
+# Date created: 29 November 2006
+# Whom: Nick Barkas <snb@threerings.net>
+#
+# $FreeBSD$
+
+PORTNAME= farbot
+PORTVERSION= 1.0.a2
+CATEGORIES= sysutils
+MASTER_SITES= http://dpw.threerings.net/projects/farbot/
+DISTNAME= farbot-1.0-alpha2
+
+MAINTAINER= snb@threerings.net
+COMMENT= FreeBSD Automated Release Bot
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/ZConfig:${PORTSDIR}/devel/py-zconfig \
+ ${PYTHON_SITELIBDIR}/twisted:${PORTSDIR}/devel/py-twistedCore
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= yes
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/farbot.conf ${PREFIX}/etc/farbot.conf.sample
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/xhtml
+ ${INSTALL_MAN} ${WRKSRC}/docs/xhtml/* ${DOCSDIR}/xhtml
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/farbot/distinfo b/sysutils/farbot/distinfo
new file mode 100644
index 000000000000..9d352652dda0
--- /dev/null
+++ b/sysutils/farbot/distinfo
@@ -0,0 +1,3 @@
+MD5 (farbot-1.0-alpha2.tar.gz) = f01daa8e5d8549866171afbed2239ac5
+SHA256 (farbot-1.0-alpha2.tar.gz) = 48237c1d60dc8293f034ed5f318e8a3328c92ca1de01af2ed7069494f35ad3f1
+SIZE (farbot-1.0-alpha2.tar.gz) = 90142
diff --git a/sysutils/farbot/pkg-descr b/sysutils/farbot/pkg-descr
new file mode 100644
index 000000000000..a0a4da64b4e2
--- /dev/null
+++ b/sysutils/farbot/pkg-descr
@@ -0,0 +1,15 @@
+Farbot automates building of netinstall/PXE boot FreeBSD releases. It features a
+simple configuration file based on the concept of "Installations",
+"PackageSets", and "PartitionMaps."
+
+Farbot currently handles the following:
+
+* Building FreeBSD releases, including grabbing any source needed.
+* Building packages for each release, derived from per installation package
+ sets.
+* Laying out an NFS/TFTP exportable file system structure for all built
+ releases, customized for each installation type.
+* Generation of a customized bootloader with options to install each
+ installation type
+
+WWW: http://dpw.threerings.net/projects/farbot/
diff --git a/sysutils/farbot/pkg-plist b/sysutils/farbot/pkg-plist
new file mode 100644
index 000000000000..5de5e0c10176
--- /dev/null
+++ b/sysutils/farbot/pkg-plist
@@ -0,0 +1,35 @@
+bin/farbot
+etc/farbot.conf.sample
+%%PYTHON_SITELIBDIR%%/farb/__init__.py
+%%PYTHON_SITELIBDIR%%/farb/builder.py
+%%PYTHON_SITELIBDIR%%/farb/config.py
+%%PYTHON_SITELIBDIR%%/farb/sysinstall.py
+%%PYTHON_SITELIBDIR%%/farb/utils.py
+%%PYTHON_SITELIBDIR%%/farb/data/boot.conf.tmpl
+%%PYTHON_SITELIBDIR%%/farb/data/farb_conf.xml
+%%PYTHON_SITELIBDIR%%/farb/data/install_package.sh
+%%PYTHON_SITELIBDIR%%/farb/data/loader.conf
+%%PYTHON_SITELIBDIR%%/farb/data/loader.rc
+%%PYTHON_SITELIBDIR%%/farb/data/netinstall.4th.tmpl
+%%PYTHON_SITELIBDIR%%/farb/__init__.pyc
+%%PYTHON_SITELIBDIR%%/farb/builder.pyc
+%%PYTHON_SITELIBDIR%%/farb/config.pyc
+%%PYTHON_SITELIBDIR%%/farb/sysinstall.pyc
+%%PYTHON_SITELIBDIR%%/farb/utils.pyc
+%%PYTHON_SITELIBDIR%%/farb/__init__.pyo
+%%PYTHON_SITELIBDIR%%/farb/builder.pyo
+%%PYTHON_SITELIBDIR%%/farb/config.pyo
+%%PYTHON_SITELIBDIR%%/farb/sysinstall.pyo
+%%PYTHON_SITELIBDIR%%/farb/utils.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/farb/data
+@dirrm %%PYTHON_SITELIBDIR%%/farb
+%%PORTDOCS%%%%DOCSDIR%%/xhtml/ch01.html
+%%PORTDOCS%%%%DOCSDIR%%/xhtml/ch01s02.html
+%%PORTDOCS%%%%DOCSDIR%%/xhtml/ch01s03.html
+%%PORTDOCS%%%%DOCSDIR%%/xhtml/ch01s04.html
+%%PORTDOCS%%%%DOCSDIR%%/xhtml/ch02.html
+%%PORTDOCS%%%%DOCSDIR%%/xhtml/docbook.css
+%%PORTDOCS%%%%DOCSDIR%%/xhtml/index.html
+%%PORTDOCS%%%%DOCSDIR%%/xhtml/pr01.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/xhtml
+%%PORTDOCS%%@dirrm %%DOCSDIR%%