aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-04-07 18:34:44 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-04-07 18:34:44 +0000
commit2970933003f09a22ee205804c8e4e2b15252e0c4 (patch)
tree903c8629d698f52c1e5ea91b7cbfc942727d8592 /sysutils
parent6b85a0912f3d5e9c94769b5435ef39a473617b60 (diff)
downloadports-2970933003f09a22ee205804c8e4e2b15252e0c4.tar.gz
ports-2970933003f09a22ee205804c8e4e2b15252e0c4.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/uptimec/Makefile12
-rw-r--r--sysutils/uptimec/distinfo4
-rw-r--r--sysutils/uptimec/files/uptimec.sh9
-rw-r--r--sysutils/uptimec/files/uptimecrc.sample1
4 files changed, 14 insertions, 12 deletions
diff --git a/sysutils/uptimec/Makefile b/sysutils/uptimec/Makefile
index 0f81d2823dab..a70fb0182682 100644
--- a/sysutils/uptimec/Makefile
+++ b/sysutils/uptimec/Makefile
@@ -6,24 +6,21 @@
#
PORTNAME= uptimec
-PORTVERSION= 0.1
+PORTVERSION= 0.2
CATEGORIES= sysutils
-MASTER_SITES= http://www.mrEriksson.net/downloads/
+MASTER_SITES= http://www.mrEriksson.net/downloads/ \
+ ftp://ftp.mrEriksson.net/pub/uptimec/
MAINTAINER= hsn@netmag.cz
COMMENT= Client for Uptime Project
GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-USE_AUTOCONF_VER= 257
-USE_REINPLACE= yes
PLIST_FILES= sbin/uptimec etc/uptimecrc.sample etc/rc.d/uptimec.sh
PORTDOCS= README COPYING ChangeLog INSTALL protocol.txt
-post-patch:
- @${REINPLACE_CMD} -e 's|CC =|CC ?=|g' ${WRKSRC}/Makefile
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/uptimec ${PREFIX}/sbin
${INSTALL_DATA} ${MASTERDIR}/files/uptimecrc.sample ${PREFIX}/etc
@@ -37,6 +34,5 @@ do-install:
post-install:
@${SED} -e 's,%%LOCALBASE%%,${LOCALBASE},' ${PKGMESSAGE}
- ${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/sysutils/uptimec/distinfo b/sysutils/uptimec/distinfo
index f403443650a8..ae85e94e2193 100644
--- a/sysutils/uptimec/distinfo
+++ b/sysutils/uptimec/distinfo
@@ -1,2 +1,2 @@
-MD5 (uptimec-0.1.tar.gz) = 7f266a6afbe1c7b50ee335d497e8bd1f
-SIZE (uptimec-0.1.tar.gz) = 44173
+MD5 (uptimec-0.2.tar.gz) = 42289c40bf7dc8e1110bc70ed8d664f7
+SIZE (uptimec-0.2.tar.gz) = 73195
diff --git a/sysutils/uptimec/files/uptimec.sh b/sysutils/uptimec/files/uptimec.sh
index 7554ad97fe35..994e17e4c3c1 100644
--- a/sysutils/uptimec/files/uptimec.sh
+++ b/sysutils/uptimec/files/uptimec.sh
@@ -7,10 +7,11 @@
# REQUIRE: LOGIN
# KEYWORD: FreeBSD shutdown
+# Uptimec is enabled by default, if you have configuration file
#
-# Add the following line to /etc/rc.conf to enable uptimec:
+# Add the following line to /etc/rc.conf to disable uptimec:
#
-#uptimec_enable="YES"
+#uptimec_enable="NO"
#
. /etc/rc.subr
@@ -33,11 +34,15 @@ if [ -z "$uptimec_flags" -a -r $required_files ]; then
hostid=`awk -F '( |\t)*=( |\t)*' '/^HOSTID/ { print $2;exit 0;}' $required_files`
password=`awk -F '( |\t)*=( |\t)*' '/^PASSWORD/ { print $2;exit 0;}' $required_files`
server=`awk -F '( |\t)*=( |\t)*' '/^SERVER/ { print $2;exit 0;}' $required_files`
+ port=`awk -F '( |\t)*=( |\t)*' '/^PORT/ { print $2;exit 0;}' $required_files`
if [ -z "$hostid" -o -z "$password" ]; then
exit 0;
fi
if [ -n "$server" ]; then
uptimec_flags="-s $server"
+ fi
+ if [ -n "$port" ]; then
+ uptimec_flags="$uptimec_flags -P $port"
fi
uptimec_flags="$uptimec_flags -i $hostid -p $password"
else
diff --git a/sysutils/uptimec/files/uptimecrc.sample b/sysutils/uptimec/files/uptimecrc.sample
index d84a00f5ccf4..5c9b675d8944 100644
--- a/sysutils/uptimec/files/uptimecrc.sample
+++ b/sysutils/uptimec/files/uptimecrc.sample
@@ -2,3 +2,4 @@
HOSTID=2345
PASSWORD=blabla
#SERVER=uptimes.mreriksson.net
+#PORT=2050 \ No newline at end of file