aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorIan Lepore <ian@FreeBSD.org>2015-08-09 02:16:54 +0000
committerIan Lepore <ian@FreeBSD.org>2015-08-09 02:16:54 +0000
commit2dd618a75f4e1254a3a627a13405799f113820e2 (patch)
tree896582116e00a4e0e06e834228692ee2c871166f /sysutils
parent35c9f9b47e9fa697babb54d3c9fd87dad8d51171 (diff)
downloadports-2dd618a75f4e1254a3a627a13405799f113820e2.tar.gz
ports-2dd618a75f4e1254a3a627a13405799f113820e2.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/u-boot-cubox-hummingboard/Makefile8
-rw-r--r--sysutils/u-boot-cubox-hummingboard/files/patch-board_solidrun_mx6__cubox-i_mx6__cubox-i.c2
2 files changed, 7 insertions, 3 deletions
diff --git a/sysutils/u-boot-cubox-hummingboard/Makefile b/sysutils/u-boot-cubox-hummingboard/Makefile
index 44d651689cb4..f75d6ef33bae 100644
--- a/sysutils/u-boot-cubox-hummingboard/Makefile
+++ b/sysutils/u-boot-cubox-hummingboard/Makefile
@@ -2,6 +2,7 @@
PORTNAME= u-boot
PORTVERSION= 2013.10
+PORTREVISION= 1
CATEGORIES= sysutils
PKGNAMESUFFIX= -cubox-hummingboard
@@ -10,7 +11,9 @@ COMMENT= Cross-build U-Boot loader for SolidRun Cubox
LICENSE= GPLv2
-BUILD_DEPENDS= arm-none-eabi-gcc:${PORTSDIR}/devel/arm-none-eabi-gcc
+BUILD_DEPENDS= ${CROSS_GCC}:${PORTSDIR}/devel/arm-none-eabi-gcc492
+
+CROSS_GCC= arm-none-eabi-gcc-4.9.2
USE_GITHUB= yes
GH_ACCOUNT= SolidRun
@@ -28,8 +31,9 @@ PLIST_FILES= ${U_BOOT_DIR}/u-boot.imx \
${U_BOOT_DIR}/README
MAKE_ARGS+= ARCH=arm \
+ CC=${CROSS_GCC} \
CROSS_COMPILE=arm-none-eabi- \
- HOSTCC=clang
+ HOSTCC=cc
do-configure:
cd ${WRKSRC}; ${GMAKE} ${MAKE_ARGS} mx6_cubox-i_config
diff --git a/sysutils/u-boot-cubox-hummingboard/files/patch-board_solidrun_mx6__cubox-i_mx6__cubox-i.c b/sysutils/u-boot-cubox-hummingboard/files/patch-board_solidrun_mx6__cubox-i_mx6__cubox-i.c
index 435855c8ad1f..8178f62d8e44 100644
--- a/sysutils/u-boot-cubox-hummingboard/files/patch-board_solidrun_mx6__cubox-i_mx6__cubox-i.c
+++ b/sysutils/u-boot-cubox-hummingboard/files/patch-board_solidrun_mx6__cubox-i_mx6__cubox-i.c
@@ -12,7 +12,7 @@
}
static char const *board_type = "uninitialized";
-+static char const *fdt_board;
++static char const *fdt_board = "uninitialized";
int checkboard(void)
{