aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorWarner Losh <imp@FreeBSD.org>2015-12-17 23:12:56 +0000
committerWarner Losh <imp@FreeBSD.org>2015-12-17 23:12:56 +0000
commit56e11c5daf7d716a230927c17bcc660a8d2abdff (patch)
treee8934ff193dce1fb6ebe2b3b052fa4572a20333f /sysutils
parentf9c8a1a2b196e7c1188266ea86f8ee4ca2ffcad6 (diff)
downloadports-56e11c5daf7d716a230927c17bcc660a8d2abdff.tar.gz
ports-56e11c5daf7d716a230927c17bcc660a8d2abdff.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/intel-pcm/Makefile6
-rw-r--r--sysutils/intel-pcm/distinfo4
-rw-r--r--sysutils/intel-pcm/files/patch-cpucounters.cpp17
-rw-r--r--sysutils/intel-pcm/files/patch-cpucounters.h11
4 files changed, 33 insertions, 5 deletions
diff --git a/sysutils/intel-pcm/Makefile b/sysutils/intel-pcm/Makefile
index 6ba332accaba..c7935597956e 100644
--- a/sysutils/intel-pcm/Makefile
+++ b/sysutils/intel-pcm/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= intel-pcm
-PORTVERSION= 2.8
+PORTVERSION= 2.10
CATEGORIES= sysutils
MASTER_SITES= LOCAL/imp
-DISTNAME= intelperformancecountermonitorv${PORTVERSION}
+DISTNAME= IntelPerformanceCounterMonitor-PCM-V${PORTVERSION}
MAINTAINER= imp@FreeBSD.org
COMMENT= Intel PCM toolkit
@@ -16,7 +16,7 @@ USES= gmake compiler:c++11-lang zip
ONLY_FOR_ARCHS= i386 amd64
-WRKSRC= ${WRKDIR}/IntelPerformanceCounterMonitorV${PORTVERSION}
+WRKSRC= ${WRKDIR}/IntelPerformanceCounterMonitor-PCM-V${PORTVERSION}
MAKE_ARGS= CXX="${CXX}" LIB=-lpthread
do-install:
diff --git a/sysutils/intel-pcm/distinfo b/sysutils/intel-pcm/distinfo
index 0336c2f44999..e8b9f85fb8ca 100644
--- a/sysutils/intel-pcm/distinfo
+++ b/sysutils/intel-pcm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (intelperformancecountermonitorv2.8.zip) = 3c51b2fc7b772f16f746ea6fda0471d280c0f27bfd52fa51dd78433ca5a6ca6a
-SIZE (intelperformancecountermonitorv2.8.zip) = 931374
+SHA256 (IntelPerformanceCounterMonitor-PCM-V2.10.zip) = 46897ab2a8627ad5a58f05b19746b00b4f95126e8abccd9bed978b1f2675fc19
+SIZE (IntelPerformanceCounterMonitor-PCM-V2.10.zip) = 950922
diff --git a/sysutils/intel-pcm/files/patch-cpucounters.cpp b/sysutils/intel-pcm/files/patch-cpucounters.cpp
new file mode 100644
index 000000000000..4e9f4f3e80e2
--- /dev/null
+++ b/sysutils/intel-pcm/files/patch-cpucounters.cpp
@@ -0,0 +1,17 @@
+--- cpucounters.cpp.orig 2015-11-17 01:01:38.000000000 -0700
++++ cpucounters.cpp 2015-12-14 14:46:09.000000000 -0700
+@@ -1365,7 +1365,13 @@
+ cpu_model = ATOM;
+ }
+ if (cpu_model == HASWELL_ULT || cpu_model == HASWELL_2) cpu_model = HASWELL;
+- if (cpu_model == BROADWELL_XEON_E3) cpu_model = BROADWELL;
++
++ if ((cpu_model == BROADWELL_XEON_E3) ||
++ (cpu_model == BROADWELL_XEON_E5) ||
++ (cpu_model == BROADWELL_XEON_E7)) {
++ cpu_model = BROADWELL;
++ }
++
+ if (cpu_model == SKL_UY) cpu_model = SKL;
+
+ if(!isCPUModelSupported((int)cpu_model))
diff --git a/sysutils/intel-pcm/files/patch-cpucounters.h b/sysutils/intel-pcm/files/patch-cpucounters.h
new file mode 100644
index 000000000000..487802e7b5bc
--- /dev/null
+++ b/sysutils/intel-pcm/files/patch-cpucounters.h
@@ -0,0 +1,11 @@
+--- cpucounters.h.orig 2015-11-17 01:01:38.000000000 -0700
++++ cpucounters.h 2015-12-14 14:45:07.000000000 -0700
+@@ -709,6 +709,8 @@
+ HASWELLX = 63,
+ BROADWELL = 61,
+ BROADWELL_XEON_E3 = 71,
++ BROADWELL_XEON_E5 = 79,
++ BROADWELL_XEON_E7 = 86,
+ BDX_DE = 86,
+ SKL_UY = 78,
+ SKL = 94,